libdwarf is a library to analyze (and even produce) DWARF debugging
information in ELF files.
This commit is contained in:
parent
f2b63b5314
commit
90be6507b5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128639
8 changed files with 115 additions and 0 deletions
|
@ -415,6 +415,7 @@
|
|||
SUBDIR += libdlmalloc
|
||||
SUBDIR += libds
|
||||
SUBDIR += libdsp
|
||||
SUBDIR += libdwarf
|
||||
SUBDIR += libedit
|
||||
SUBDIR += libelf
|
||||
SUBDIR += libevent
|
||||
|
|
35
devel/libdwarf/Makefile
Normal file
35
devel/libdwarf/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: libdwarf
|
||||
# Date created: 11 Feb 2005
|
||||
# Whom: joerg@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libdwarf
|
||||
PORTVERSION= 20041122
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://reality.sgi.com/davea/
|
||||
|
||||
MAINTAINER= joerg@FreeBSD.org
|
||||
COMMENT= A library to analyze DWARF debugging information in ELF files
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libelf.so.0:${PORTSDIR}/devel/libelf
|
||||
|
||||
WRKSRC= ${WRKDIR}/dwarf-${PORTVERSION}/libdwarf
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
PS_FILES= dwarf.v2.ps index.v2.ps libdwarf2.1.ps libdwarf2p.1.ps mips_extensions.ps
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/libdwarf.a ${PREFIX}/lib
|
||||
${INSTALL_DATA} ${WRKSRC}/dwarf.h ${PREFIX}/include
|
||||
${INSTALL_DATA} ${WRKSRC}/libdwarf.h ${PREFIX}/include
|
||||
${MKDIR} ${PREFIX}/share/doc/libdwarf
|
||||
for f in ${PS_FILES}; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$$f ${PREFIX}/share/doc/libdwarf ; \
|
||||
done
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/libdwarf/distinfo
Normal file
2
devel/libdwarf/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (libdwarf-20041122.tar.gz) = f326a50b103ecd9bb7884fd70d7d40cf
|
||||
SIZE (libdwarf-20041122.tar.gz) = 792298
|
11
devel/libdwarf/files/patch-configure
Normal file
11
devel/libdwarf/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig Mon Nov 22 19:20:35 2004
|
||||
+++ configure Sat Feb 12 22:06:36 2005
|
||||
@@ -3255,7 +3255,7 @@
|
||||
|
||||
|
||||
|
||||
-for ac_header in alloca.h elf.h elfaccess.h libelf.h libelf/libelf.h sys/types.h sys/ia64/elf.h
|
||||
+for ac_header in alloca.h elfaccess.h libelf.h libelf/libelf.h sys/types.h sys/ia64/elf.h
|
||||
do
|
||||
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
||||
if eval "test \"\${$as_ac_Header+set}\" = set"; then
|
30
devel/libdwarf/files/patch-malloc.h
Normal file
30
devel/libdwarf/files/patch-malloc.h
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- dwarf_alloc.c.orig Mon Nov 22 19:20:35 2004
|
||||
+++ dwarf_alloc.c Fri Feb 11 22:22:22 2005
|
||||
@@ -41,7 +41,6 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
-#include <malloc.h>
|
||||
|
||||
/*
|
||||
These files are included to get the sizes
|
||||
--- dwarf_init_finish.c.orig Mon Nov 22 19:20:33 2004
|
||||
+++ dwarf_init_finish.c Fri Feb 11 22:22:30 2005
|
||||
@@ -57,7 +57,6 @@
|
||||
#include <sys/types.h>
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
-#include <malloc.h>
|
||||
|
||||
#include "dwarf_incl.h"
|
||||
|
||||
--- dwarf_sort_line.c.orig Mon Nov 22 19:20:35 2004
|
||||
+++ dwarf_sort_line.c Fri Feb 11 22:22:39 2005
|
||||
@@ -43,7 +43,6 @@
|
||||
#ifdef HAVE_ALLOCA_H
|
||||
#include <alloca.h>
|
||||
#endif
|
||||
-#include <malloc.h>
|
||||
|
||||
#define MINIMUM_POSSIBLE_PROLOG_LEN 10 /* 10 is based on */
|
||||
/* the definition of the DWARF2/3 line table prolog.
|
21
devel/libdwarf/files/patch-pro_incl.h
Normal file
21
devel/libdwarf/files/patch-pro_incl.h
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- pro_incl.h.orig Mon Nov 22 19:20:35 2004
|
||||
+++ pro_incl.h Sat Feb 12 22:17:11 2005
|
||||
@@ -38,6 +38,18 @@
|
||||
#ifdef HAVE_ELF_H
|
||||
#include <elf.h>
|
||||
#endif
|
||||
+#ifdef __SGI_FAST_LIBELF
|
||||
+#include <libelf_sgi.h>
|
||||
+#else
|
||||
+#ifdef HAVE_LIBELF_H
|
||||
+#include <libelf.h>
|
||||
+#else
|
||||
+#ifdef HAVE_LIBELF_LIBELF_H
|
||||
+#include <libelf/libelf.h>
|
||||
+#endif
|
||||
+#endif
|
||||
+#endif /* !defined(__SGI_FAST_LIBELF) */
|
||||
+
|
||||
|
||||
/* The target address is given: the place in the source integer
|
||||
is to be determined.
|
6
devel/libdwarf/pkg-descr
Normal file
6
devel/libdwarf/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
The libdwarf library is the base for the dwarfdump utility
|
||||
by the same author. It implements routines to access the
|
||||
DWARF debugging information found in ELF object files.
|
||||
|
||||
WWW: http://reality.sgi.com/davea/
|
||||
Author: David Anderson of SGI
|
9
devel/libdwarf/pkg-plist
Normal file
9
devel/libdwarf/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
include/dwarf.h
|
||||
include/libdwarf.h
|
||||
lib/libdwarf.a
|
||||
share/doc/libdwarf/dwarf.v2.ps
|
||||
share/doc/libdwarf/index.v2.ps
|
||||
share/doc/libdwarf/libdwarf2.1.ps
|
||||
share/doc/libdwarf/libdwarf2p.1.ps
|
||||
share/doc/libdwarf/mips_extensions.ps
|
||||
@dirrm share/doc/libdwarf
|
Loading…
Reference in a new issue