- Fix build

This commit is contained in:
Wen Heping 2015-01-23 15:40:25 +00:00
parent 9436ce76ac
commit 9102a9c892
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=377744
2 changed files with 21 additions and 7 deletions

View file

@ -24,12 +24,6 @@ HAM_DOCS= README INSTALL ChangeLog TODO AUTHORS CREDITS
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1000000
BROKEN= does not build on FreeBSD < 10
.endif
post-patch:
${REINPLACE_CMD} -e 's#-ldl##g' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's#-ldl##g' ${WRKSRC}/unittests/Makefile.in
@ -41,4 +35,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}/
.endfor
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,20 @@
--- src/1os/os_posix.cc.orig 2015-01-23 22:50:40.837448364 +0800
+++ src/1os/os_posix.cc 2015-01-23 22:51:34.327606541 +0800
@@ -277,7 +277,7 @@
throw Exception(HAM_IO_ERROR);
}
-uint64_t
+size_t
File::tell()
{
uint64_t offset = lseek(m_fd, 0, SEEK_CUR);
@@ -287,7 +287,7 @@
return (offset);
}
-uint64_t
+size_t
File::get_file_size()
{
seek(0, kSeekEnd);