Unbreak with new GCC by fixing bad C++ code.

PR:		77809
Submitted by:	self
Approved by:	maintainer timeout (2 months)
This commit is contained in:
Eric Anholt 2005-04-23 21:06:40 +00:00
parent 12aad6f2be
commit 912a0e2310
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=134020
12 changed files with 197 additions and 4 deletions

View file

@ -25,10 +25,6 @@ MAN6= pipenightdreams.6
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
post-patch:
${REINPLACE_CMD} 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g; \
s|SDL_LIBSS|SDL_LIBS|g; s|datadir/games|datadir|;' \

View file

@ -0,0 +1,11 @@
--- src/eventmanager.cpp.orig Sat Jan 1 14:52:51 2005
+++ src/eventmanager.cpp Sat Jan 1 14:52:55 2005
@@ -40,7 +40,7 @@
lista_streams->remove(lista_streams->indexOf(s));
}
-void EventManager::pumpEvents(bool wait=false){
+void EventManager::pumpEvents(bool wait){
SDL_Event event;
Index * stream;
bool got=false;

View file

@ -0,0 +1,25 @@
--- src/graphic.cpp.orig Sat Jan 1 14:51:18 2005
+++ src/graphic.cpp Sat Jan 1 14:52:31 2005
@@ -44,11 +44,11 @@
if (pixels) free(pixels);
}
-void Graphic::setAlpha(char value=OPAQUE){
+void Graphic::setAlpha(char value){
SDL_SetAlpha(surface, SDL_SRCALPHA, value);
}
-void Graphic::enableClipping(bool flag=true){
+void Graphic::enableClipping(bool flag){
if (flag){
SDL_Rect rect;
@@ -68,7 +68,7 @@
clip_height=height;
}
-void Graphic::flip(Axis a=HAxis){
+void Graphic::flip(Axis a){
if (surface){
if (SDL_MUSTLOCK(surface))
if (SDL_LockSurface(surface)<0) return;

View file

@ -0,0 +1,35 @@
--- src/hash.cpp.orig Sat Jan 1 14:48:35 2005
+++ src/hash.cpp Sat Jan 1 14:50:49 2005
@@ -55,10 +55,12 @@
return(sum % nbuckets);
}
-Hash::Hash(int bs=256){
+typedef List *ListPtr;
+
+Hash::Hash(int bs){
int i;
nbuckets=bs;
- lbuckets=new (List *)[nbuckets];
+ lbuckets=new ListPtr[nbuckets];
for (i=0;i<nbuckets;i++)
lbuckets[i]=new List();
@@ -99,7 +101,7 @@
return NotAdded;
}
-Hash::Result Hash::remove(Str * str, bool del=false){
+Hash::Result Hash::remove(Str * str, bool del){
if (str){
Index * i;
List * list=lbuckets[function(str)];
@@ -135,7 +137,7 @@
return NULL;
}
-void Hash::empty(bool del=true){
+void Hash::empty(bool del){
int i;
List * list;
for (i=0;i<nbuckets;i++){

View file

@ -0,0 +1,11 @@
--- src/image.cpp.orig Sat Jan 1 14:47:18 2005
+++ src/image.cpp Sat Jan 1 14:47:24 2005
@@ -19,7 +19,7 @@
#include "SDL_image.h"
#include <stdio.h>
-Image::Image(Str * filename=NULL):Graphic(){
+Image::Image(Str * filename):Graphic(){
if (filename) load(filename);
}

View file

@ -0,0 +1,20 @@
--- src/list.cpp.orig Sat Jan 1 14:45:36 2005
+++ src/list.cpp Sat Jan 1 14:47:10 2005
@@ -125,7 +125,7 @@
return (insert(indexOf(i), obj));
}
-List::Result List::remove(Index * index, bool del=false){
+List::Result List::remove(Index * index, bool del){
if (isEmpty()) return EmptyList;
if (!index) return NullIndex;
@@ -155,7 +155,7 @@
return Removed;
}
-void List::empty(bool del=true){
+void List::empty(bool del){
while (!isEmpty())
remove(getFirst(), del);
}

View file

@ -0,0 +1,16 @@
--- src/pipe.cpp.orig Sat Jan 1 14:45:09 2005
+++ src/pipe.cpp Sat Jan 1 14:45:19 2005
@@ -43,11 +43,11 @@
return !(full_level>0) && !fixed;
}
-void Pipe::setFixed(bool flag=true){
+void Pipe::setFixed(bool flag){
fixed=flag;
}
-void Pipe::setBonus(Bonus bonus=NormalBonus){
+void Pipe::setBonus(Bonus bonus){
this->bonus=bonus;
}

View file

@ -0,0 +1,13 @@
--- src/player.h.orig Sat Apr 23 14:01:47 2005
+++ src/player.h Sat Apr 23 14:01:49 2005
@@ -47,8 +47,8 @@
void setStartRowColumn(int row, int column);
void setBoard(Board * bd);
- inline void setRestrictionCoef(unsigned int coef);
- inline void setFixedCoef(unsigned int coef);
+ void setRestrictionCoef(unsigned int coef);
+ void setFixedCoef(unsigned int coef);
void incLives();
void decLives();

View file

@ -0,0 +1,11 @@
--- src/pointer.cpp.orig Sat Jan 1 14:44:34 2005
+++ src/pointer.cpp Sat Jan 1 14:44:44 2005
@@ -17,7 +17,7 @@
#include "pointer.h"
-Pointer::Pointer(int row=0, int column=0){
+Pointer::Pointer(int row, int column){
this->row=row;
this->column=column;
this->moved_flag=true;

View file

@ -0,0 +1,15 @@
--- src/pointer.h.orig Sat Jan 1 14:55:27 2005
+++ src/pointer.h Sat Jan 1 14:56:09 2005
@@ -45,9 +45,9 @@
inline void setRow(int row);
inline void setColumn(int column);
- inline void setRowColumn(int row, int column);
- inline void setMoved(bool flag);
- inline bool moved();
+ void setRowColumn(int row, int column);
+ void setMoved(bool flag);
+ bool moved();
Str * image_name;
Image * ima;

View file

@ -0,0 +1,11 @@
--- src/score.cpp.orig Sat Jan 1 14:44:00 2005
+++ src/score.cpp Sat Jan 1 14:44:07 2005
@@ -18,7 +18,7 @@
#include "score.h"
#include <math.h>
-Score::Score(int value=0){
+Score::Score(int value){
this->value=value;
delta=0;
changed=true;

View file

@ -0,0 +1,29 @@
--- src/str.cpp.orig Sat Jan 1 14:43:20 2005
+++ src/str.cpp Sat Jan 1 14:43:25 2005
@@ -11,7 +11,7 @@
const char Str::nul = '\0';
-Str::Str(const char * string=NULL){
+Str::Str(const char * string){
s=NULL;
set(string);
}
@@ -25,7 +25,7 @@
if (s) delete[] s;
}
-void Str::set(const char * string=NULL){
+void Str::set(const char * string){
if (s) delete[] s;
if (string){
s=new char[strlen(string)+1];
@@ -71,7 +71,7 @@
return (strlen(s));
}
-bool Str::isEqual(Str * str, bool case_sensitive = true){
+bool Str::isEqual(Str * str, bool case_sensitive){
if (case_sensitive){
return (!strcmp(s, str->s));
}