Update to V 1b4. Also fixes fetching.
This commit is contained in:
parent
7f61aba396
commit
916b38493e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128862
8 changed files with 84 additions and 84 deletions
|
@ -6,11 +6,11 @@
|
|||
#
|
||||
|
||||
PORTNAME= jacal
|
||||
PORTVERSION= 1b2
|
||||
PORTVERSION= 1b4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://swissnet.ai.mit.edu/ftpdir/scm/
|
||||
DISTNAME= jacal1b2
|
||||
DISTNAME= jacal1b4
|
||||
|
||||
MAINTAINER= markm@FreeBSD.org
|
||||
COMMENT= Symbolic mathematics program written in Scheme
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (jacal1b2.zip) = e2cf04a72082a50365dec5fc140e3fb1
|
||||
SIZE (jacal1b2.zip) = 191825
|
||||
MD5 (jacal1b4.zip) = 2d4adac18d44ccb6e67a6b84a646012c
|
||||
SIZE (jacal1b4.zip) = 244102
|
||||
|
|
11
math/jacal/files/patch-Makefile
Normal file
11
math/jacal/files/patch-Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./Makefile.orig Mon Dec 1 04:55:13 2003
|
||||
+++ ./Makefile Mon Feb 14 21:44:19 2005
|
||||
@@ -37,7 +37,7 @@
|
||||
RELEASE = 1
|
||||
|
||||
rpm_prefix=/usr/src/redhat/
|
||||
-prefix = /usr/local/
|
||||
+prefix = %%PREFIX%%/
|
||||
exec_prefix = $(prefix)
|
||||
# directory where `make install' will put executable.
|
||||
bindir = $(exec_prefix)bin/
|
|
@ -1,56 +0,0 @@
|
|||
diff -udr ../jacal.ORIG/Makefile ./Makefile
|
||||
--- ../jacal.ORIG/Makefile Thu Feb 21 00:46:31 2002
|
||||
+++ ./Makefile Sat Mar 16 13:11:15 2002
|
||||
@@ -24,7 +24,7 @@
|
||||
RELEASE = 1
|
||||
|
||||
rpm_prefix=/usr/src/redhat/
|
||||
-prefix = /usr/local/
|
||||
+prefix = %%PREFIX%%/
|
||||
exec_prefix = $(prefix)
|
||||
# directory where `make install' will put executable.
|
||||
bindir = $(exec_prefix)bin/
|
||||
diff -udr ../jacal.ORIG/jacal.info ./jacal.info
|
||||
--- ../jacal.ORIG/jacal.info Thu Feb 21 00:47:50 2002
|
||||
+++ ./jacal.info Sat Mar 16 13:11:28 2002
|
||||
@@ -213,9 +213,9 @@
|
||||
This may involve setting up that implementation's initialization file or |
|
||||
LOADing a `.init' file from the `slib' directory. Then type: |
|
||||
|
|
||||
- (slib:load "/usr/local/lib/jacal/math") |
|
||||
+ (slib:load "%%PREFIX%%/lib/jacal/math") |
|
||||
|
|
||||
-where `/usr/local/lib/jacal/' is a path to the JACAL directory. JACAL |
|
||||
+where `%%PREFIX%%/lib/jacal/' is a path to the JACAL directory. JACAL |
|
||||
should then print: |
|
||||
|
|
||||
JACAL version 1b2, Copyright 1989-1999, 2002 Aubrey Jaffer |
|
||||
diff -udr ../jacal.ORIG/jacal.sh ./jacal.sh
|
||||
--- ../jacal.ORIG/jacal.sh Fri Feb 15 04:19:32 2002
|
||||
+++ ./jacal.sh Sat Mar 16 13:13:18 2002
|
||||
@@ -62,6 +62,8 @@
|
||||
if [ -z "${SCHEME_LIBRARY_PATH}" ]; then
|
||||
if [ -d /usr/local/lib/slib/ ]; then
|
||||
export SCHEME_LIBRARY_PATH=/usr/local/lib/slib/
|
||||
+ elif [ -d %%PREFIX%%/lib/slib/ ]; then
|
||||
+ export SCHEME_LIBRARY_PATH=%%PREFIX%%/lib/slib/
|
||||
elif [ -d /usr/share/slib/ ]; then
|
||||
export SCHEME_LIBRARY_PATH=/usr/share/slib/
|
||||
fi
|
||||
diff -udr ../jacal.ORIG/jacal.texi ./jacal.texi
|
||||
--- ../jacal.ORIG/jacal.texi Mon Feb 18 05:37:53 2002
|
||||
+++ ./jacal.texi Sat Mar 16 13:12:04 2002
|
||||
@@ -344,11 +344,11 @@
|
||||
LOADing a @samp{.init} file from the @file{slib} directory. Then type:
|
||||
|
||||
@example
|
||||
-(slib:load "/usr/local/lib/jacal/math")
|
||||
+(slib:load "%%PREFIX%%/lib/jacal/math")
|
||||
@end example
|
||||
|
||||
@noindent
|
||||
-where @file{/usr/local/lib/jacal/} is a path to the JACAL directory.
|
||||
+where @file{%%PREFIX%%/lib/jacal/} is a path to the JACAL directory.
|
||||
JACAL should then print:
|
||||
|
||||
@example
|
14
math/jacal/files/patch-jacal.info
Normal file
14
math/jacal/files/patch-jacal.info
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- ./jacal.info.orig Mon Dec 1 04:55:18 2003
|
||||
+++ ./jacal.info Mon Feb 14 21:46:12 2005
|
||||
@@ -213,9 +213,9 @@
|
||||
This may involve setting up that implementation's initialization file or
|
||||
LOADing a `.init' file from the `slib' directory. Then type:
|
||||
|
||||
- (slib:load "/usr/local/lib/jacal/math")
|
||||
+ (slib:load "%%PREFIX%%/lib/jacal/math")
|
||||
|
||||
-where `/usr/local/lib/jacal/' is a path to the JACAL directory. JACAL
|
||||
+where `%%PREFIX%%/lib/jacal/' is a path to the JACAL directory. JACAL
|
||||
should then print:
|
||||
|
||||
JACAL version 1b4, Copyright 1989-1999, 2002 Aubrey Jaffer |
|
11
math/jacal/files/patch-jacal.sh
Normal file
11
math/jacal/files/patch-jacal.sh
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./jacal.sh.orig Mon Dec 1 04:19:32 2003
|
||||
+++ ./jacal.sh Mon Feb 14 21:44:19 2005
|
||||
@@ -92,6 +92,8 @@
|
||||
if [ -z "${SCHEME_LIBRARY_PATH}" ]; then
|
||||
if [ -d /usr/local/lib/slib/ ]; then
|
||||
export SCHEME_LIBRARY_PATH=/usr/local/lib/slib/
|
||||
+ elif [ -d %%PREFIX%%/lib/slib/ ]; then
|
||||
+ export SCHEME_LIBRARY_PATH=%%PREFIX%%/lib/slib/
|
||||
elif [ -d /usr/share/slib/ ]; then
|
||||
export SCHEME_LIBRARY_PATH=/usr/share/slib/
|
||||
fi
|
16
math/jacal/files/patch-jacal.texi
Normal file
16
math/jacal/files/patch-jacal.texi
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- ./jacal.texi.orig Sun Nov 30 22:29:33 2003
|
||||
+++ ./jacal.texi Mon Feb 14 21:44:19 2005
|
||||
@@ -344,11 +344,11 @@
|
||||
LOADing a @samp{.init} file from the @file{slib} directory. Then type:
|
||||
|
||||
@example
|
||||
-(slib:load "/usr/local/lib/jacal/math")
|
||||
+(slib:load "%%PREFIX%%/lib/jacal/math")
|
||||
@end example
|
||||
|
||||
@noindent
|
||||
-where @file{/usr/local/lib/jacal/} is a path to the JACAL directory.
|
||||
+where @file{%%PREFIX%%/lib/jacal/} is a path to the JACAL directory.
|
||||
JACAL should then print:
|
||||
|
||||
@example
|
|
@ -1,31 +1,35 @@
|
|||
bin/jacal
|
||||
lib/jacal/types.scm
|
||||
lib/jacal/COPYING
|
||||
lib/jacal/Makefile
|
||||
lib/jacal/English.scm
|
||||
lib/jacal/toploads.scm
|
||||
lib/jacal/view.scm
|
||||
lib/jacal/debug.scm
|
||||
lib/jacal/modeinit.scm
|
||||
lib/jacal/math.scm
|
||||
lib/jacal/scl.scm
|
||||
lib/jacal/hensel.scm
|
||||
lib/jacal/combin.scm
|
||||
lib/jacal/ff.scm
|
||||
lib/jacal/tensor.scm
|
||||
lib/jacal/info.scm
|
||||
lib/jacal/builtin.scm
|
||||
lib/jacal/unparse.scm
|
||||
lib/jacal/grammar.scm
|
||||
lib/jacal/sexp.scm
|
||||
lib/jacal/hist.scm
|
||||
lib/jacal/norm.scm
|
||||
lib/jacal/ext.scm
|
||||
lib/jacal/vect.scm
|
||||
lib/jacal/elim.scm
|
||||
lib/jacal/HELP
|
||||
lib/jacal/poly.scm
|
||||
lib/jacal/Makefile
|
||||
lib/jacal/builtin.scm
|
||||
lib/jacal/combin.scm
|
||||
lib/jacal/debug.scm
|
||||
lib/jacal/elim.scm
|
||||
lib/jacal/ext.scm
|
||||
lib/jacal/factors.scm
|
||||
lib/jacal/ff.scm
|
||||
lib/jacal/func.scm
|
||||
lib/jacal/guile.scm
|
||||
lib/jacal/go.scm
|
||||
lib/jacal/grammar.scm
|
||||
lib/jacal/guile.scm
|
||||
lib/jacal/hensel.scm
|
||||
lib/jacal/hist.scm
|
||||
lib/jacal/info.scm
|
||||
lib/jacal/jacalcat
|
||||
lib/jacal/math.scm
|
||||
lib/jacal/modeinit.scm
|
||||
lib/jacal/norm.scm
|
||||
lib/jacal/poly.scm
|
||||
lib/jacal/scl.scm
|
||||
lib/jacal/sexp.scm
|
||||
lib/jacal/sqfree.scm
|
||||
lib/jacal/tensor.scm
|
||||
lib/jacal/toploads.scm
|
||||
lib/jacal/types.scm
|
||||
lib/jacal/unparse.scm
|
||||
lib/jacal/uv-hensel.scm
|
||||
lib/jacal/vect.scm
|
||||
lib/jacal/view.scm
|
||||
@dirrm lib/jacal
|
||||
|
|
Loading…
Reference in a new issue