GUI app launcher with completion and history
PR: 9939 Submitted by: stephen farrell <sfarrell@healthquiz.com>
This commit is contained in:
parent
c9df971f88
commit
917a015b1a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=18147
6 changed files with 57 additions and 0 deletions
36
misc/tkrunit/Makefile
Normal file
36
misc/tkrunit/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
|||
# New ports collection makefile for: tkrunnit
|
||||
# Version required: 0.94.1
|
||||
# Date created: 6 February, 1999
|
||||
# Whom: Stephen Farrell <steve@farrell.org>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= tkRunIt-0941
|
||||
PKGNAME= tkRunIt-0.94.1
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www.cs.columbia.edu/~etgold/software/tkRunIt/
|
||||
|
||||
MAINTAINER= steve@farrell.org
|
||||
|
||||
RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
post-extract:
|
||||
@(cd ${WRKDIR} ; ${MV} tkRunIt ${DISTNAME})
|
||||
|
||||
do-install:
|
||||
@(cd ${WRKSRC} ; ${INSTALL_SCRIPT} runit.tcl ${PREFIX}/bin)
|
||||
|
||||
post-install:
|
||||
@${ECHO} " "
|
||||
@${ECHO} "-------------------------------------------------------------------"
|
||||
@${ECHO} "===> Installing runitrc.sample in ${PREFIX}/share/examples/tkrunit"
|
||||
@${ECHO} "===> Copy runitrc.sample to ~/.runitrc and modify if you wish"
|
||||
@${ECHO} "-------------------------------------------------------------------"
|
||||
@${ECHO} " "
|
||||
@${MKDIR} ${PREFIX}/share/examples/tkrunit && chmod a+rx ${PREFIX}/share/examples/tkrunit
|
||||
@${INSTALL_DATA} ${WRKSRC}/runitrc.sample ${PREFIX}/share/examples/tkrunit
|
||||
|
||||
.include <bsd.port.mk>
|
1
misc/tkrunit/distinfo
Normal file
1
misc/tkrunit/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (tkRunIt-0941.tar.gz) = 350ed155295f8ae81519c2215aadc72c
|
10
misc/tkrunit/files/patch-aa
Normal file
10
misc/tkrunit/files/patch-aa
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- runit.tcl.bak Tue Apr 27 11:48:06 1999
|
||||
+++ runit.tcl Tue Apr 27 11:48:06 1999
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/sh
|
||||
# the next line restarts using wish \
|
||||
- exec wish "$0" "$@"
|
||||
+ exec wish8.0 "$0" "$@"
|
||||
|
||||
#!/usr/local/bin/wish
|
||||
## runit (tkRunIt) 12/4/98
|
1
misc/tkrunit/pkg-comment
Normal file
1
misc/tkrunit/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
GUI app launcher with completion and history
|
6
misc/tkrunit/pkg-descr
Normal file
6
misc/tkrunit/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
tkRunIt is a run dialog box for X which allows you to execute
|
||||
commandline without using an xterm. tkRunIt was inspired by Xrun
|
||||
but is designed to be completely navigable from the keyboard and
|
||||
to allow extreme customizablility as I often find that personal
|
||||
workspace tools/shortcuts are seldom workflow compatible across
|
||||
users.
|
3
misc/tkrunit/pkg-plist
Normal file
3
misc/tkrunit/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/runit.tcl
|
||||
share/examples/tkrunit/runitrc.sample
|
||||
@dirrm share/examples/tkrunit
|
Loading…
Reference in a new issue