Say goodbuy to gtk13/glib13 - it was replaced with gtk20 (after a repo-copy of

course).

Special thanks to:	cvs (for extremely fast repo-copying)
This commit is contained in:
Maxim Sobolev 2002-03-11 20:44:36 +00:00
parent 39ab963267
commit 91829143b8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55885
26 changed files with 0 additions and 867 deletions

View file

@ -175,7 +175,6 @@
SUBDIR += glade--
SUBDIR += glg
SUBDIR += glib12
SUBDIR += glib13
SUBDIR += glib20
SUBDIR += global
SUBDIR += glui

View file

@ -1,46 +0,0 @@
# New ports collection makefile for: glib13
# Date Created: 28 July 1998
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= glib
PORTVERSION= 1.3.14
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,pre-gnome2/releases/gnome-2.0-desktop-beta,} \
ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
http://www.ameth.org/gimp/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/gimp/%SUBDIR%,}
MASTER_SITE_SUBDIR= gtk/v${PORTVERSION:R}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv \
intl.1:${PORTSDIR}/devel/gettext
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
NO_LATEST_LINK= "Unstable, development version."
USE_BZIP2= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= glib-genmarshal.1 glib-mkenums.1
pre-patch:
@find ${WRKSRC} -type f | xargs ${GREP} -l iconv.h | \
xargs ${PERL} -pi -e "s|iconv\.h|giconv.h|g"
@find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
.include <bsd.port.mk>

View file

@ -1 +0,0 @@
MD5 (gnome2/glib-1.3.14.tar.bz2) = 8bf2f7584928ce5edef30542ee9407d7

View file

@ -1,59 +0,0 @@
$FreeBSD$
--- configure.orig Fri Feb 15 18:43:40 2002
+++ configure Wed Feb 27 09:37:41 2002
@@ -16692,8 +16692,8 @@
rm -f conftest.$ac_objext conftest.$ac_ext
fi
;;
- *-freebsd2.2*)
- G_THREAD_CFLAGS="$G_THREAD_CFLAGS -D_THREAD_SAFE"
+ *-freebsd*)
+ G_THREAD_CFLAGS="$G_THREAD_CFLAGS $PTHREAD_CFLAGS"
# FreeBSD 2.2.x shiped with gcc 2.7.2.x, which doesn't support
# -mthreads flag.
@@ -16771,13 +16771,13 @@
fi
;;
*)
- for thread_lib in "" pthread pthread32 pthreads c_r thread dce; do
+ for thread_lib in "$PTHREAD_LIBS" "" pthread pthread32 pthreads c_r thread dce; do
if test x"$thread_lib" = x; then
add_thread_lib=""
IN=""
else
- add_thread_lib="-l$thread_lib"
- IN=" in -l$thread_lib"
+ add_thread_lib="$thread_lib"
+ IN=" in $thread_lib"
fi
if test x"$have_threads" = xposix; then
defattr=0
@@ -17974,13 +17974,13 @@
#
# Check for libiconv
#
- echo "$as_me:17977: checking for libiconv_open in -liconv" >&5
-echo $ECHO_N "checking for libiconv_open in -liconv... $ECHO_C" >&6
+ echo "$as_me:17977: checking for libiconv_open in -lgiconv" >&5
+echo $ECHO_N "checking for libiconv_open in -lgiconv... $ECHO_C" >&6
if test "${ac_cv_lib_iconv_libiconv_open+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-liconv $LIBS"
+LIBS="-lgiconv $LIBS"
cat >conftest.$ac_ext <<_ACEOF
#line 17985 "configure"
#include "confdefs.h"
@@ -18042,7 +18042,7 @@
fi
if test "x$with_libiconv" = "xyes" ; then
- ICONV_LIBS="-liconv"
+ ICONV_LIBS="-lgiconv"
cat >>confdefs.h <<\_ACEOF
#define USE_LIBICONV 1
_ACEOF

View file

@ -1,14 +0,0 @@
--- Makefile.in.orig Sun Dec 23 16:53:53 2001
+++ Makefile.in Fri Feb 8 12:44:30 2002
@@ -151,3 +151,3 @@
-SUBDIRS = . m4macros glib gobject gmodule gthread tests build po docs
+SUBDIRS = . m4macros glib gobject gmodule gthread build po docs
@@ -192,4 +192,4 @@
-
-configexecincludedir = $(libdir)/glib-2.0/include
+glibincludedir = $(includedir)/glib-2.0
+configexecincludedir = $(glibincludedir)

View file

@ -1,11 +0,0 @@
--- docs/reference/Makefile.in 2000/11/20 09:49:25 1.1
+++ docs/reference/Makefile.in 2000/11/20 09:50:55
@@ -106,7 +106,7 @@
STRIP_END = @STRIP_END@
VERSION = @VERSION@
-SUBDIRS = glib gobject
+SUBDIRS = #glib gobject
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../config.h
CONFIG_CLEAN_FILES =

View file

@ -1,25 +0,0 @@
$FreeBSD$
--- glib/libcharset/Makefile.in 2002/01/18 08:04:15 1.1
+++ glib/libcharset/Makefile.in 2002/01/18 08:13:49
@@ -148,7 +148,7 @@
ms_librarian = @ms_librarian@
INCLUDES = \
- -DLIBDIR=\"$(libdir)\"
+ -DLIBDIR=\"$(prefix)/libdata\"
noinst_LTLIBRARIES = libcharset.la
@@ -172,8 +172,8 @@
make-patch.sh
-charset_alias = $(DESTDIR)$(libdir)/charset.alias
-charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
+charset_alias = $(DESTDIR)$(prefix)/libdata/charset.alias
+charset_tmp = $(DESTDIR)$(prefix)/libdata/charset.tmp
SUFFIXES = .sed .sin

View file

@ -1,23 +0,0 @@
$FreeBSD$
--- gmodule/gmodule-dl.c.orig Sat Feb 17 08:28:07 2001
+++ gmodule/gmodule-dl.c Fri Jan 18 09:48:45 2002
@@ -104,6 +104,7 @@
static gpointer
_g_module_self (void)
{
+#ifndef __FreeBSD__
gpointer handle;
/* to query symbols from the program itself, special link options
@@ -115,6 +116,9 @@
g_module_set_error (fetch_dlerror (TRUE));
return handle;
+#else
+ return RTLD_DEFAULT;
+#endif
}
static void

View file

@ -1,45 +0,0 @@
$FreeBSD$
--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
+++ ltmain.sh Sun Feb 3 01:44:17 2002
@@ -1037,8 +1037,16 @@
continue
;;
+ -pthread)
+ compile_command="$compile_command -pthread"
+ finalize_command="$finalize_command -pthread"
+ compiler_flags="$compiler_flags -pthread"
+ continue
+ ;;
+
-module)
module=yes
+ build_old_libs=no
continue
;;
@@ -2412,6 +2420,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4179,10 +4190,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -1 +0,0 @@
Some useful routines of C programming (unstable development version)

View file

@ -1,14 +0,0 @@
This is GLib version 1.3. GLib, is a library which includes support
routines for C such as lists, trees, hashes, memory allocation, and
many other things.
WWW: http://www.gtk.org/
ftp://ftp.gtk.org/pub/gtk
A mailing list is located at gtk-list@redhat.com for discussion.
Warning: this library is unstable development version, incompatible with
version 1.2, so it could not be used as a replacement for the older one.
- Vanilla
vanilla@FreeBSD.ORG

View file

@ -1,117 +0,0 @@
bin/glib-genmarshal
bin/glib-gettextize
bin/glib-mkenums
bin/gobject-query
include/glib-2.0/glib-object.h
include/glib-2.0/glib.h
include/glib-2.0/glib/galloca.h
include/glib-2.0/glib/garray.h
include/glib-2.0/glib/gasyncqueue.h
include/glib-2.0/glib/gbacktrace.h
include/glib-2.0/glib/gcache.h
include/glib-2.0/glib/gcompletion.h
include/glib-2.0/glib/gconvert.h
include/glib-2.0/glib/gdataset.h
include/glib-2.0/glib/gdate.h
include/glib-2.0/glib/gdir.h
include/glib-2.0/glib/gerror.h
include/glib-2.0/glib/gfileutils.h
include/glib-2.0/glib/ghash.h
include/glib-2.0/glib/ghook.h
include/glib-2.0/glib/giochannel.h
include/glib-2.0/glib/glist.h
include/glib-2.0/glib/gmacros.h
include/glib-2.0/glib/gmain.h
include/glib-2.0/glib/gmarkup.h
include/glib-2.0/glib/gmem.h
include/glib-2.0/glib/gmessages.h
include/glib-2.0/glib/gnode.h
include/glib-2.0/glib/gpattern.h
include/glib-2.0/glib/gprimes.h
include/glib-2.0/glib/gqsort.h
include/glib-2.0/glib/gquark.h
include/glib-2.0/glib/gqueue.h
include/glib-2.0/glib/grand.h
include/glib-2.0/glib/grel.h
include/glib-2.0/glib/gscanner.h
include/glib-2.0/glib/gshell.h
include/glib-2.0/glib/gslist.h
include/glib-2.0/glib/gspawn.h
include/glib-2.0/glib/gstrfuncs.h
include/glib-2.0/glib/gstring.h
include/glib-2.0/glib/gthread.h
include/glib-2.0/glib/gthreadpool.h
include/glib-2.0/glib/gtimer.h
include/glib-2.0/glib/gtree.h
include/glib-2.0/glib/gtypes.h
include/glib-2.0/glib/gunicode.h
include/glib-2.0/glib/gutils.h
include/glib-2.0/glib/gwin32.h
include/glib-2.0/glibconfig.h
include/glib-2.0/gmodule.h
include/glib-2.0/gobject/gboxed.h
include/glib-2.0/gobject/gclosure.h
include/glib-2.0/gobject/genums.h
include/glib-2.0/gobject/gmarshal.h
include/glib-2.0/gobject/gobject.h
include/glib-2.0/gobject/gobjectnotifyqueue.c
include/glib-2.0/gobject/gparam.h
include/glib-2.0/gobject/gparamspecs.h
include/glib-2.0/gobject/gsignal.h
include/glib-2.0/gobject/gsourceclosure.h
include/glib-2.0/gobject/gtype.h
include/glib-2.0/gobject/gtypemodule.h
include/glib-2.0/gobject/gtypeplugin.h
include/glib-2.0/gobject/gvalue.h
include/glib-2.0/gobject/gvaluearray.h
include/glib-2.0/gobject/gvaluecollector.h
include/glib-2.0/gobject/gvaluetypes.h
lib/libglib-1.3.a
lib/libglib-1.3.so
lib/libglib-1.3.so.14
lib/libgmodule-1.3.a
lib/libgmodule-1.3.so
lib/libgmodule-1.3.so.14
lib/libgobject-1.3.a
lib/libgobject-1.3.so
lib/libgobject-1.3.so.14
lib/libgthread-1.3.a
lib/libgthread-1.3.so
lib/libgthread-1.3.so.14
libdata/pkgconfig/glib-2.0.pc
libdata/pkgconfig/gmodule-2.0.pc
libdata/pkgconfig/gobject-2.0.pc
libdata/pkgconfig/gthread-2.0.pc
share/aclocal/glib-2.0.m4
share/aclocal/glib-gettext.m4
share/glib-2.0/gettext/po/Makefile.in.in
share/locale/az/LC_MESSAGES/glib20.mo
share/locale/ca/LC_MESSAGES/glib20.mo
share/locale/de/LC_MESSAGES/glib20.mo
share/locale/es/LC_MESSAGES/glib20.mo
share/locale/eu/LC_MESSAGES/glib20.mo
share/locale/fr/LC_MESSAGES/glib20.mo
share/locale/gl/LC_MESSAGES/glib20.mo
share/locale/ja/LC_MESSAGES/glib20.mo
share/locale/ko/LC_MESSAGES/glib20.mo
share/locale/nl/LC_MESSAGES/glib20.mo
share/locale/nn/LC_MESSAGES/glib20.mo
share/locale/no/LC_MESSAGES/glib20.mo
share/locale/pl/LC_MESSAGES/glib20.mo
share/locale/pt/LC_MESSAGES/glib20.mo
share/locale/ro/LC_MESSAGES/glib20.mo
share/locale/ru/LC_MESSAGES/glib20.mo
share/locale/sk/LC_MESSAGES/glib20.mo
share/locale/sl/LC_MESSAGES/glib20.mo
share/locale/sv/LC_MESSAGES/glib20.mo
share/locale/ta/LC_MESSAGES/glib20.mo
share/locale/tr/LC_MESSAGES/glib20.mo
share/locale/uk/LC_MESSAGES/glib20.mo
share/locale/zh_CN/LC_MESSAGES/glib20.mo
share/locale/zh_TW/LC_MESSAGES/glib20.mo
@dirrm share/glib-2.0/gettext/po
@dirrm share/glib-2.0/gettext
@dirrm share/glib-2.0
@dirrm include/glib-2.0/gobject
@dirrm include/glib-2.0/glib
@dirrm include/glib-2.0

View file

@ -37,7 +37,6 @@
SUBDIR += gtk-zenith-theme
SUBDIR += gtk12
SUBDIR += gtk12-apireference
SUBDIR += gtk13
SUBDIR += gtk20
SUBDIR += gtkada
SUBDIR += gtkbe

View file

@ -1,52 +0,0 @@
# New ports collection makefile for: gtk13
# Date Created: 28 Sep 1997
# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
#
# $FreeBSD$
#
PORTNAME= gtk
PORTVERSION= 1.3.14
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,pre-gnome2/releases/gnome-2.0-desktop-beta,} \
ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
http://www.ameth.org/gimp/%SUBDIR%/ \
ftp://ftp.mirror.ac.uk/sites/ftp.gimp.org/pub/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/gimp/%SUBDIR%,}
MASTER_SITE_SUBDIR= gtk/v${PORTVERSION:R}
DISTNAME= gtk+-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= atk.12:${PORTSDIR}/devel/atk \
pango.0:${PORTSDIR}/x11-toolkits/pango \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg
USE_BZIP2= yes
NO_LATEST_LINK= "Unstable, development version."
USE_X_PREFIX= yes
USE_XPM= yes
USE_PERL5= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= GTK_VERSION="${PORTVERSION}"
MAN1= gdk-pixbuf-csource.1
post-extract:
@find ${WRKSRC} -name "Makefile.in" | xargs ${GREP} -l lgmodule | \
xargs ${PERL} -pi -e 's|-lgmodule|\@GMODULE_LIBS\@|g'
@find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
pre-build:
${RM} -rf ${WRKSRC}/docs/gtk.info*
.include <bsd.port.mk>

View file

@ -1 +0,0 @@
MD5 (gnome2/gtk+-1.3.14.tar.bz2) = 2f1408386e6d79ea55d2a61494867312

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- Makefile.in 2002/02/12 13:29:11 1.1
+++ Makefile.in 2002/02/12 13:29:28
@@ -168,7 +168,7 @@
ms_librarian = @ms_librarian@
xinput_progs = @xinput_progs@
-SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos tests contrib
+SRC_SUBDIRS = gdk-pixbuf gdk gtk modules contrib
SUBDIRS = po $(SRC_SUBDIRS) docs build m4macros
# require automake 1.4

View file

@ -1,23 +0,0 @@
$FreeBSD$
--- gtk/gtkrc.c.orig Thu Dec 13 21:51:18 2001
+++ gtk/gtkrc.c Fri Jan 18 11:14:14 2002
@@ -336,7 +336,7 @@
if (im_module_file)
result = g_strdup (im_module_file);
else
- result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtk.immodules", NULL);
+ result = g_build_filename (GTK_DATA_PREFIX, "etc", "gtk-2.0", "gtk.immodules", NULL);
}
return result;
@@ -418,7 +418,7 @@
}
else
{
- str = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtkrc", NULL);
+ str = g_build_filename (GTK_SYSCONFDIR, "gtk", NULL);
gtk_rc_add_default_file (str);
g_free (str);

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- configure.orig Wed Jan 30 05:58:27 2002
+++ configure Tue Feb 12 11:19:52 2002
@@ -9783,7 +9783,7 @@
echo "$as_me: failed program was:" >&5
cat conftest.$ac_ext >&5
CATOBJEXT=.mo
- DATADIRNAME=lib
+ DATADIRNAME=share
fi
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
INSTOBJEXT=.mo

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- gtk/Makefile.in.orig Fri Jan 18 11:03:21 2002
+++ gtk/Makefile.in Fri Jan 18 11:18:26 2002
@@ -176,7 +176,7 @@
-DG_LOG_DOMAIN=\"Gtk\" \
-DGTK_LIBDIR=\"$(libdir)\" \
-DGTK_DATA_PREFIX=\"$(prefix)\" \
- -DGTK_SYSCONFDIR=\"$(sysconfdir)\" \
+ -DGTK_SYSCONFDIR=\"$(datadir)/themes/Default/gtk-2.0\" \
-DGTK_LOCALEDIR=\"$(gtklocaledir)\" \
-DGTK_VERSION=\"@GTK_VERSION@\" \
-DGTK_BINARY_VERSION=\"@GTK_BINARY_VERSION@\" \

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- docs/Makefile.in.orig Wed Oct 24 10:33:45 2001
+++ docs/Makefile.in Wed Oct 24 10:33:46 2001
@@ -136,7 +136,7 @@
LT_RELEASE = @LT_RELEASE@
LT_REVISION = @LT_REVISION@
MAINT = @MAINT@
-MAKEINFO = @MAKEINFO@
+MAKEINFO = @MAKEINFO@ --no-split
MKINSTALLDIRS = @MKINSTALLDIRS@
OBJDUMP = @OBJDUMP@
OBJEXT = @OBJEXT@

View file

@ -1,11 +0,0 @@
--- docs/reference/Makefile.in.orig Sat Nov 18 03:17:56 2000
+++ docs/reference/Makefile.in Mon Nov 20 15:33:25 2000
@@ -160,7 +160,7 @@
x_libs = @x_libs@
xinput_progs = @xinput_progs@
-SUBDIRS = gdk-pixbuf gdk gtk
+SUBDIRS =
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../config.h
CONFIG_CLEAN_FILES =

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- gdk/Makefile.in.orig Thu Feb 14 12:38:26 2002
+++ gdk/Makefile.in Thu Feb 14 12:45:37 2002
@@ -315,7 +315,7 @@
#
# Rule to install gdkconfig.h header file
#
-configexecincludedir = $(libdir)/gtk-2.0/include
+configexecincludedir = $(prefix)/include/gtk-2.0
#note: not gdkconfig.h
BUILT_SOURCES = stamp-gc-h @REBUILD@ gdkenumtypes.c gdkenumtypes.h

View file

@ -1,45 +0,0 @@
$FreeBSD$
--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
+++ ltmain.sh Sun Feb 3 01:44:17 2002
@@ -1037,8 +1037,16 @@
continue
;;
+ -pthread)
+ compile_command="$compile_command -pthread"
+ finalize_command="$finalize_command -pthread"
+ compiler_flags="$compiler_flags -pthread"
+ continue
+ ;;
+
-module)
module=yes
+ build_old_libs=no
continue
;;
@@ -2412,6 +2420,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4179,10 +4190,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -1 +0,0 @@
General Toolkit for X11 GUI (unstable development version)

View file

@ -1,19 +0,0 @@
GTK is a library for creating graphical user interfaces similar to
the Motif "look and feel". It is designed to be small and efficient, but
still flexible enough to allow the programmer freedom in the interfaces
created. GTK allows the programmer to use a variety of standard user
interface widgets such as push, radio and check buttons, menus, lists
and frames. It also provides several "container" widgets which can be
used to control the layout of the user interface elements.
GTK provides some unique features. (At least, I know of no other
widget library which provides them). For example, a button does not
contain a label, it contains a child widget, which in most instances
will be a label. However, the child widget can also be a pixmap, image
or any combination possible the programmer desires. This flexibility is
adhered to throughout the library.
Warning: this library is unstable development version, incompatible with
version 1.2, so it could not be used as a replacement for the older one.
WWW: http://www.gtk.org/

View file

@ -1,287 +0,0 @@
bin/gdk-pixbuf-csource
bin/gtk-query-immodules-2.0
etc/gtk-2.0/gtk.immodules
include/gtk-2.0/gdk-pixbuf-xlib/gdk-pixbuf-xlib.h
include/gtk-2.0/gdk-pixbuf-xlib/gdk-pixbuf-xlibrgb.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-enum-types.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-features.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-loader.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-marshal.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf.h
include/gtk-2.0/gdk-pixbuf/gdk-pixdata.h
include/gtk-2.0/gdk/gdk.h
include/gtk-2.0/gdk/gdkcolor.h
include/gtk-2.0/gdk/gdkcursor.h
include/gtk-2.0/gdk/gdkdnd.h
include/gtk-2.0/gdk/gdkdrawable.h
include/gtk-2.0/gdk/gdkenumtypes.h
include/gtk-2.0/gdk/gdkevents.h
include/gtk-2.0/gdk/gdkfont.h
include/gtk-2.0/gdk/gdkgc.h
include/gtk-2.0/gdk/gdki18n.h
include/gtk-2.0/gdk/gdkimage.h
include/gtk-2.0/gdk/gdkinput.h
include/gtk-2.0/gdk/gdkkeys.h
include/gtk-2.0/gdk/gdkkeysyms.h
include/gtk-2.0/gdk/gdkpango.h
include/gtk-2.0/gdk/gdkpixbuf.h
include/gtk-2.0/gdk/gdkpixmap.h
include/gtk-2.0/gdk/gdkprivate.h
include/gtk-2.0/gdk/gdkproperty.h
include/gtk-2.0/gdk/gdkregion.h
include/gtk-2.0/gdk/gdkrgb.h
include/gtk-2.0/gdk/gdkselection.h
include/gtk-2.0/gdk/gdktypes.h
include/gtk-2.0/gdk/gdkvisual.h
include/gtk-2.0/gdk/gdkwindow.h
include/gtk-2.0/gdk/gdkx.h
include/gtk-2.0/gdkconfig.h
include/gtk-2.0/gtk/gtk.h
include/gtk-2.0/gtk/gtkaccelgroup.h
include/gtk-2.0/gtk/gtkaccellabel.h
include/gtk-2.0/gtk/gtkaccelmap.h
include/gtk-2.0/gtk/gtkaccessible.h
include/gtk-2.0/gtk/gtkadjustment.h
include/gtk-2.0/gtk/gtkalignment.h
include/gtk-2.0/gtk/gtkarrow.h
include/gtk-2.0/gtk/gtkaspectframe.h
include/gtk-2.0/gtk/gtkbbox.h
include/gtk-2.0/gtk/gtkbin.h
include/gtk-2.0/gtk/gtkbindings.h
include/gtk-2.0/gtk/gtkbox.h
include/gtk-2.0/gtk/gtkbutton.h
include/gtk-2.0/gtk/gtkcalendar.h
include/gtk-2.0/gtk/gtkcelleditable.h
include/gtk-2.0/gtk/gtkcellrenderer.h
include/gtk-2.0/gtk/gtkcellrendererpixbuf.h
include/gtk-2.0/gtk/gtkcellrenderertext.h
include/gtk-2.0/gtk/gtkcellrenderertoggle.h
include/gtk-2.0/gtk/gtkcheckbutton.h
include/gtk-2.0/gtk/gtkcheckmenuitem.h
include/gtk-2.0/gtk/gtkclipboard.h
include/gtk-2.0/gtk/gtkclist.h
include/gtk-2.0/gtk/gtkcolorsel.h
include/gtk-2.0/gtk/gtkcolorseldialog.h
include/gtk-2.0/gtk/gtkcombo.h
include/gtk-2.0/gtk/gtkcontainer.h
include/gtk-2.0/gtk/gtkctree.h
include/gtk-2.0/gtk/gtkcurve.h
include/gtk-2.0/gtk/gtkdebug.h
include/gtk-2.0/gtk/gtkdialog.h
include/gtk-2.0/gtk/gtkdnd.h
include/gtk-2.0/gtk/gtkdrawingarea.h
include/gtk-2.0/gtk/gtkeditable.h
include/gtk-2.0/gtk/gtkentry.h
include/gtk-2.0/gtk/gtkenums.h
include/gtk-2.0/gtk/gtkeventbox.h
include/gtk-2.0/gtk/gtkfilesel.h
include/gtk-2.0/gtk/gtkfixed.h
include/gtk-2.0/gtk/gtkfontsel.h
include/gtk-2.0/gtk/gtkframe.h
include/gtk-2.0/gtk/gtkgamma.h
include/gtk-2.0/gtk/gtkgc.h
include/gtk-2.0/gtk/gtkhandlebox.h
include/gtk-2.0/gtk/gtkhbbox.h
include/gtk-2.0/gtk/gtkhbox.h
include/gtk-2.0/gtk/gtkhpaned.h
include/gtk-2.0/gtk/gtkhruler.h
include/gtk-2.0/gtk/gtkhscale.h
include/gtk-2.0/gtk/gtkhscrollbar.h
include/gtk-2.0/gtk/gtkhseparator.h
include/gtk-2.0/gtk/gtkiconfactory.h
include/gtk-2.0/gtk/gtkimage.h
include/gtk-2.0/gtk/gtkimagemenuitem.h
include/gtk-2.0/gtk/gtkimcontext.h
include/gtk-2.0/gtk/gtkimcontextsimple.h
include/gtk-2.0/gtk/gtkimmodule.h
include/gtk-2.0/gtk/gtkimmulticontext.h
include/gtk-2.0/gtk/gtkinputdialog.h
include/gtk-2.0/gtk/gtkinvisible.h
include/gtk-2.0/gtk/gtkitem.h
include/gtk-2.0/gtk/gtkitemfactory.h
include/gtk-2.0/gtk/gtklabel.h
include/gtk-2.0/gtk/gtklayout.h
include/gtk-2.0/gtk/gtklist.h
include/gtk-2.0/gtk/gtklistitem.h
include/gtk-2.0/gtk/gtkliststore.h
include/gtk-2.0/gtk/gtkmain.h
include/gtk-2.0/gtk/gtkmarshal.h
include/gtk-2.0/gtk/gtkmenu.h
include/gtk-2.0/gtk/gtkmenubar.h
include/gtk-2.0/gtk/gtkmenuitem.h
include/gtk-2.0/gtk/gtkmenushell.h
include/gtk-2.0/gtk/gtkmessagedialog.h
include/gtk-2.0/gtk/gtkmisc.h
include/gtk-2.0/gtk/gtknotebook.h
include/gtk-2.0/gtk/gtkobject.h
include/gtk-2.0/gtk/gtkoldeditable.h
include/gtk-2.0/gtk/gtkoptionmenu.h
include/gtk-2.0/gtk/gtkpaned.h
include/gtk-2.0/gtk/gtkpixmap.h
include/gtk-2.0/gtk/gtkplug.h
include/gtk-2.0/gtk/gtkpreview.h
include/gtk-2.0/gtk/gtkprivate.h
include/gtk-2.0/gtk/gtkprogress.h
include/gtk-2.0/gtk/gtkprogressbar.h
include/gtk-2.0/gtk/gtkradiobutton.h
include/gtk-2.0/gtk/gtkradiomenuitem.h
include/gtk-2.0/gtk/gtkrange.h
include/gtk-2.0/gtk/gtkrc.h
include/gtk-2.0/gtk/gtkruler.h
include/gtk-2.0/gtk/gtkscale.h
include/gtk-2.0/gtk/gtkscrollbar.h
include/gtk-2.0/gtk/gtkscrolledwindow.h
include/gtk-2.0/gtk/gtkselection.h
include/gtk-2.0/gtk/gtkseparator.h
include/gtk-2.0/gtk/gtkseparatormenuitem.h
include/gtk-2.0/gtk/gtksettings.h
include/gtk-2.0/gtk/gtksignal.h
include/gtk-2.0/gtk/gtksizegroup.h
include/gtk-2.0/gtk/gtksocket.h
include/gtk-2.0/gtk/gtkspinbutton.h
include/gtk-2.0/gtk/gtkstatusbar.h
include/gtk-2.0/gtk/gtkstock.h
include/gtk-2.0/gtk/gtkstyle.h
include/gtk-2.0/gtk/gtktable.h
include/gtk-2.0/gtk/gtktearoffmenuitem.h
include/gtk-2.0/gtk/gtktext.h
include/gtk-2.0/gtk/gtktextbuffer.h
include/gtk-2.0/gtk/gtktextchild.h
include/gtk-2.0/gtk/gtktextdisplay.h
include/gtk-2.0/gtk/gtktextiter.h
include/gtk-2.0/gtk/gtktextlayout.h
include/gtk-2.0/gtk/gtktextmark.h
include/gtk-2.0/gtk/gtktexttag.h
include/gtk-2.0/gtk/gtktexttagtable.h
include/gtk-2.0/gtk/gtktextview.h
include/gtk-2.0/gtk/gtktipsquery.h
include/gtk-2.0/gtk/gtktogglebutton.h
include/gtk-2.0/gtk/gtktoolbar.h
include/gtk-2.0/gtk/gtktooltips.h
include/gtk-2.0/gtk/gtktree.h
include/gtk-2.0/gtk/gtktreednd.h
include/gtk-2.0/gtk/gtktreeitem.h
include/gtk-2.0/gtk/gtktreemodel.h
include/gtk-2.0/gtk/gtktreemodelsort.h
include/gtk-2.0/gtk/gtktreeselection.h
include/gtk-2.0/gtk/gtktreesortable.h
include/gtk-2.0/gtk/gtktreestore.h
include/gtk-2.0/gtk/gtktreeview.h
include/gtk-2.0/gtk/gtktreeviewcolumn.h
include/gtk-2.0/gtk/gtktypebuiltins.h
include/gtk-2.0/gtk/gtktypeutils.h
include/gtk-2.0/gtk/gtkvbbox.h
include/gtk-2.0/gtk/gtkvbox.h
include/gtk-2.0/gtk/gtkversion.h
include/gtk-2.0/gtk/gtkviewport.h
include/gtk-2.0/gtk/gtkvpaned.h
include/gtk-2.0/gtk/gtkvruler.h
include/gtk-2.0/gtk/gtkvscale.h
include/gtk-2.0/gtk/gtkvscrollbar.h
include/gtk-2.0/gtk/gtkvseparator.h
include/gtk-2.0/gtk/gtkwidget.h
include/gtk-2.0/gtk/gtkwindow.h
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-bmp.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-gif.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-ico.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-jpeg.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-png.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-pnm.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-ras.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-tga.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-tiff.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-wbmp.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-xbm.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-xpm.so
lib/gtk-2.0/immodules/%%GTK_VERSION%%/im-am-et.so
lib/gtk-2.0/immodules/%%GTK_VERSION%%/im-cyrillic-translit.so
lib/gtk-2.0/immodules/%%GTK_VERSION%%/im-hangul.so
lib/gtk-2.0/immodules/%%GTK_VERSION%%/im-inuktitut.so
lib/gtk-2.0/immodules/%%GTK_VERSION%%/im-ipa.so
lib/gtk-2.0/immodules/%%GTK_VERSION%%/im-thai-broken.so
lib/gtk-2.0/immodules/%%GTK_VERSION%%/im-ti-er.so
lib/gtk-2.0/immodules/%%GTK_VERSION%%/im-ti-et.so
lib/gtk-2.0/immodules/%%GTK_VERSION%%/im-viqr.so
lib/gtk-2.0/immodules/%%GTK_VERSION%%/im-xim.so
lib/libgdk-x11-1.3.a
lib/libgdk-x11-1.3.so
lib/libgdk-x11-1.3.so.14
lib/libgdk_pixbuf-1.3.a
lib/libgdk_pixbuf-1.3.so
lib/libgdk_pixbuf-1.3.so.14
lib/libgdk_pixbuf_xlib-1.3.a
lib/libgdk_pixbuf_xlib-1.3.so
lib/libgdk_pixbuf_xlib-1.3.so.14
lib/libgtk-x11-1.3.a
lib/libgtk-x11-1.3.so
lib/libgtk-x11-1.3.so.14
libdata/pkgconfig/gdk-2.0.pc
libdata/pkgconfig/gdk-pixbuf-2.0.pc
libdata/pkgconfig/gdk-pixbuf-xlib-2.0.pc
libdata/pkgconfig/gdk-x11-2.0.pc
libdata/pkgconfig/gtk+-2.0.pc
libdata/pkgconfig/gtk+-x11-2.0.pc
share/aclocal/gtk-2.0.m4
share/locale/az/LC_MESSAGES/gtk20.mo
share/locale/ca/LC_MESSAGES/gtk20.mo
share/locale/cs/LC_MESSAGES/gtk20.mo
share/locale/da/LC_MESSAGES/gtk20.mo
share/locale/de/LC_MESSAGES/gtk20.mo
share/locale/el/LC_MESSAGES/gtk20.mo
share/locale/en@IPA/LC_MESSAGES/gtk20.mo
share/locale/en_GB/LC_MESSAGES/gtk20.mo
share/locale/es/LC_MESSAGES/gtk20.mo
share/locale/et/LC_MESSAGES/gtk20.mo
share/locale/eu/LC_MESSAGES/gtk20.mo
share/locale/fa/LC_MESSAGES/gtk20.mo
share/locale/fi/LC_MESSAGES/gtk20.mo
share/locale/fr/LC_MESSAGES/gtk20.mo
share/locale/ga/LC_MESSAGES/gtk20.mo
share/locale/gl/LC_MESSAGES/gtk20.mo
share/locale/he/LC_MESSAGES/gtk20.mo
share/locale/hr/LC_MESSAGES/gtk20.mo
share/locale/hu/LC_MESSAGES/gtk20.mo
share/locale/ia/LC_MESSAGES/gtk20.mo
share/locale/it/LC_MESSAGES/gtk20.mo
share/locale/ja/LC_MESSAGES/gtk20.mo
share/locale/ko/LC_MESSAGES/gtk20.mo
share/locale/lt/LC_MESSAGES/gtk20.mo
share/locale/ms/LC_MESSAGES/gtk20.mo
share/locale/nl/LC_MESSAGES/gtk20.mo
share/locale/nn/LC_MESSAGES/gtk20.mo
share/locale/no/LC_MESSAGES/gtk20.mo
share/locale/pl/LC_MESSAGES/gtk20.mo
share/locale/pt/LC_MESSAGES/gtk20.mo
share/locale/pt_BR/LC_MESSAGES/gtk20.mo
share/locale/ro/LC_MESSAGES/gtk20.mo
share/locale/ru/LC_MESSAGES/gtk20.mo
share/locale/sk/LC_MESSAGES/gtk20.mo
share/locale/sl/LC_MESSAGES/gtk20.mo
share/locale/sp/LC_MESSAGES/gtk20.mo
share/locale/sr/LC_MESSAGES/gtk20.mo
share/locale/sv/LC_MESSAGES/gtk20.mo
share/locale/tr/LC_MESSAGES/gtk20.mo
share/locale/uk/LC_MESSAGES/gtk20.mo
share/locale/vi/LC_MESSAGES/gtk20.mo
share/locale/wa/LC_MESSAGES/gtk20.mo
share/locale/zh_CN/LC_MESSAGES/gtk20.mo
share/locale/zh_TW/LC_MESSAGES/gtk20.mo
share/themes/Default/gtk-2.0-key/gtkrc
share/themes/Default/gtk-2.0/gtkrc
share/themes/Emacs/gtk-2.0-key/gtkrc
@dirrm share/themes/Emacs/gtk-2.0-key
@dirrm share/themes/Emacs
@dirrm share/themes/Default/gtk-2.0-key
@dirrm share/themes/Default/gtk-2.0
@dirrm share/themes/Default
@dirrm lib/gtk-2.0/immodules/%%GTK_VERSION%%
@dirrm lib/gtk-2.0/immodules
@dirrm lib/gtk-2.0/%%GTK_VERSION%%/loaders
@dirrm lib/gtk-2.0/%%GTK_VERSION%%
@dirrm lib/gtk-2.0
@dirrm include/gtk-2.0/gtk
@dirrm include/gtk-2.0/gdk-pixbuf-xlib
@dirrm include/gtk-2.0/gdk-pixbuf
@dirrm include/gtk-2.0/gdk
@dirrm include/gtk-2.0
@dirrm etc/gtk-2.0