Update to 20170228 snapshot, which ceases loading i915.ko after i915kms.ko

Add an option for default AccelMethod, choice of UXA (default) or SNA (new)

Approved by:	swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D9862
This commit is contained in:
Matthew Rezny 2017-03-06 02:12:22 +00:00
parent e19969c795
commit 91a846b45e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=435512
8 changed files with 57 additions and 39 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xf86-video-intel
PORTVERSION= 2.99.917.20170103
PORTVERSION= 2.99.917.20170228
CATEGORIES= x11-drivers
MASTER_SITES= http://cgit.freedesktop.org/xorg/${XORG_CAT}/${PORTNAME}/snapshot/
DISTNAME= ${PORTNAME}-${COMMIT_ID}
@ -10,10 +10,13 @@ DISTNAME= ${PORTNAME}-${COMMIT_ID}
MAINTAINER= x11@FreeBSD.org
COMMENT= Driver for Intel integrated graphics chipsets
LICENSE= MIT # various
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libxcb-util.so:x11/xcb-util \
libdrm.so:graphics/libdrm
COMMIT_ID= 028c946df0855728b2a34d1d588701dc6c5ad4c1
COMMIT_ID= 78d7a09b0343829c81257024b164b0b3764392ac
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= Intel integrated GPU only exists in Intel x86 processors/chipsets
@ -27,6 +30,17 @@ USE_XORG= pciaccess pixman x11 xcb xext xrender xv xvmc
USES+= cpe autoreconf
CPE_VENDOR= x
CONFIGURE_ARGS+= --with-default-accel=uxa
OPTIONS_SINGLE= ACCEL
OPTIONS_SINGLE_ACCEL= SNA UXA
OPTIONS_DEFAULT= UXA
ACCEL_DESC= Default AccelMethod (if not specified in xorg.conf)
SNA_DESC= SandyBridge's New Acceleration
UXA_DESC= Unified Acceleration Architecture
CONFIGURE_ARGS+= --disable-udev
SNA_CONFIGURE_ON= --with-default-accel=sna
UXA_CONFIGURE_ON= --with-default-accel=uxa
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1484505738
SHA256 (xorg/driver/xf86-video-intel-028c946df0855728b2a34d1d588701dc6c5ad4c1.tar.bz2) = 34d00a1c85f33c55a58bc072b59633d84e48776c771cec5e4d313664c3f56f7c
SIZE (xorg/driver/xf86-video-intel-028c946df0855728b2a34d1d588701dc6c5ad4c1.tar.bz2) = 1236389
TIMESTAMP = 1488408514
SHA256 (xorg/driver/xf86-video-intel-78d7a09b0343829c81257024b164b0b3764392ac.tar.bz2) = 00efe1ccff175de207ce46be7d73c249b8ba8ab3ee90284ad7f60a645dbee362
SIZE (xorg/driver/xf86-video-intel-78d7a09b0343829c81257024b164b0b3764392ac.tar.bz2) = 1236509

View file

@ -1,10 +0,0 @@
--- src/intel_device.c.orig 2016-02-16 09:25:09.124344000 +0100
+++ src/intel_device.c 2016-02-16 09:22:49.541922000 +0100
@@ -204,6 +207,7 @@
}
static const char *kernel_module_names[] ={
+ "i915kms",
"i915",
NULL,
};

View file

@ -1,5 +1,5 @@
--- src/intel_device.c.orig 2014-12-21 20:36:40.268102983 +0100
+++ src/intel_device.c 2014-12-21 20:36:01.358104504 +0100
--- src/intel_device.c.orig 2017-02-28 20:52:19 UTC
+++ src/intel_device.c
@@ -28,6 +28,9 @@
#include "config.h"
#endif
@ -10,3 +10,11 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <assert.h>
@@ -204,6 +207,7 @@ static inline struct intel_device *intel
}
static const char *kernel_module_names[] ={
+ "i915kms",
"i915",
NULL,
};

View file

@ -1,6 +1,6 @@
--- src/intel_list.h.orig 2015-12-10 23:29:35.000000000 +0100
+++ src/intel_list.h 2016-10-24 10:22:57.280379000 +0200
@@ -305,8 +305,6 @@
--- src/intel_list.h.orig 2017-02-28 20:52:19 UTC
+++ src/intel_list.h
@@ -305,8 +305,6 @@ list_is_empty(const struct list *head)
#define list_last_entry(ptr, type, member) \
list_entry((ptr)->prev, type, member)
@ -9,7 +9,7 @@
/**
* Loop through the list given by head and set pos to struct in the list.
*
@@ -325,12 +323,12 @@
@@ -325,12 +323,12 @@ list_is_empty(const struct list *head)
*
*/
#define list_for_each_entry(pos, head, member) \
@ -25,7 +25,7 @@
&pos->member != (head); \
pos = __container_of(pos->member.prev, pos, member))
@@ -342,7 +340,7 @@
@@ -342,7 +340,7 @@ list_is_empty(const struct list *head)
* See list_for_each_entry for more details.
*/
#define list_for_each_entry_safe(pos, tmp, head, member) \

View file

@ -1,12 +1,12 @@
--- src/sna/kgem.c.orig 2014-12-09 17:08:21.000000000 +0100
+++ src/sna/kgem.c 2015-11-19 00:06:27.883010000 +0100
--- src/sna/kgem.c.orig 2017-02-28 20:52:19 UTC
+++ src/sna/kgem.c
@@ -29,6 +29,9 @@
#include "config.h"
#endif
+#define _WITH_GETLINE /* to expose getline() in stdio.h on FreeBSD */
+#include <stdio.h> /* for getline() */
+
#include "sna.h"
#include "sna_reg.h"

View file

@ -1,12 +1,12 @@
--- src/sna/sna_threads.c.orig 2016-11-18 16:32:46 UTC
--- src/sna/sna_threads.c.orig 2017-02-28 20:52:19 UTC
+++ src/sna/sna_threads.c
@@ -29,6 +29,9 @@
#include "config.h"
#endif
+#define _WITH_GETLINE /* to expose getline() in stdio.h on FreeBSD */
+#include <stdio.h> /* for getline() */
+
#include "sna.h"
#include <unistd.h>

View file

@ -1,10 +1,16 @@
Driver for Intel(R) Integrated Graphics Chipsets:
i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
Driver for Intel(R) HD Graphics: 2000-5000
Driver for Intel(R) Iris(TM) Graphics: 5100
Driver for Intel(R) Iris(TM) Pro Graphics: 5200
The xf86-video-intel module is an open-source 2D graphics driver for
the X Window System as implemented by X.org. It supports a variety of
Intel graphics chipsets including:
WWW: http://www.intellinuxgraphics.com/
i810/i810e/i810-dc100,i815,
i830M,845G,852GM,855GM,865G,
915G/GM,945G/GM/GME,946GZ
G/GM/GME/Q965,
G/Q33,G/Q35,G41,G/Q43,G/GM/Q45
PineView-M (Atom N400 series)
PineView-D (Atom D400/D500 series)
Intel(R) HD Graphics,
Intel(R) Iris(TM) Graphics,
Intel(R) Iris(TM) Pro Graphics.
WWW: https://01.org/linuxgraphics/