Upgrade to 1.17.
This commit is contained in:
parent
0bcc637ac4
commit
91bb6fd722
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=14831
7 changed files with 55 additions and 46 deletions
|
@ -1,13 +1,13 @@
|
|||
# New ports collection makefile for: gxedit
|
||||
# Version required: 1.16
|
||||
# Version required: 1.17
|
||||
# Date created: 01 Jul 1998
|
||||
# Whom: Dom Mitchell <dom@myrddin.demon.co.uk>
|
||||
#
|
||||
# $Id: Makefile,v 1.14 1998/10/24 17:10:14 vanilla Exp $
|
||||
# $Id: Makefile,v 1.15 1998/11/04 08:56:21 vanilla Exp $
|
||||
#
|
||||
|
||||
DISTNAME= GXedit1.16
|
||||
PKGNAME= gxedit-1.16
|
||||
DISTNAME= GXedit1.17
|
||||
PKGNAME= gxedit-1.17
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= http://devplanet.fastethernet.net/
|
||||
|
||||
|
@ -20,5 +20,7 @@ ALL_TARGET= gxedit
|
|||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/gxedit ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/ftp.sh ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/ftp-ls.sh ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (GXedit1.16.tar.gz) = 9a627ef5637e0d8cd3ca5ba256de0ad3
|
||||
MD5 (GXedit1.17.tar.gz) = fa4d1da89c99d764826d418c7e6eeb0d
|
||||
|
|
|
@ -1,22 +1,24 @@
|
|||
--- config.h.orig Fri Oct 30 20:36:26 1998
|
||||
+++ config.h Sun Nov 1 17:43:51 1998
|
||||
@@ -1,8 +1,8 @@
|
||||
--- config.h.orig Mon Nov 23 04:58:50 1998
|
||||
+++ config.h Tue Nov 24 00:54:58 1998
|
||||
@@ -1,7 +1,7 @@
|
||||
/* configuration file - precompile options */
|
||||
|
||||
#define USE_NET /* Use networking features */
|
||||
-#undef BG_ON_START /* Background on startup */
|
||||
-#undef GTK_1_1 /* Use GTK 1.1.x */
|
||||
+#define BG_ON_START /* Background on startup */
|
||||
+#define GTK_1_1 /* Use GTK 1.1.x */
|
||||
#define GTK_1_1 /* Use GTK 1.1.x */
|
||||
#undef GTKEDITOR_PATCH /* Use the GtkEditor patch */
|
||||
|
||||
/* Highlighting styles */
|
||||
@@ -15,7 +15,7 @@
|
||||
/* proxy */
|
||||
#undef USE_SOCKS /* you need to add -lsocks5 to the makefile for this */
|
||||
|
||||
-#undef INTERNATIONAL /* set locale */
|
||||
+#define INTERNATIONAL /* set locale */
|
||||
|
||||
/* mail path */
|
||||
@@ -44,9 +44,9 @@
|
||||
/* paths */
|
||||
|
||||
#define NETSCAPE "/usr/local/bin/netscape -remote"
|
||||
-#define EMACS "/usr/bin/emcas"
|
||||
-#define DES "/bin/des"
|
||||
-#define IDEA "/bin/idea"
|
||||
+#define EMACS "/usr/local/bin/emcas"
|
||||
+#define DES "/usr/local/bin/des"
|
||||
+#define IDEA "/usr/local/bin/idea"
|
||||
#define XTERM "/usr/X11R6/bin/xterm"
|
||||
#define AWK "awk"
|
||||
#define SED "sed"
|
||||
|
|
|
@ -1,23 +1,19 @@
|
|||
--- Makefile.orig Fri Oct 30 20:02:16 1998
|
||||
+++ Makefile Sun Nov 1 17:45:10 1998
|
||||
@@ -1,13 +1,12 @@
|
||||
--- Makefile.orig Mon Nov 23 04:54:57 1998
|
||||
+++ Makefile Tue Nov 24 02:02:35 1998
|
||||
@@ -1,9 +1,9 @@
|
||||
BIN_DIR =
|
||||
INSTALL_DIR = /usr/X11R6/bin/
|
||||
-CFLAGS = `gtk-config --cflags` -I/usr/local/include -I. -O -Wall
|
||||
+CFLAGS += `gtk11-config --cflags` -I/usr/local/include -I. -DX_LOCALE
|
||||
GTKEDITOR_CFLAGS = -I../gtkeditor-0.0.2-1
|
||||
+CFLAGS += `gtk11-config --cflags` -I/usr/local/include -I.
|
||||
GTKEDITOR_CFLAGS = -I../gtkeditor-0.0.3
|
||||
GNOME_CFLAGS = -DUSE_GNOME
|
||||
-LIBS = `gtk-config --libs`
|
||||
+LIBS = `gtk11-config --libs`
|
||||
GNOME_LIBS = -lgnomesupport -lgnome -lgnomeui
|
||||
OBJS = bindings.o gxedit.o net.o
|
||||
GTKEDITOR_OBJS = ../gtkeditor-0.0.2-1/gtkeditor.o ../gtkeditor-0.0.2-1/regex.o
|
||||
-CC = gcc
|
||||
|
||||
all:
|
||||
@echo "Use ./setup"
|
||||
@@ -22,7 +21,7 @@
|
||||
$(CC) $(CFLAGS) -c bindings.c
|
||||
OBJS = bindings.o gxedit.o net.o utils.o
|
||||
GTKEDITOR_OBJS = ../gtkeditor-0.0.3/gtkeditor.o ../gtkeditor-0.0.3/regex.o -L../gtkeditor-0.0.3 -lgtkeditor -lregex
|
||||
@@ -23,7 +23,7 @@
|
||||
$(CC) $(CFLAGS) -c utils.c
|
||||
$(CC) $(CFLAGS) -o $(BIN_DIR)gxedit $(OBJS) $(LIBS)
|
||||
@(rm -f ./.chk_config)
|
||||
- (cd xproc-src; make BIN_DIR=../; cd ..)
|
||||
|
@ -25,7 +21,7 @@
|
|||
@echo "You should delete your ~/.gxedit file to allow GXedit to re-create it if you're upgrading GXedit."
|
||||
|
||||
gxe-with-gtkeditor:
|
||||
@@ -55,7 +54,7 @@
|
||||
@@ -58,7 +58,7 @@
|
||||
|
||||
install:
|
||||
cp $(BIN_DIR)gxedit $(INSTALL_DIR)gxedit
|
||||
|
|
|
@ -1,15 +1,6 @@
|
|||
--- gxedit.c.orig Fri Oct 30 19:55:24 1998
|
||||
+++ gxedit.c Wed Nov 4 16:27:37 1998
|
||||
@@ -4482,7 +4482,7 @@
|
||||
}
|
||||
fputs((char *)gtk_editable_get_chars(GTK_EDITABLE (text), 0, gtk_text_get_length(GTK_TEXT(text))),fd);
|
||||
if(fd!=NULL) fclose(fd);
|
||||
- sprintf(temp, "/usr/bin/emacs %s &", tmp_name);
|
||||
+ sprintf(temp, "/usr/local/bin/emacs %s &", tmp_name);
|
||||
system(temp);
|
||||
}
|
||||
|
||||
@@ -6765,6 +6765,7 @@
|
||||
--- gxedit.c.orig Mon Nov 23 04:30:47 1998
|
||||
+++ gxedit.c Tue Nov 24 00:58:23 1998
|
||||
@@ -6569,6 +6569,7 @@
|
||||
if(tooltips)
|
||||
gtk_tooltips_set_tip(tips, menuitem, "HTML reference", "");
|
||||
|
||||
|
@ -17,7 +8,7 @@
|
|||
menuitem = gtk_menu_item_new_with_label("System information");
|
||||
gtk_menu_append(GTK_MENU(menu), menuitem);
|
||||
gtk_signal_connect_object(GTK_OBJECT(menuitem), "activate",
|
||||
@@ -6772,6 +6773,7 @@
|
||||
@@ -6576,6 +6577,7 @@
|
||||
gtk_widget_show(menuitem);
|
||||
if(tooltips)
|
||||
gtk_tooltips_set_tip(tips, menuitem, "Run Xproc", "");
|
||||
|
|
16
editors/gxedit/files/patch-ad
Normal file
16
editors/gxedit/files/patch-ad
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- ftp-ls.sh.orig Tue Nov 24 02:02:51 1998
|
||||
+++ ftp-ls.sh Tue Nov 24 02:03:00 1998
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/bin/sh
|
||||
# ftp.sh output_file host directory user pass
|
||||
ftp -n $2 > $1 2> $1 <<EOC
|
||||
user $4 $5
|
||||
--- ftp.sh.orig Tue Nov 24 02:02:48 1998
|
||||
+++ ftp.sh Tue Nov 24 02:02:56 1998
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/bin/sh
|
||||
# ftp.sh output_file host directory remote_file local_file user pass
|
||||
ftp -n $2 > $1 2> $1 <<EOC
|
||||
user $6 $7
|
|
@ -1 +1,3 @@
|
|||
bin/ftp-ls.sh
|
||||
bin/ftp.sh
|
||||
bin/gxedit
|
||||
|
|
Loading…
Reference in a new issue