Add rubygem-cucumber-messages4 4.0.0 (copied from rubygem-cucumber-messages)
This commit is contained in:
parent
e192474d17
commit
91c1c8e9f5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=538744
5 changed files with 44 additions and 0 deletions
|
@ -5905,6 +5905,7 @@
|
|||
SUBDIR += rubygem-cucumber-expressions6
|
||||
SUBDIR += rubygem-cucumber-formatter-dots
|
||||
SUBDIR += rubygem-cucumber-messages
|
||||
SUBDIR += rubygem-cucumber-messages4
|
||||
SUBDIR += rubygem-cucumber-rails
|
||||
SUBDIR += rubygem-cucumber-tag-expressions
|
||||
SUBDIR += rubygem-cucumber-tag_expressions1
|
||||
|
|
23
devel/rubygem-cucumber-messages4/Makefile
Normal file
23
devel/rubygem-cucumber-messages4/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= cucumber-messages
|
||||
PORTVERSION= 4.0.0
|
||||
CATEGORIES= devel rubygems
|
||||
MASTER_SITES= RG
|
||||
PKGNAMESUFFIX= 4
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Protocol Buffer messages for Cucumber
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= rubygem-google-protobuf>=3.2:devel/rubygem-google-protobuf
|
||||
|
||||
USES= gem
|
||||
USE_RUBY= yes
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/rubygem-cucumber-messages4/distinfo
Normal file
3
devel/rubygem-cucumber-messages4/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1591281338
|
||||
SHA256 (rubygem/cucumber-messages-4.0.0.gem) = 5afb9af646edd8a5da2437760d08efc307466dc06e892b654540850023701069
|
||||
SIZE (rubygem/cucumber-messages-4.0.0.gem) = 10240
|
11
devel/rubygem-cucumber-messages4/files/patch-gemspec
Normal file
11
devel/rubygem-cucumber-messages4/files/patch-gemspec
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- cucumber-messages.gemspec.orig 2019-03-30 16:48:28 UTC
|
||||
+++ cucumber-messages.gemspec
|
||||
@@ -25,7 +25,7 @@ Gem::Specification.new do |s|
|
||||
s.specification_version = 4
|
||||
|
||||
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
|
||||
- s.add_runtime_dependency(%q<google-protobuf>.freeze, [">= 3.2", "<= 3.8"])
|
||||
+ s.add_runtime_dependency(%q<google-protobuf>.freeze, [">= 3.2"])
|
||||
s.add_development_dependency(%q<bundler>.freeze, [">= 0"])
|
||||
s.add_development_dependency(%q<rake>.freeze, ["~> 12.3"])
|
||||
s.add_development_dependency(%q<rspec>.freeze, ["~> 3.7"])
|
6
devel/rubygem-cucumber-messages4/pkg-descr
Normal file
6
devel/rubygem-cucumber-messages4/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
Cucumber Messages is a message protocol based on Protocol Buffers. It allows one
|
||||
process to construct message objects and send them to another process. Protobuf
|
||||
takes care of serialising those messages to a binary format, and deserialise
|
||||
them on the other end.
|
||||
|
||||
WWW: https://github.com/cucumber/cucumber-messages-ruby
|
Loading…
Reference in a new issue