- Fix build on AMD (hopefully)
- Remove extra-patch in favour of USE_LIBTOOL - Remove two-line plist PR: ports/77563 Submitted by: Kay Lehmann (maintainer)
This commit is contained in:
parent
8231a23521
commit
91c41fc06a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=129489
8 changed files with 28 additions and 42 deletions
|
@ -17,6 +17,7 @@ COMMENT= Default plugins for lineakd
|
||||||
|
|
||||||
LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd
|
LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd
|
||||||
|
|
||||||
|
USE_LIBTOOL_VER=15
|
||||||
USE_GMAKE= yes
|
USE_GMAKE= yes
|
||||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||||
|
@ -24,6 +25,8 @@ CONFIGURE_ARGS+= --program-prefix=''
|
||||||
USE_REINPLACE= yes
|
USE_REINPLACE= yes
|
||||||
|
|
||||||
MAN1= lineak_defaultplugin.1
|
MAN1= lineak_defaultplugin.1
|
||||||
|
PLIST_FILES= lib/lineakd/plugins/defaultplugin.so \
|
||||||
|
lib/lineakd/plugins/mediadetectplugin.so
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
@ -31,9 +34,6 @@ MAN1= lineak_defaultplugin.1
|
||||||
# lineakd is compiled with 3.4 on FreeBSD 4.x, so plugins must be too
|
# lineakd is compiled with 3.4 on FreeBSD 4.x, so plugins must be too
|
||||||
USE_GCC= 3.4
|
USE_GCC= 3.4
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
EXTRA_PATCHES= ${FILESDIR}/extra-patch-ltmain.sh
|
|
||||||
.else
|
|
||||||
USE_LIBTOOL_VER=15
|
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
|
|
|
@ -1,15 +0,0 @@
|
||||||
--- admin/ltmain.sh.orig Fri Mar 19 14:14:27 2004
|
|
||||||
+++ admin/ltmain.sh Fri Mar 19 14:14:40 2004
|
|
||||||
@@ -5425,10 +5425,12 @@
|
|
||||||
fi
|
|
||||||
|
|
||||||
# Install the pseudo-library for information purposes.
|
|
||||||
+ if /usr/bin/false ; then
|
|
||||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
|
||||||
instname="$dir/$name"i
|
|
||||||
$show "$install_prog $instname $destdir/$name"
|
|
||||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
|
||||||
+ fi
|
|
||||||
|
|
||||||
# Maybe install the static library, too.
|
|
||||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
11
sysutils/lineak-defaultplugin/files/patch-mdloader.cpp
Normal file
11
sysutils/lineak-defaultplugin/files/patch-mdloader.cpp
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- default_plugin/mdloader.cpp.orig Tue Feb 15 18:31:13 2005
|
||||||
|
+++ default_plugin/mdloader.cpp Tue Feb 15 18:31:41 2005
|
||||||
|
@@ -109,7 +109,7 @@
|
||||||
|
// Handle empty lines.
|
||||||
|
loc = tmp.find('=');
|
||||||
|
// empty line
|
||||||
|
- if (loc == string::npos)
|
||||||
|
+ if (loc == (unsigned int)string::npos)
|
||||||
|
continue;
|
||||||
|
|
||||||
|
// key == the name of the key.
|
|
@ -1,3 +0,0 @@
|
||||||
@comment $FreeBSD$
|
|
||||||
lib/lineakd/plugins/defaultplugin.so
|
|
||||||
lib/lineakd/plugins/mediadetectplugin.so
|
|
|
@ -17,6 +17,7 @@ COMMENT= Default plugins for lineakd
|
||||||
|
|
||||||
LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd
|
LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd
|
||||||
|
|
||||||
|
USE_LIBTOOL_VER=15
|
||||||
USE_GMAKE= yes
|
USE_GMAKE= yes
|
||||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||||
|
@ -24,6 +25,8 @@ CONFIGURE_ARGS+= --program-prefix=''
|
||||||
USE_REINPLACE= yes
|
USE_REINPLACE= yes
|
||||||
|
|
||||||
MAN1= lineak_defaultplugin.1
|
MAN1= lineak_defaultplugin.1
|
||||||
|
PLIST_FILES= lib/lineakd/plugins/defaultplugin.so \
|
||||||
|
lib/lineakd/plugins/mediadetectplugin.so
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
@ -31,9 +34,6 @@ MAN1= lineak_defaultplugin.1
|
||||||
# lineakd is compiled with 3.4 on FreeBSD 4.x, so plugins must be too
|
# lineakd is compiled with 3.4 on FreeBSD 4.x, so plugins must be too
|
||||||
USE_GCC= 3.4
|
USE_GCC= 3.4
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
EXTRA_PATCHES= ${FILESDIR}/extra-patch-ltmain.sh
|
|
||||||
.else
|
|
||||||
USE_LIBTOOL_VER=15
|
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
|
|
|
@ -1,15 +0,0 @@
|
||||||
--- admin/ltmain.sh.orig Fri Mar 19 14:14:27 2004
|
|
||||||
+++ admin/ltmain.sh Fri Mar 19 14:14:40 2004
|
|
||||||
@@ -5425,10 +5425,12 @@
|
|
||||||
fi
|
|
||||||
|
|
||||||
# Install the pseudo-library for information purposes.
|
|
||||||
+ if /usr/bin/false ; then
|
|
||||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
|
||||||
instname="$dir/$name"i
|
|
||||||
$show "$install_prog $instname $destdir/$name"
|
|
||||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
|
||||||
+ fi
|
|
||||||
|
|
||||||
# Maybe install the static library, too.
|
|
||||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
11
sysutils/lineak_defaultplugin/files/patch-mdloader.cpp
Normal file
11
sysutils/lineak_defaultplugin/files/patch-mdloader.cpp
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- default_plugin/mdloader.cpp.orig Tue Feb 15 18:31:13 2005
|
||||||
|
+++ default_plugin/mdloader.cpp Tue Feb 15 18:31:41 2005
|
||||||
|
@@ -109,7 +109,7 @@
|
||||||
|
// Handle empty lines.
|
||||||
|
loc = tmp.find('=');
|
||||||
|
// empty line
|
||||||
|
- if (loc == string::npos)
|
||||||
|
+ if (loc == (unsigned int)string::npos)
|
||||||
|
continue;
|
||||||
|
|
||||||
|
// key == the name of the key.
|
|
@ -1,3 +0,0 @@
|
||||||
@comment $FreeBSD$
|
|
||||||
lib/lineakd/plugins/defaultplugin.so
|
|
||||||
lib/lineakd/plugins/mediadetectplugin.so
|
|
Loading…
Reference in a new issue