Add papaya-plugins 0.90, plugins for papaya, a graphical GTK mud

client.

PR:		32958
Submitted by:	Edwin Groothuis <edwin@mavetju.org>
This commit is contained in:
Pete Fritchman 2001-12-19 09:48:32 +00:00
parent 9b2f027b72
commit 91e2db011f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51809
8 changed files with 134 additions and 0 deletions

View file

@ -327,6 +327,7 @@
SUBDIR += p5-perl-ldap
SUBDIR += pancho
SUBDIR += papaya
SUBDIR += papaya-plugins
SUBDIR += passlogd
SUBDIR += pathchar
SUBDIR += pchar

View file

@ -0,0 +1,49 @@
# New ports collection makefile for: papaya-plugins
# Date created: 23 August 2001
# Whom: Edwin Groothuis <edwin@mavetju.org>
#
# $FreeBSD$
#
PORTNAME= papaya-plugins
PORTVERSION= 0.90
CATEGORIES= net
MASTER_SITES= http://www.gtk-papaya.org/downloads/plugins/source/
DISTNAME= papaya-plugins-src-${PORTVERSION}
MAINTAINER= edwin@mavetju.org
# We need the source for papaya to build the plugins.
BUILD_DEPENDS= ${PORTSDIR}/net/papaya/work/papaya-src-${PORTVERSION}/src/h:${PORTSDIR}/net/papaya
RUN_DEPENDS= papaya:${PORTSDIR}/net/papaya
IS_INTERACTIVE= yes
USE_GMAKE= yes
USE_GNOMELIBS= yes
USE_GTK= yes
GNU_CONFIGURE= yes
MAKE_ARGS+= CXX="${CXX}"
PLIST= ${WRKSRC}/pkg-plist
post-patch:
@${PERL} -pi -e 's,g\+\+,${CXX},g' ${WRKSRC}/Makefile.in
@${PERL} -pi -e 's,malloc.h,stdlib.h,' ${WRKSRC}/PythonPlugin.cpp \
${WRKSRC}/TurfProtocol.cpp
@${PERL} -pi -e 's,stdint.h,sys/types.h,' ${WRKSRC}/SpellStacker.h
pre-configure:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.papaya-plugins
${RM} ${WRKSRC}/config.cache
post-configure:
${LN} -fs ${PORTSDIR}/net/papaya/work/papaya-src-${PORTVERSION}/src/h ${WRKSRC}/h
post-build:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/add-plugins
.include <bsd.port.mk>
.if exists(${WRKDIR}/Makefile.inc)
.include "${WRKDIR}/Makefile.inc"
.endif

View file

@ -0,0 +1 @@
MD5 (papaya-plugins-src-0.90.tar.gz) = 4d89921d9d91fbb6aba3e774bbbc8c8b

View file

@ -0,0 +1,19 @@
$FreeBSD$
--- Makefile.in.orig Fri Aug 31 14:39:08 2001
+++ Makefile.in Wed Dec 19 04:19:31 2001
@@ -1,4 +1,4 @@
-CC = g++
+CC = ${CXX}
# Commonly used modules that don't require TurfProtocol
COMMONMODULES = o/Speedwalk.so o/MudLog.so o/PromptPlugin.so \
@@ -47,7 +47,7 @@
# should select the correct LFLAGS line.
##
-C++FLAGS = -I/usr/local/include $(POSTGRES_INC) `glib-config --cflags` `gtk-config --cflags` -fno-exceptions -fno-rtti -fno-inline @DEBUG@ -DUNIX -Wall $(MIDI) -Ih `gnome-config --cflags gnomeui`
+C++FLAGS = -I/usr/local/include $(POSTGRES_INC) `${GLIB_CONFIG} --cflags` `${GTK_CONFIG} --cflags` -fno-exceptions -fno-rtti -fno-inline @DEBUG@ -DUNIX -Wall $(MIDI) -Ih `gnome-config --cflags gnomeui` ${CXXFLAGS}
all: $(MODULES)

View file

@ -0,0 +1 @@
Plugins for papaya, a graphical GTK mud client

View file

@ -0,0 +1,8 @@
Papaya is a MUD client. A MUD client is a program like telnet, but
customised for playing MUDs with. Papaya has a number of features
designed to make playing MUDs more enjoyable. Papaya makes use of
Gnome to provide a graphical interface.
This section is only the plugins.
WWW: http://www.gtk-papaya.org/

View file

@ -0,0 +1,10 @@
#!/bin/sh
files=`ls ${WRKSRC}/o/ | sed -e 's/^.*\/o\///g'`
> pkg-plist
for f in $files; do
echo share/papaya/plugins/$f >> ${WRKSRC}/pkg-plist
done
echo "@dirrm share/papaya/plugins" >> ${WRKSRC}/pkg-plist

View file

@ -0,0 +1,45 @@
#!/bin/sh
# $FreeBSD$
tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"common\"
else
/usr/bin/dialog --title "Postfix configuration options" --clear \
--checklist "\n\
Please select desired options:" -1 -1 8 \
common "Enable common generic plugins" ON \
extra "Enable extra generic plugins" OFF \
turf "Enable the TurfProtocol plugin" OFF \
turf-common "Enable common Turf plugins" OFF \
turf-extra "Enable extra Turf plugins" OFF \
python "Enable the Python interpreter" OFF \
all "Overrides above" OFF \
debugging "Compile with debugging symbols" OFF \
2> $tempfile
retval=$?
if [ -s $tempfile ]; then
set `cat $tempfile`
fi
rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then
echo "Nothing selected"
fi
;;
1) echo "Cancel pressed."
exit 1
;;
esac
fi
exec > ${WRKDIR}/Makefile.inc
while [ "$1" ]; do
echo "CONFIGURE_ARGS+= --enable-`echo $1 | sed -e 's/"//g'`"
shift
done