- stagify rss2html
- add license - take maintainership ( dhn drop its maintainship) Approved by: kwm (mentor), dhn
This commit is contained in:
parent
3c38f53bc6
commit
91fde41091
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=359819
3 changed files with 33 additions and 13 deletions
|
@ -7,29 +7,24 @@ PORTREVISION= 3
|
|||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://mirror.mcx2.org/
|
||||
|
||||
MAINTAINER= dhn@FreeBSD.org
|
||||
MAINTAINER= rodrigo@FreeBSD.org
|
||||
COMMENT= RSS to HTML converter
|
||||
|
||||
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CFLAGS+= "-I${LOCALBASE}/include" "-L${LOCALBASE}/lib"
|
||||
|
||||
MAN1= rss2html.1
|
||||
MANCOMPRESSED= no
|
||||
|
||||
PLIST_FILES= bin/rss2html
|
||||
PLIST_FILES= bin/rss2html man/man1/rss2html.1.gz
|
||||
PORTDOCS= rss2html.links usage.example rss2html.template
|
||||
|
||||
NO_STAGE= yes
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '16,20d' ${WRKSRC}/Makefile.acr
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}/
|
||||
.endif
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
25
textproc/rss2html/files/patch-Makefile.acr
Normal file
25
textproc/rss2html/files/patch-Makefile.acr
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- Makefile.acr.orig 2014-06-29 22:15:48.507493419 +0000
|
||||
+++ Makefile.acr 2014-06-29 22:16:59.373488121 +0000
|
||||
@@ -11,14 +11,14 @@
|
||||
cd src/ && ${MAKE} all
|
||||
|
||||
install:
|
||||
- mkdir -p ${BINDIR}
|
||||
- ${INSTALL_PROGRAM} src/rss2html ${BINDIR}/
|
||||
- mkdir -p ${PREFIX}/share/doc/rss2html/
|
||||
- ${INSTALL_DATA} doc/rss2html.links ${PREFIX}/share/doc/rss2html/
|
||||
- ${INSTALL_DATA} doc/usage.example ${PREFIX}/share/doc/rss2html/
|
||||
- ${INSTALL_DATA} doc/rss2html.template ${PREFIX}/share/doc/rss2html/
|
||||
- ${INSTALL_DATA} README ${PREFIX}/share/doc/rss2html/
|
||||
- ${INSTALL_MAN} doc/rss2html.1 ${MANDIR}/man1/
|
||||
+ mkdir -p ${DESTDIR}${BINDIR}
|
||||
+ ${INSTALL_PROGRAM} src/rss2html ${DESTDIR}${BINDIR}/
|
||||
+ mkdir -p ${DESTDIR}${PREFIX}/share/doc/rss2html/
|
||||
+ ${INSTALL_DATA} doc/rss2html.links ${DESTDIR}${PREFIX}/share/doc/rss2html/
|
||||
+ ${INSTALL_DATA} doc/usage.example ${DESTDIR}${PREFIX}/share/doc/rss2html/
|
||||
+ ${INSTALL_DATA} doc/rss2html.template ${DESTDIR}${PREFIX}/share/doc/rss2html/
|
||||
+ ${INSTALL_DATA} README ${DESTDIR}${PREFIX}/share/doc/rss2html/
|
||||
+ ${INSTALL_MAN} doc/rss2html.1 ${DESTDIR}${MANDIR}/man1/
|
||||
|
||||
clean:
|
||||
cd src/ && ${MAKE} clean
|
Loading…
Reference in a new issue