. Install the PKCS#11 JAR and build and install the PKCS#11 native library.

Prompted by:	ale, Havard Eidnes <he@uninett.no>
This commit is contained in:
Greg Lewis 2008-01-14 06:08:08 +00:00
parent 836873e17f
commit 920e8b7f80
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=205625
3 changed files with 54 additions and 1 deletions

View file

@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= ${JDK_VERSION}.${JDK_UPDATE_VERSION}p${JDK_PATCHSET_VERSION}
PORTREVISION= 3
PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= java devel
MASTER_SITES= # http://download.java.net/tiger/
@ -254,6 +254,24 @@ do-extract:
fi \
done
post-extract:
cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
j2se/make/tools/crypto/pkcs11/sunpkcs11_src.zip \
${EXTRACT_AFTER_ARGS}
-${MKDIR} ${WRKDIR}/j2se/make/sun/security
-${MKDIR} ${WRKDIR}/j2se/src/share/classes/sun/security
-${MKDIR} ${WRKDIR}/j2se/src/share/native/sun/security
-${MKDIR} ${WRKDIR}/j2se/src/solaris/native/sun/security
${MV} ${WRKDIR}/make/sun/security/pkcs11 \
${WRKDIR}/j2se/make/sun/security/pkcs11
${MV} ${WRKDIR}/src/share/classes/sun/security/pkcs11 \
${WRKDIR}/j2se/src/share/classes/sun/security/pkcs11
${MV} ${WRKDIR}/src/share/native/sun/security/pkcs11 \
${WRKDIR}/j2se/src/share/native/sun/security/pkcs11
${MV} ${WRKDIR}/src/solaris/native/sun/security/pkcs11 \
${WRKDIR}/j2se/src/solaris/native/sun/security/pkcs11
cd ${WRKDIR} && ${RM} -rf src
pre-patch:
@cd ${WRKDIR} && \
${BZIP2_CMD} -dc ${DISTDIR}/${PATCHSETFILE} | ${TAR} -xf - && \

View file

@ -0,0 +1,22 @@
$FreeBSD$
--- ../../j2se/make/sun/security/pkcs11/Makefile.orig Sun Jan 13 11:11:15 2008
+++ ../../j2se/make/sun/security/pkcs11/Makefile Sun Jan 13 13:12:48 2008
@@ -47,7 +47,7 @@
#
# Libraries to link
#
-ifeq ($(PLATFORM), windows)
+ifneq (,$(findstring $(PLATFORM), windows bsd))
OTHER_LDLIBS = $(JVMLIB)
else
OTHER_LDLIBS = -ldl $(JVMLIB)
@@ -62,7 +62,7 @@
jar: classes
-$(RM) $(PKCS11_JAR)
- $(JAR) cf $(PKCS11_JAR) -C $(CLASSDESTDIR) sun/security/pkcs11 || exit 1
+ $(CP) $(BUILDDIR)/tools/crypto/pkcs11/sunpkcs11.jar $(PKCS11_JAR) || exit 1
# testing only
KEY_LOCATION = /security/ws/JCE-tiger/src

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- ../../j2se/make/sun/security/Makefile.orig Sat Jan 12 21:33:28 2008
+++ ../../j2se/make/sun/security/Makefile Sat Jan 12 21:33:51 2008
@@ -27,7 +27,7 @@
endif # solaris
endif
-SUBDIRS = acl action util x509 pkcs provider tools keytool jgss validator jca rsa timestamp $(TOOLS_SUBDIRS)
+SUBDIRS = acl action util x509 pkcs pkcs11 provider tools keytool jgss validator jca rsa timestamp $(TOOLS_SUBDIRS)
all optimized debug clean clobber ::
@for i in $(SUBDIRS) ; do \