This commit is contained in:
Jeremy Messenger 2012-08-04 19:56:17 +00:00
parent 89ee391f1c
commit 924bc30e9a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=302028
6 changed files with 12250 additions and 6498 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= opa
PORTVERSION= 0.9.4.${GITVER}
PORTVERSION= 1.0.5.${GITVER}
CATEGORIES= lang
MASTER_SITES= http://download.opalang.org/tar-gz/
DISTNAME= ${PORTNAME}_v${GITVER}
@ -19,14 +19,17 @@ BUILD_DEPENDS= ${OCAMLFIND_DEPEND} \
${LOCALBASE}/${OCAML_SITELIBDIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit \
${LOCALBASE}/${OCAML_SITELIBDIR}/zip/zip.a:${PORTSDIR}/archivers/ocaml-zip \
${LOCALBASE}/${OCAML_LIBDIR}/ocamlgraph/graph.a:${PORTSDIR}/math/ocaml-ocamlgraph \
${LOCALBASE}/${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
${LOCALBASE}/${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex \
${LOCALBASE}/bin/node:${PORTSDIR}/www/node
RUN_DEPENDS= ${LOCALBASE}/${OCAML_SITELIBDIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl \
${LOCALBASE}/${OCAML_SITELIBDIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit \
${LOCALBASE}/${OCAML_SITELIBDIR}/zip/zip.a:${PORTSDIR}/archivers/ocaml-zip \
${LOCALBASE}/${OCAML_LIBDIR}/ocamlgraph/graph.a:${PORTSDIR}/math/ocaml-ocamlgraph \
${LOCALBASE}/${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
${LOCALBASE}/${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex \
${LOCALBASE}/bin/node:${PORTSDIR}/www/node \
${LOCALBASE}/bin/npm:${PORTSDIR}/www/npm
GITVER= 1903
GITVER= 2988
USE_JAVA= yes
JAVA_BUILD= yes
USE_GMAKE= yes
@ -35,19 +38,20 @@ USE_OCAML= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -prefix ${PREFIX}
MAKE_ENV= MLSTATELIBS="${WRKSRC}/_build"
MAN1= bslbrowser.1 filepos.1 gen_opa_manpage.1 gen_opatop_manpage.1 \
genman.native.1 jsstat.1 mlidl.1 ocamlbase.1 odep.1 odeplink.1 \
ofile.1 opa.1 opa-cloud.1 opa-db-server.1 opa-db-tool.1 \
opa-plugin-browser-bin.1 opa-plugin-builder-bin.1 \
opa-translate.1 opa2opa.1 opadep.1 opatop.1 opatrack.1 \
passdesign.1 ppdebug.1 qmljs.1 trx.1 trx_interpreter.1 \
wsdl2ml.1
MAN1= bslbrowser.1 filepos.1 gen_opa_manpage.1 \
gen_opatop_manpage.1 genman.1 globalizer.1 jsstat.1 \
mlidl.1 ocamlbase.1 odep.1 odeplink.1 ofile.1 opa-cloud.1 \
opa-db-server.1 opa-db-tool.1 opa-plugin-browser-bin.1 \
opa-plugin-builder-bin.1 opa-translate.1 opa.1 opa2opa.1 \
opadep.1 opatop.1 opatrack.1 passdesign.1 ppdebug.1 \
qmljs.1 trx.1 trx_interpreter.1 wsdl2ml.1
.if defined(WITH_CAMLIDL)
BUILD_DEPENDS+= ${LOCALBASE}/bin/camlidl:${PORTSDIR}/lang/ocaml-camlidl
LIB_DEPENDS+= natpmp.1:${PORTSDIR}/net/libnatpmp \
miniupnpc.8:${PORTSDIR}/net/miniupnpc
LIB_DEPENDS+= natpmp:${PORTSDIR}/net/libnatpmp \
miniupnpc:${PORTSDIR}/net/miniupnpc
RUN_DEPENDS+= ${LOCALBASE}/bin/camlidl:${PORTSDIR}/lang/ocaml-camlidl
CONFIGURE_ARGS+=-camlidl
.endif
@ -56,8 +60,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|share/man/|/man/|g' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|_git_version = .*"|_git_version = ${GITVER}"|g' \
${WRKSRC}/buildinfos/generate_buildinfos.sh
${WRKSRC}/compiler/buildinfos/generate_buildinfos.sh
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/build/myocamlbuild_prefix.ml
${WRKSRC}/tools/build/myocamlbuild_prefix.ml
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (opa_v1903.tar.gz) = 5a41e98e13d6082093a88cec24631f8c36277608516b7478f6cb38b02094adc4
SIZE (opa_v1903.tar.gz) = 9762857
SHA256 (opa_v2988.tar.gz) = fb3257d943465f5901dade3fd1a18a5dbdacb2e27a892a76fba57e770ce3ea9f
SIZE (opa_v2988.tar.gz) = 10006465

View file

@ -1,17 +0,0 @@
--- build/myocamlbuild_prefix.ml.orig 2012-06-12 12:21:51.000000000 -0500
+++ build/myocamlbuild_prefix.ml 2012-06-12 12:25:27.000000000 -0500
@@ -325,7 +325,13 @@
let sedexpr =
Printf.sprintf "s/^\\?HAS_(%s)://; /HAS_.*:/d" tags
in
- Cmd(S[sed; A"-r"; A sedexpr; P(env "%.mllibp"); Sh">"; P(env "%.mllib")]));
+ (* FreeBSD 8.x and above have added -r that does exactly same as -E
+ for increased compatibility with GNU sed. Since FreeBSD still
+ supports 7.x that does not has -r, so use -E instead. *)
+ if is_fbsd then
+ Cmd(S[sed; A"-E"; A sedexpr; P(env "%.mllibp"); Sh">"; P(env "%.mllib")])
+ else
+ Cmd(S[sed; A"-r"; A sedexpr; P(env "%.mllibp"); Sh">"; P(env "%.mllib")]));
(* Windows specific : redefinition of an existing rule in Ocaml_specific.ml,
Louis please have a look to avoid the two copies at the end

View file

@ -1,19 +1,20 @@
--- build_rules.ml.orig 2012-06-11 14:51:35.000000000 -0500
+++ build_rules.ml 2012-06-11 14:54:06.000000000 -0500
@@ -397,6 +397,7 @@
|> filter_system_libs
--- tools/build/build_rules.ml.orig 2012-08-01 21:43:40.000000000 -0500
+++ tools/build/build_rules.ml 2012-08-01 21:47:37.000000000 -0500
@@ -452,6 +452,7 @@
else ".."/dir
)]
in
let lib_dir s = [A"--ml";A"-I";A"--ml";P (if Pathname.exists s then ".." / s else ("+"^s))] in
+ let custom_i = [A"--ml";A"-I";A"--ml";A"+site-lib/cryptokit"] in
+ let custom_i = [A"--ml";A"-I";A"--ml";A"+site-lib/cryptokit";A"--ml";A"-I";A"--ml";A"+site-lib/ssl";A"--ml";A"-I";A"--ml";A"+site-lib/ssl_threads"] in
let include_dirs = List.flatten (List.map lib_dir caml_use_lib) in
let clib s = [A"--ml";A"-cclib";A"--ml";A("-l"^s)] in
let include_libs = List.flatten (List.map clib c_libs) in
@@ -415,7 +416,7 @@
unsafe_js @ [A"--js-validator"] @ js_checker @ files_validation
)
@@ -511,7 +512,8 @@
let version = get_version_buildinfos () in
let options = [A"--package-version"; A version; A"-o" ;
P((Pathname.basename (env opp)))] @ preprocess_js @ preprocess_ml @
- include_dirs @ include_libs @ js_validation @ files_lib @ options
+ custom_i @ include_dirs @ include_libs @ js_validation @ files_lib @
+ options
in
- let options = [A"--static" ; A"-o" ; P((Pathname.basename (env opp)))] @ include_dirs @ include_libs @js_validation @ files_lib in
+ let options = [A"--static" ; A"-o" ; P((Pathname.basename (env opp)))] @ include_dirs @ custom_i @ include_libs @js_validation @ files_lib in
Seq[Cmd(S(opa_plugin_builder::options));
Cmd(S[A"touch"; P(env oppf) ] )]
in
Seq[
Cmd(S(

View file

@ -1,5 +1,5 @@
--- libnet/nattraversal/stubsnatpmp.idl.orig 2011-12-31 12:31:30.000000000 -0600
+++ libnet/nattraversal/stubsnatpmp.idl 2011-12-31 12:32:12.000000000 -0600
--- ocamllib/libnet/nattraversal/stubsnatpmp.idl.orig 2011-12-31 12:31:30.000000000 -0600
+++ ocamllib/libnet/nattraversal/stubsnatpmp.idl 2011-12-31 12:32:12.000000000 -0600
@@ -26,8 +26,7 @@
#include <arpa/inet.h> \n\
#endif");

File diff suppressed because it is too large Load diff