New patches for sfio98. (Not that many changes, I've just split them up

into a single patch for each source file).
This commit is contained in:
James Raynard 1998-11-07 18:06:17 +00:00
parent 0fa4f8390e
commit 9258520d84
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=14395
6 changed files with 70 additions and 0 deletions

11
devel/sfio/files/patch-ab Normal file
View file

@ -0,0 +1,11 @@
--- src/lib/sfio/sfhdr.h.orig Sat Nov 7 13:29:09 1998
+++ src/lib/sfio/sfhdr.h Sat Nov 7 13:29:25 1998
@@ -134,7 +134,7 @@
#include <floatingpoint.h>
#endif
#if _hdr_values
-#include <values.h>
+#include <float.h>
#endif
#if _hdr_math
#include <math.h>

12
devel/sfio/files/patch-ac Normal file
View file

@ -0,0 +1,12 @@
--- src/lib/sfio/Sfio_dc/Makefile.orig Sat Nov 7 15:39:40 1998
+++ src/lib/sfio/Sfio_dc/Makefile Sat Nov 7 15:40:01 1998
@@ -10,7 +10,8 @@
# Compiler and flags to use
CXFLAGS=
CCMODE= -O
-CCFLAGS= -I. -I$(INCDIR) $(CCMODE) $(CXFLAGS)
+CCFLAGS= $(CFLAGS)
+CCFLAGS+= -I. -I$(INCDIR)
AR= ar
CC= cc

12
devel/sfio/files/patch-ad Normal file
View file

@ -0,0 +1,12 @@
--- src/lib/sfio/Sfio_f/Makefile.orig Sat Nov 7 15:39:51 1998
+++ src/lib/sfio/Sfio_f/Makefile Sat Nov 7 15:40:06 1998
@@ -7,7 +7,8 @@
CC= cc
CXFLAGS=
CCMODE= -O
-CCFLAGS= -I.. $(CCMODE) $(CXFLAGS)
+CCFLAGS= $(CFLAGS)
+CCFLAGS+= -I..
SRCS= _sfclrerr.c _sfdlen.c _sfeof.c _sferror.c _sffileno.c _sfgetc.c \
_sfgetl.c _sfgetu.c _sfllen.c _sfputc.c _sfputd.c _sfputl.c _sfputu.c \

12
devel/sfio/files/patch-ae Normal file
View file

@ -0,0 +1,12 @@
--- src/lib/sfio/Stdio_b/Makefile.orig Sat Nov 7 15:41:32 1998
+++ src/lib/sfio/Stdio_b/Makefile Sat Nov 7 15:41:43 1998
@@ -7,7 +7,8 @@
CC= cc
CXFLAGS=
CCMODE= -O
-CCFLAGS= -I.. $(CCMODE) $(CXFLAGS)
+CCFLAGS= $(CFLAGS)
+CCFLAGS+= -I..
BINDIR= ../../../../bin
SRCS= doprnt.c doscan.c fclose.c fdopen.c fflush.c fgetc.c fgets.c filbuf.c \

12
devel/sfio/files/patch-af Normal file
View file

@ -0,0 +1,12 @@
--- src/lib/sfio/Stdio_s/Makefile.orig Sat Nov 7 15:53:36 1998
+++ src/lib/sfio/Stdio_s/Makefile Sat Nov 7 15:41:45 1998
@@ -7,7 +7,8 @@
CC= cc
CXFLAGS=
CCMODE= -O
-CCFLAGS= -I.. $(CCMODE) $(CXFLAGS)
+CCFLAGS= $(CFLAGS)
+CCFLAGS+= -I..
SRCS= stdgets.c stdopen.c stdprintf.c stdscanf.c stdsprintf.c stdvbuf.c \
stdputc.c stdgetc.c

11
devel/sfio/files/patch-ag Normal file
View file

@ -0,0 +1,11 @@
--- src/lib/sfio/Sfio_t/runtest.orig Sat Nov 7 15:35:55 1998
+++ src/lib/sfio/Sfio_t/runtest Sat Nov 7 15:36:11 1998
@@ -32,7 +32,7 @@
if $CC -g -I.. -I$INCLUDE $i $LIB/libsfio.a -lm -o t
then
if ./t
- then rm t; status=passed
+ then rm -f t; status=passed
else status=failed
fi
else status="Not compiled"