- Update to 1.14
PR: ports/107585 Submitted by: Daniel Roethlisberger <daniel@roe.ch> (maintainer)
This commit is contained in:
parent
1abe65568c
commit
928be63b84
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=181888
4 changed files with 16 additions and 15 deletions
|
@ -6,14 +6,14 @@
|
|||
#
|
||||
|
||||
PORTNAME= msieve
|
||||
PORTVERSION= 1.13
|
||||
PORTVERSION= 1.14
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://www.boo.net/~jasonp/ \
|
||||
http://mirror.roe.ch/dist/msieve/
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
|
||||
|
||||
MAINTAINER= daniel@roe.ch
|
||||
COMMENT= Fast factorization of big integers using MPQS and NFS
|
||||
COMMENT= Fast factorization of big integers using MPQS and GNFS
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
USE_GMAKE= yes
|
||||
|
@ -27,7 +27,7 @@ PLIST_DIRS= include/msieve
|
|||
PORTDOCS= Changes Readme Readme.nfs Readme.qs
|
||||
|
||||
OPTIONS= OCFLAGS "Enable optimized CFLAGS" On \
|
||||
NFS "Enable Number Field Sieve (EXPERIMENTAL)" Off
|
||||
GNFS "General Number Field Sieve support" On
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -35,7 +35,7 @@ OPTIONS= OCFLAGS "Enable optimized CFLAGS" On \
|
|||
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
|
||||
.endif
|
||||
|
||||
.if defined(WITH_NFS)
|
||||
.if !defined(WITHOUT_GNFS)
|
||||
LIB_DEPENDS+= gsl.9:${PORTSDIR}/math/gsl
|
||||
ALL_TARGET= nfs
|
||||
.endif
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (msieve113.tar.gz) = 88a2b7ac1cf5a67dc1d3b5861d1b03e1
|
||||
SHA256 (msieve113.tar.gz) = a9f76cdeab4c95a5facc5c9b21063ff58e5b598ddc9c480c72631cdaee13a5b9
|
||||
SIZE (msieve113.tar.gz) = 188723
|
||||
MD5 (msieve114.tar.gz) = 536957406a42230978b38e6c074d24e2
|
||||
SHA256 (msieve114.tar.gz) = 692ea969a884306f21debfaf0b5a42701ac7110a20d2d0d7a852aee45c39ed3e
|
||||
SIZE (msieve114.tar.gz) = 190549
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
--- Makefile.orig Sun Dec 31 21:10:39 2006
|
||||
+++ Makefile Wed Jan 3 01:34:16 2007
|
||||
@@ -22,21 +22,21 @@
|
||||
# WARN_FLAGS = -Wall -W -Wconversion
|
||||
--- Makefile.orig Fri Jan 5 07:22:21 2007
|
||||
+++ Makefile Fri Jan 5 16:30:18 2007
|
||||
@@ -23,21 +23,21 @@
|
||||
|
||||
# gcc for x86 and x86-64
|
||||
# gcc for x86 and x86-64; use the k8 flag below if running
|
||||
# a 64-bit operating system on a 64-bit processor
|
||||
-CC = gcc
|
||||
-OPT_FLAGS = -O3 -fomit-frame-pointer
|
||||
+#CC = gcc
|
||||
|
@ -28,7 +28,7 @@
|
|||
|
||||
COMMON_HDR = \
|
||||
include/ap.h \
|
||||
@@ -100,13 +100,13 @@
|
||||
@@ -101,13 +101,13 @@
|
||||
rm -f libmsieve.a
|
||||
ar r libmsieve.a $(OBJS)
|
||||
ranlib libmsieve.a
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
Msieve is a library and utility for factoring large integers using the most
|
||||
powerful modern algorithms. It features a stable and very fast implementation
|
||||
of a self-initializing multiple polynomial quadratic sieve (MPQS), plus a
|
||||
highly experimental and unfinished number field sieve (NFS) implementation.
|
||||
of a self-initializing multiple polynomial quadratic sieve (MPQS), plus highly
|
||||
experimental and unfinished general number field sieve (GNFS) code.
|
||||
|
||||
Primary design goals are speed, portability and ease of use. Msieve claims to
|
||||
be the fastest implementation for factoring general inputs between 40 and 100
|
||||
decimal digits.
|
||||
|
|
Loading…
Reference in a new issue