Remove expired ports:
2014-04-04 www/webobjects: Unmaintained, interactive and restricted 2014-04-04 devel/p5-Devel-LeakTrace-Fast: Broken for more than 6 months
This commit is contained in:
parent
1e132ef8ae
commit
929fabc9bd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=350085
18 changed files with 2 additions and 720 deletions
2
MOVED
2
MOVED
|
@ -5877,3 +5877,5 @@ security/aolserver-nsopenssl||2014-04-03|Has expired: abandonware, messing up on
|
|||
databases/aolserver-nspostgres||2014-04-03|Has expired: abandonware, messing up on clusters
|
||||
databases/aolserver-nsmysql||2014-04-03|Has expired: abandonware, messing up on clusters
|
||||
security/aolserver-nssha1||2014-04-03|Has expired: abandonware, messing up on clusters
|
||||
www/webobjects||2014-04-04|Has expired: Unmaintained, interactive and restricted
|
||||
devel/p5-Devel-LeakTrace-Fast||2014-04-04|Has expired: Broken for more than 6 months
|
||||
|
|
|
@ -1877,7 +1877,6 @@
|
|||
SUBDIR += p5-Devel-Leak-Object
|
||||
SUBDIR += p5-Devel-LeakGuard-Object
|
||||
SUBDIR += p5-Devel-LeakTrace
|
||||
SUBDIR += p5-Devel-LeakTrace-Fast
|
||||
SUBDIR += p5-Devel-LexAlias
|
||||
SUBDIR += p5-Devel-MAT
|
||||
SUBDIR += p5-Devel-Messenger
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
# Created by: Lars Thegler <lth@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= Devel-LeakTrace-Fast
|
||||
PORTVERSION= 0.11
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= lth@FreeBSD.org
|
||||
COMMENT= Indicate where leaked variables are coming from
|
||||
|
||||
USES= perl5
|
||||
USE_PERL5= configure
|
||||
|
||||
BROKEN= does not compile under perl >= 5.12, see https://rt.cpan.org/Public/Bug/Display.html?id=56079
|
||||
DEPRECATED= Broken for more than 6 months
|
||||
EXPIRATION_DATE= 2014-04-04
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (Devel-LeakTrace-Fast-0.11.tar.gz) = 014cf1fac607e8f003e1ea9969adfa02892b62de27a54f8e4b5c31a51f846d29
|
||||
SIZE (Devel-LeakTrace-Fast-0.11.tar.gz) = 12910
|
|
@ -1,5 +0,0 @@
|
|||
Devel::LeakTrace::Fast is a rewrite of Devel::LeakTrace. Like
|
||||
Devel::LeakTrace it uses the pluggable runops feature found in perl 5.6
|
||||
and later in order to trace SV allocations of a running program.
|
||||
|
||||
WWW: http://search.cpan.org/dist/Devel-LeakTrace-Fast/
|
|
@ -1,10 +0,0 @@
|
|||
%%SITE_PERL%%/%%PERL_ARCH%%/Devel/LeakTrace/Fast.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/LeakTrace/Fast/.packlist
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/LeakTrace/Fast/Fast.bs
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/LeakTrace/Fast/Fast.so
|
||||
%%PERL5_MAN3%%/Devel::LeakTrace::Fast.3.gz
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/LeakTrace/Fast
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/LeakTrace
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Devel/LeakTrace
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Devel
|
|
@ -2108,7 +2108,6 @@
|
|||
SUBDIR += weblint
|
||||
SUBDIR += weblint++
|
||||
SUBDIR += webmachine
|
||||
SUBDIR += webobjects
|
||||
SUBDIR += webpy
|
||||
SUBDIR += webreport
|
||||
SUBDIR += webresolve
|
||||
|
|
|
@ -1,108 +0,0 @@
|
|||
# Created by: Quinton Dolan <q@onthenet.com.au>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= webobjects
|
||||
PORTVERSION= 5.3.3
|
||||
CATEGORIES= www java
|
||||
MASTER_SITES= #
|
||||
DISTNAME= WebObjects${DISTVERSION}Update
|
||||
EXTRACT_SUFX= .pax.gz
|
||||
|
||||
MAINTAINER?= ports@FreeBSD.org
|
||||
COMMENT= WebObjects Application Server Runtime
|
||||
|
||||
IS_INTERACTIVE= yes
|
||||
RESTRICTED= License doesn't allow redistribution
|
||||
DEPRECATED= Unmaintained, interactive and restricted
|
||||
EXPIRATION_DATE= 2014-04-04
|
||||
|
||||
WOBINURL= http://www.apple.com/support/downloads/webobjects533.html
|
||||
WOPKGBUNDLE= WebObjects5.3.3Update.dmg
|
||||
WOBINARCHIVE= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
NO_BUILD= yes
|
||||
USE_RC_SUBR= wotaskd JavaMonitor
|
||||
USE_JAVA= 1.4+
|
||||
EXTRACT_PRESERVE_OWNERSHIP= yes
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.pre.mk>
|
||||
.include "${MASTERDIR}/Makefile.plist"
|
||||
|
||||
NEXT_ROOT?= ${PREFIX}/apple
|
||||
NEXT_BASE= ${NEXT_ROOT:S,^${PREFIX}/,,}
|
||||
NEXT_USER?= ${WWWOWN}
|
||||
NEXT_GROUP?= ${WWWGRP}
|
||||
SYSTEM_LIBRARY= ${NEXT_BASE}/Library
|
||||
LOCAL_LIBRARY= ${NEXT_BASE}/Local/Library
|
||||
LOCALLIB= ${PREFIX}/${LOCAL_LIBRARY}
|
||||
WOLOCAL= ${LOCALLIB}/WebObjects
|
||||
WODOCROOT?= ${WWWDIR}
|
||||
WODOCROOT_REL= ${WODOCROOT:S,^${PREFIX}/,,}
|
||||
|
||||
PLIST_SUB= NEXT_ROOT=${NEXT_BASE} WODOCROOT=${WODOCROOT_REL}
|
||||
SUB_LIST+= NEXT_ROOT=${NEXT_BASE} USER=${NEXT_USER} GROUP=${NEXT_GROUP} \
|
||||
JAVA=${JAVA} WODOCROOT=${WODOCROOT_REL}
|
||||
SUB_FILES+= pkg-message pkg-install pkg-deinstall
|
||||
|
||||
.if defined(WITH_APACHE)
|
||||
USE_APACHE?= 22+
|
||||
BUILD_DEPENDS+= ${APACHEMODDIR}/mod_WebObjects.so:${PORTSDIR}/www/mod_webobjects
|
||||
.endif
|
||||
|
||||
# Check for distribution files
|
||||
.if !exists(${DISTDIR}/${WOBPKGBUNDLE})
|
||||
IGNORE= may not be redistributed because of licensing reasons. Please visit ${WOBINURL} and download ${WOBINARCHIVE} from Apple into ${DISTDIR}
|
||||
.endif
|
||||
|
||||
do-fetch:
|
||||
# See http://wiki.objectstyle.org/confluence/display/WO/Deploying+on+FreeBSD+6.x+and+7.x+%28WO+5.3.3%29
|
||||
# for the gory details.
|
||||
dd if=${DISTDIR}/${WOPKGBUNDLE} bs=0x1000 skip=0xb12 \
|
||||
of=${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
pre-install:
|
||||
@${FIND} ${WRKSRC} -name '*.bak' -delete
|
||||
@${FIND} ${WRKSRC} -name '*.orig' -delete
|
||||
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${PREFIX}/${SYSTEM_LIBRARY}
|
||||
@${MKDIR} ${PREFIX}/${LOCAL_LIBRARY}
|
||||
@${CHMOD} -R 755 ${PREFIX}/${NEXT_BASE}
|
||||
@${ECHO_MSG} -n ">> Installing WebObjects Runtime..."
|
||||
@(cd ${WRKSRC}/System/Library && ${COPYTREE_BIN} \* \
|
||||
${PREFIX}/${SYSTEM_LIBRARY})
|
||||
@(cd ${WRKSRC}/Library && ${COPYTREE_BIN} \* \
|
||||
${PREFIX}/${LOCAL_LIBRARY})
|
||||
@${ECHO_MSG} " [ DONE ]"
|
||||
@${CHOWN} ${NEXT_USER}:${NEXT_GROUP} ${WOLOCAL}
|
||||
@${CHMOD} 0775 ${WOLOCAL}
|
||||
@${MKDIR} ${WOLOCAL}/Configuration
|
||||
@${MKDIR} ${WOLOCAL}/Applications
|
||||
@${MKDIR} ${WOLOCAL}/JavaApplications
|
||||
@${MKDIR} ${LOCALLIB}/Frameworks
|
||||
@${CHOWN} -R ${NEXT_USER}:${NEXT_GROUP} ${WOLOCAL}/Configuration
|
||||
@${CHOWN} ${NEXT_USER}:${NEXT_GROUP} ${WOLOCAL}/Applications
|
||||
@${CHOWN} ${NEXT_USER}:${NEXT_GROUP} ${WOLOCAL}/JavaApplications
|
||||
@${CHOWN} ${NEXT_USER}:${NEXT_GROUP} ${LOCALLIB}/Frameworks
|
||||
@${ECHO_MSG} -n ">> Installing WebObjects Web Resources..."
|
||||
@${MKDIR} ${WODOCROOT}
|
||||
@(cd ${WRKSRC}/System/Library/WebObjects/WODocumentRoot && \
|
||||
${COPYTREE_SHARE} \* ${WODOCROOT})
|
||||
@${ECHO_MSG} " [ DONE ]"
|
||||
|
||||
post-install:
|
||||
@(cd ${WRKSRC}/System/Library && ${PLIST_GEN} \* ${PREFIX}/${SYSTEM_LIBRARY})
|
||||
@(cd ${WRKSRC}/Library && ${PLIST_GEN} \* ${PREFIX}/${LOCAL_LIBRARY} "-mindepth 1" )
|
||||
@(cd ${WRKSRC}/System/Library/WebObjects/WODocumentRoot && \
|
||||
${PLIST_GEN} \* ${WODOCROOT})
|
||||
@${PLIST_DIRRM} ${NEXT_BASE}/Library
|
||||
@${PLIST_DIRRMTRY} ${WODOCROOT}
|
||||
@${PLIST_DIRRMTRY} ${WOLOCAL} Configuration Applications JavaApplications
|
||||
@${PLIST_DIRRMTRY} ${NEXT_BASE} Local/Library/Frameworks
|
||||
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,27 +0,0 @@
|
|||
PLIST_GEN=${SH} -c '((${ECHO_CMD} ${FIND} -d $$0 ! -type d $$2) | ${SH} | \
|
||||
${SED} -e "s,^,$$1/, ; s,^${PREFIX}/,," >> ${TMPPLIST}) && \
|
||||
((${ECHO_CMD} ${FIND} -d $$0 -type d -empty $$2) | ${SH} | \
|
||||
${SED} -e "s,^,$$1/, ; s,^${PREFIX}/,@exec mkdir -p %D/," \
|
||||
>> ${TMPPLIST}) && \
|
||||
((${ECHO_CMD} ${FIND} -d $$0 -type d $$2) | ${SH} | \
|
||||
${SED} -e "s,^,$$1/, ; s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST})' --
|
||||
PLIST_DIRRMTRY=${SH} -c '(BASE=`${ECHO_CMD} $$0 | ${SED} -e "s,^${PREFIX}/,,"` ; \
|
||||
while [ $$\# -gt 0 ] ; do \
|
||||
DIRNAME=$${1-.}; \
|
||||
while [ "$$DIRNAME" != "." ]; do \
|
||||
(${ECHO_CMD} "@unexec rmdir %D/$$BASE/$$DIRNAME 2>/dev/null || true" >> ${TMPPLIST}); \
|
||||
DIRNAME=`dirname $$DIRNAME`; \
|
||||
done; \
|
||||
shift; \
|
||||
done; \
|
||||
${ECHO_CMD} "@unexec rmdir %D/$$BASE 2>/dev/null || true" >> ${TMPPLIST};)' --
|
||||
PLIST_DIRRM=${SH} -c '(BASE=$$0; BASE=`${ECHO_CMD} $$BASE | ${SED} -e "s,^${PREFIX}/,,"` ; \
|
||||
while [ $$\# -gt 0 ] ; do \
|
||||
DIRNAME=$${1-.}; \
|
||||
while [ "$$DIRNAME" != "." ]; do \
|
||||
(${ECHO_CMD} "@dirrm $$BASE/$$DIRNAME" >> ${TMPPLIST}); \
|
||||
DIRNAME=`dirname $$DIRNAME`; \
|
||||
done; \
|
||||
shift; \
|
||||
done; \
|
||||
(${ECHO_CMD} "@dirrm $$BASE" >> ${TMPPLIST});)' --
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (WebObjects5.3.3Update.pax.gz) = c3b2fae5ca2aa0d1d9bc8e2ed4e641bdabbf43a3bf132e0bb822eb2faaca92a8
|
||||
SIZE (WebObjects5.3.3Update.pax.gz) = 30713652
|
|
@ -1,55 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# $FreeBSD$
|
||||
#
|
||||
# PROVIDE: JavaMonitor
|
||||
# REQUIRE: NETWORKING SERVERS
|
||||
# BEFORE: DAEMON
|
||||
# KEYWORD: shutdown
|
||||
#
|
||||
# Define these JavaMonitor_* variables in one of these files:
|
||||
# /etc/rc.conf
|
||||
# /etc/rc.conf.local
|
||||
#
|
||||
# DO NOT CHANGE THESE DEFAULT VALUES HERE
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="JavaMonitor"
|
||||
rcvar=JavaMonitor_enable
|
||||
|
||||
load_rc_config "$name"
|
||||
load_rc_config NEXT
|
||||
|
||||
JavaMonitor_enable="${JavaMonitor_enable-"NO"}"
|
||||
JavaMonitor_user="${JavaMonitor_user-%%USER%%}"
|
||||
JavaMonitor_flags="${JavaMonitor_flags-"-WOPort 56789"}"
|
||||
JavaMonitor_pidfile="${JavaMonitor_pidfile:-/var/run/webobjects/${name}.pid}"
|
||||
JavaMonitor_logfile="${JavaMonitor_logfile:-/var/log/webobjects/${name}.log}"
|
||||
NEXT_ROOT="${NEXT_ROOT-%%PREFIX%%/%%NEXT_ROOT%%}"
|
||||
|
||||
pidfile="${JavaMonitor_pidfile}"
|
||||
logfile="${JavaMonitor_logfile}"
|
||||
runuser="${JavaMonitor_user}"
|
||||
|
||||
procname=`basename %%JAVA%%`
|
||||
log_args=">>${logfile} 2>&1 "
|
||||
run_command="${NEXT_ROOT}/Library/WebObjects/JavaApplications/${name}.woa/${name}"
|
||||
flags="-p ${pidfile} ${run_command} ${JavaMonitor_flags}"
|
||||
command="/usr/sbin/daemon"
|
||||
command_args="${log_args}"
|
||||
|
||||
export NEXT_ROOT=${NEXT_ROOT}
|
||||
|
||||
start_precmd="start_precmd"
|
||||
|
||||
start_precmd()
|
||||
{
|
||||
if [ "x${runuser}" = "xroot" ]; then
|
||||
err 1 "You have to set ${name}_user to a non-root user for security reasons"
|
||||
fi
|
||||
touch ${pidfile} && chown ${runuser} ${pidfile}
|
||||
touch ${logfile} && chown ${runuser} ${logfile}
|
||||
}
|
||||
|
||||
run_rc_command "$1"
|
|
@ -1,14 +0,0 @@
|
|||
--- System/Library/WebObjects/JavaApplications/wotaskd.woa/Contents/Resources/SpawnOfWotaskd.sh.orig Thu Jan 11 15:46:21 2001
|
||||
+++ System/Library/WebObjects/JavaApplications/wotaskd.woa/Contents/Resources/SpawnOfWotaskd.sh Mon Apr 16 00:18:50 2007
|
||||
@@ -1,3 +1,10 @@
|
||||
#!/bin/sh
|
||||
|
||||
-$@ 1>/dev/null 2>&1 &
|
||||
+PORT=`echo $* | sed -e 's|^.*-WOPort \([0-9]*\).*|\1|'`
|
||||
+APP=`basename $1`
|
||||
+touch /var/log/webobjects/${APP}-${PORT}.log 2>&1
|
||||
+if [ $? = 0 ]; then
|
||||
+ $@ >>/var/log/webobjects/${APP}-${PORT}.log 2>&1 &
|
||||
+else
|
||||
+ $@ 1>/dev/null 2>&1 &
|
||||
+fi
|
|
@ -1,18 +0,0 @@
|
|||
--- System/Library/WebObjects/JavaApplications/wotaskd.woa/Contents/Resources/javawoservice.sh.orig Sat Oct 1 04:00:34 2005
|
||||
+++ System/Library/WebObjects/JavaApplications/wotaskd.woa/Contents/Resources/javawoservice.sh Mon Apr 16 14:26:41 2007
|
||||
@@ -255,7 +255,14 @@
|
||||
echo "javawoservice.sh: \`$APP_NAME' is starting up ..."
|
||||
|
||||
# so run the app already, sheesh
|
||||
- $APP_PATH 2>&1 >/dev/null $APP_ARGS
|
||||
+ PORT=`echo ${APP_ARGS} | sed -e 's|^.*-WOPort \([0-9]*\).*|\1|'`
|
||||
+ touch /var/log/webobjects/${APP_NAME}-${PORT}.log 2>&1
|
||||
+ if [ $? = 0 ]; then
|
||||
+ $APP_PATH $APP_ARGS >>/var/log/webobjects/${APP_NAME}-${PORT}.log 2>&1
|
||||
+ else
|
||||
+ $APP_PATH $APP_ARGS 2>&1 >/dev/null
|
||||
+ fi
|
||||
+
|
||||
EXIT_CODE="$?"
|
||||
|
||||
echo "javawoservice.sh: \`$APP_NAME' exited."
|
|
@ -1,19 +0,0 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PATH=/bin:/usr/bin:/usr/sbin
|
||||
RMDIR="/bin/rmdir"
|
||||
|
||||
case $2 in
|
||||
DEINSTALL)
|
||||
;;
|
||||
POST-DEINSTALL)
|
||||
${RMDIR} /var/log/webobjects 2>/dev/null
|
||||
${RMDIR} /var/run/webobjects 2>/dev/null
|
||||
;;
|
||||
*)
|
||||
exit 64
|
||||
esac
|
||||
exit 0
|
|
@ -1,362 +0,0 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PATH=/bin:/usr/bin:/usr/sbin
|
||||
|
||||
WOLOCAL=${PKG_PREFIX}/%%NEXT_ROOT%%/Local/Library/WebObjects
|
||||
USER=%%USER%%
|
||||
GROUP=%%GROUP%%
|
||||
MKDIR="/bin/mkdir -p"
|
||||
CHOWN=/usr/sbin/chown
|
||||
CHMOD=/bin/chmod
|
||||
|
||||
case $2 in
|
||||
PRE-INSTALL)
|
||||
;;
|
||||
POST-INSTALL)
|
||||
${MKDIR} ${WOLOCAL}/Configuration
|
||||
${MKDIR} ${WOLOCAL}/Applications
|
||||
${MKDIR} ${WOLOCAL}/JavaApplications
|
||||
${CHOWN} -R ${USER}:${GROUP} ${WOLOCAL}/Configuration
|
||||
${CHOWN} ${USER}:${GROUP} ${WOLOCAL}/Applications
|
||||
${CHOWN} ${USER}:${GROUP} ${WOLOCAL}/JavaApplications
|
||||
${MKDIR} /var/log/webobjects || exit 1
|
||||
${MKDIR} /var/run/webobjects || exit 1
|
||||
${CHOWN} ${USER}:wheel /var/log/webobjects || exit 1
|
||||
${CHOWN} ${USER}:wheel /var/run/webobjects || exit 1
|
||||
${CHMOD} 0750 /var/log/webobjects || exit 1
|
||||
${CHMOD} 0750 /var/run/webobjects || exit 1
|
||||
exit 0
|
||||
;;
|
||||
*)
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
|
||||
# Preinstall
|
||||
|
||||
more << EOF_LICENSE
|
||||
|
||||
APPLE COMPUTER, INC. SOFTWARE LICENSE AGREEMENT FOR XCODE TOOLS
|
||||
FOR MAC OS X
|
||||
|
||||
PLEASE READ THIS SOFTWARE LICENSE AGREEMENT ("LICENSE") CAREFULLY
|
||||
BEFORE USING THE APPLE SOFTWARE. BY USING THE APPLE SOFTWARE, YOU
|
||||
ARE AGREEING TO BE BOUND BY THE TERMS OF THIS LICENSE. IF YOU DO
|
||||
NOT AGREE TO THE TERMS OF THIS LICENSE, DO NOT USE THE SOFTWARE.
|
||||
IF YOU DO NOT AGREE TO THE TERMS OF THE LICENSE, YOU MAY RETURN THE
|
||||
APPLE SOFTWARE TO THE PLACE WHERE YOU OBTAINED IT FOR A REFUND. IF
|
||||
THE APPLE SOFTWARE WAS ACCESSED ELECTRONICALLY, CLICK "DISAGREE/DECLINE".
|
||||
FOR APPLE SOFTWARE INCLUDED WITH YOUR PURCHASE OF HARDWARE, YOU
|
||||
MUST RETURN THE ENTIRE HARDWARE/SOFTWARE PACKAGE IN ORDER TO OBTAIN
|
||||
A REFUND.
|
||||
|
||||
IMPORTANT NOTE: This software may be used to reproduce materials.
|
||||
It is licensed to you only for reproduction of non-copyrighted
|
||||
materials, materials in which you own the copyright, or materials
|
||||
you are authorized or legally permitted to reproduce. If you are
|
||||
uncertain about your right to copy any material you should contact
|
||||
your legal advisor.
|
||||
|
||||
1. General. The software, tools, utilities, sample or example code,
|
||||
documentation, fonts and other materials accompanying this License,
|
||||
whether on disk, print or electronic documentation, in read only
|
||||
memory, or any other media, (collectively, the Developer Software)
|
||||
are licensed, not sold, to you by Apple Computer, Inc. (Apple)
|
||||
and/or Apples licensors. The rights granted herein are limited to
|
||||
Apple's and/or Apples licensors respective intellectual property
|
||||
rights in the Developer Software and do not include any other patents
|
||||
or intellectual property rights. You own the media on which the
|
||||
Developer Software is recorded but Apple and/or Apple's licensor(s)
|
||||
retain ownership of their respective portions of the Developer
|
||||
Software itself. The terms of this License will govern any software
|
||||
upgrades provided by Apple that replace and/or supplement the
|
||||
original Developer Software, unless such upgrade is accompanied by
|
||||
a separate license in which case the terms of that license will
|
||||
govern.
|
||||
|
||||
2. Permitted License Uses and Restrictions. A. Developer Software.
|
||||
Subject to the terms below you may use the Developer Software on
|
||||
Apple-labeled computers to: (i) test the Developer Software; and
|
||||
(ii) develop application and other software. The Developer Software
|
||||
contains WebObjects development and deployment components (the
|
||||
"WebObjects Software") which are subject to the additional terms
|
||||
and conditions set forth in Section 2D below and QuickTime development
|
||||
software which is subject to the additional terms and conditions
|
||||
set forth in Section 2E below. You may make only as many internal
|
||||
use copies of the Developer Software as reasonably necessary to use
|
||||
the Developer Software as permitted under this License and distribute
|
||||
such copies only to your employees whose job duties require them
|
||||
to so use the Developer Software; provided that you reproduce on
|
||||
each copy of the Developer Software or portion thereof, all copyright
|
||||
or other proprietary notices contained on the original.
|
||||
|
||||
B. Open-Sourced Components. Certain components of the Developer
|
||||
Software, and third party open source programs included with the
|
||||
Developer Software, have been or may be made available by Apple on
|
||||
its Open Source web site (http://www.opensource.apple.com/)
|
||||
(collectively the Open-Sourced Components). You may modify or
|
||||
replace only these Open-Sourced Components; provided that: (i) the
|
||||
resultant modified Developer Software is used in accordance with
|
||||
the permitted uses set forth above; and (ii) you otherwise comply
|
||||
with the terms of this License and any applicable licensing terms
|
||||
governing use of the Open-Sourced Components. Apple is not obligated
|
||||
to provide any maintenance, technical or other support for the
|
||||
resultant modified Developer Software.
|
||||
|
||||
C. Sample Code. Certain portions of the Developer Software consist
|
||||
of sample or example code provided by Apple (Sample Code). You may
|
||||
use, reproduce, modify and redistribute such Sample Code in accordance
|
||||
with the licensing terms accompanying such Sample Code or related
|
||||
project(s).
|
||||
|
||||
D. WebObjects Software. Subject to the terms and conditions of
|
||||
this License, you may use, install and permit others to access the
|
||||
WebObjects deployment software included with the Developer Software
|
||||
to deploy application programs developed using Apples WebObjects
|
||||
Software. You may also reproduce and distribute: (1) over a
|
||||
network, components of the WebObjects deployment software for
|
||||
installation and use by others (Java Client End Users) on any remote
|
||||
computers volatile memory (e.g. RAM) to enable Java Client functionality
|
||||
for the sole purpose of communicating with Apples WebObjects Software
|
||||
that may be installed and executed on the same Apple-labeled computer
|
||||
on which you have installed the Developer Software (the "Licensed
|
||||
System"); and (2) both manually and automatically over a network,
|
||||
components of the WebObjects deployment software for installation
|
||||
and use by Java Client End Users on any remote computers non-volatile
|
||||
memory (e.g. ROM) to enable Java Client functionality for the sole
|
||||
purpose of communicating with Apples WebObjects Software that may
|
||||
be installed and executed on the Licensed System; provided that all
|
||||
distributions to Java Client End Users are made under terms that
|
||||
are at least as restrictive as those set forth in this License and
|
||||
contain the disclaimers and limitations set forth in Sections 6 and
|
||||
7 of this License. Subject to the terms and conditions of this
|
||||
License, you may also deploy server applications built with the
|
||||
WebObjects Software on any platform.
|
||||
|
||||
E. QuickTime Development Software. You may use the QuickTime
|
||||
development software to develop application software that is
|
||||
compatible with, and runs only on Mac OS X and/or Windows platforms
|
||||
with QuickTime installed. Your software application may not interfere
|
||||
with the functionality of QuickTime Player or the QuickTime Plug-in,
|
||||
including but not limited to file type or MIME type associations
|
||||
that are registered to QuickTime.
|
||||
|
||||
F. Other Restrictions. Except as and only to the extent expressly
|
||||
permitted by this License, by applicable licensing terms governing
|
||||
use of the Open-Sourced Components or Sample Code, or by applicable
|
||||
law, you may not copy, decompile, reverse engineer, disassemble,
|
||||
modify, create derivative works of, incorporate into or compile in
|
||||
combination with your own programs, sublicense or otherwise
|
||||
redistribute the Developer Software. THE DEVELOPER SOFTWARE IS NOT
|
||||
INTENDED FOR USE IN THE OPERATION OF NUCLEAR FACILITIES, AIRCRAFT
|
||||
NAVIGATION OR COMMUNICATION SYSTEMS, AIR TRAFFIC CONTROL SYSTEMS,
|
||||
LIFE SUPPORT MACHINES OR OTHER EQUIPMENT IN WHICH THE FAILURE OF
|
||||
THE DEVELOPER SOFTWARE COULD LEAD TO DEATH, PERSONAL INJURY, OR
|
||||
SEVERE PHYSICAL OR ENVIRONMENTAL DAMAGE.
|
||||
|
||||
3. Transfer. You may not rent, lease, lend, redistribute or
|
||||
sublicense the Developer Software. You may, however, make a one-time
|
||||
permanent transfer of all of your license rights to the Developer
|
||||
Software (in its original form as provided by Apple) to another
|
||||
party, provided that: (a) the transfer must include all of the
|
||||
Developer Software, including all its component parts, original
|
||||
media, printed materials and this License; (b) you do not retain
|
||||
any copies of the Developer Software, full or partial, including
|
||||
copies stored on a computer or other storage device; and (c) the
|
||||
party receiving the Developer Software reads and agrees to accept
|
||||
the terms and conditions of this License. You may not rent, lease,
|
||||
lend, redistribute, sublicense or transfer any Developer Software
|
||||
that has been modified or replaced under Section 2B above. All
|
||||
components of the Developer Software are provided as part of a
|
||||
bundle and may not be separated from the bundle and distributed as
|
||||
standalone applications.
|
||||
|
||||
NFR (Not for Resale) Copies: Notwithstanding other sections of
|
||||
this License, Developer Software labeled or otherwise provided to
|
||||
you on a promotional basis may only be used for demonstration,
|
||||
testing and evaluation purposes and may not be resold or transferred.
|
||||
|
||||
4. Termination. This License is effective until terminated. Your
|
||||
rights under this License will terminate automatically without
|
||||
notice from Apple if you fail to comply with any term(s) of this
|
||||
License. In addition, Apple reserves the right to terminate this
|
||||
License if a new version of Apple's operating system software or
|
||||
the Developer Software is released which is incompatible with this
|
||||
version of the Developer Software. Upon the termination of this
|
||||
License, you shall cease all use of the Developer Software and
|
||||
destroy all copies, full or partial, of the Developer Software.
|
||||
|
||||
5. Limited Warranty on Media (if any). Apple warrants the media
|
||||
on which the Developer Software is recorded and delivered by Apple
|
||||
to be free from defects in materials and workmanship under normal
|
||||
use for a period of ninety (90) days from the date of original
|
||||
retail purchase. Your exclusive remedy under this Section shall
|
||||
be, at Apples option, a refund of the purchase price of the product
|
||||
containing the Developer Software or replacement of the Developer
|
||||
Software which is returned to Apple or an Apple authorized
|
||||
representative with a copy of the receipt. THIS LIMITED WARRANTY
|
||||
AND ANY IMPLIED WARRANTIES ON THE MEDIA INCLUDING, BUT NOT LIMITED
|
||||
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, OF SATISFACTORY
|
||||
QUALITY, AND OF FITNESS FOR A PARTICULAR PURPOSE, ARE LIMITED IN
|
||||
DURATION TO NINETY (90) DAYS FROM THE DATE OF ORIGINAL RETAIL
|
||||
PURCHASE. SOME JURISDICTIONS DO NOT ALLOW LIMITATIONS ON HOW LONG
|
||||
AN IMPLIED WARRANTY LASTS, SO THE ABOVE LIMITATION MAY NOT APPLY
|
||||
TO YOU. THE LIMITED WARRANTY SET FORTH HEREIN IS THE ONLY WARRANTY
|
||||
MADE TO YOU AND IS PROVIDED IN LIEU OF ANY OTHER WARRANTIES (IF
|
||||
ANY) CREATED BY ANY DOCUMENTATION, PACKAGING OR OTHERWISE. THIS
|
||||
LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS, AND YOU MAY ALSO
|
||||
HAVE OTHER RIGHTS WHICH VARY BY JURISDICTION.
|
||||
|
||||
6. Disclaimer of Warranties. YOU EXPRESSLY ACKNOWLEDGE AND AGREE
|
||||
THAT USE OF THE DEVELOPER SOFTWARE IS AT YOUR SOLE RISK AND THAT
|
||||
THE ENTIRE RISK AS TO SATISFACTORY QUALITY, PERFORMANCE, ACCURACY
|
||||
AND EFFORT IS WITH YOU. EXCEPT FOR THE LIMITED WARRANTY ON MEDIA
|
||||
SET FORTH ABOVE AND TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE
|
||||
LAW, THE DEVELOPER SOFTWARE IS PROVIDED AS IS, WITH ALL FAULTS AND
|
||||
WITHOUT WARRANTY OF ANY KIND, AND APPLE AND APPLE'S LICENSORS
|
||||
(COLLECTIVELY REFERRED TO AS APPLE FOR THE PURPOSES OF SECTIONS 6
|
||||
AND 7) HEREBY DISCLAIM ALL WARRANTIES AND CONDITIONS WITH RESPECT
|
||||
TO THE DEVELOPER SOFTWARE, EITHER EXPRESS, IMPLIED OR STATUTORY,
|
||||
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES AND/OR
|
||||
CONDITIONS OF MERCHANTABILITY, OF SATISFACTORY QUALITY, OF FITNESS
|
||||
FOR A PARTICULAR PURPOSE, OF ACCURACY, OF QUIET ENJOYMENT, AND
|
||||
NON-INFRINGEMENT OF THIRD PARTY RIGHTS. APPLE DOES NOT WARRANT
|
||||
AGAINST INTERFERENCE WITH YOUR ENJOYMENT OF THE DEVELOPER SOFTWARE,
|
||||
THAT THE FUNCTIONS CONTAINED IN THE DEVELOPER SOFTWARE WILL MEET
|
||||
YOUR REQUIREMENTS, THAT THE OPERATION OF THE DEVELOPER SOFTWARE
|
||||
WILL BE UNINTERRUPTED OR ERROR-FREE, OR THAT DEFECTS IN THE DEVELOPER
|
||||
SOFTWARE WILL BE CORRECTED. NO ORAL OR WRITTEN INFORMATION OR ADVICE
|
||||
GIVEN BY APPLE OR AN APPLE AUTHORIZED REPRESENTATIVE SHALL CREATE
|
||||
A WARRANTY. SHOULD THE DEVELOPER SOFTWARE PROVE DEFECTIVE, YOU
|
||||
ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR OR
|
||||
CORRECTION. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED
|
||||
WARRANTIES OR LIMITATIONS ON APPLICABLE STATUTORY RIGHTS OF A
|
||||
CONSUMER, SO THE ABOVE EXCLUSION AND LIMITATIONS MAY NOT APPLY TO
|
||||
YOU.
|
||||
|
||||
7. Limitation of Liability. TO THE EXTENT NOT PROHIBITED BY LAW,
|
||||
IN NO EVENT SHALL APPLE BE LIABLE FOR PERSONAL INJURY, OR ANY
|
||||
INCIDENTAL, SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES WHATSOEVER,
|
||||
INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF PROFITS, LOSS
|
||||
OF DATA, BUSINESS INTERRUPTION OR ANY OTHER COMMERCIAL DAMAGES OR
|
||||
LOSSES, ARISING OUT OF OR RELATED TO YOUR USE OR INABILITY TO USE
|
||||
THE DEVELOPER SOFTWARE, HOWEVER CAUSED, REGARDLESS OF THE THEORY
|
||||
OF LIABILITY (CONTRACT, TORT OR OTHERWISE) AND EVEN IF APPLE HAS
|
||||
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME JURISDICTIONS
|
||||
DO NOT ALLOW THE LIMITATION OF LIABILITY FOR PERSONAL INJURY, OR
|
||||
OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS LIMITATION MAY NOT
|
||||
APPLY TO YOU. In no event shall Apple's total liability to you for
|
||||
all damages (other than as may be required by applicable law in
|
||||
cases involving personal injury) exceed the amount of fifty dollars
|
||||
($50.00). The foregoing limitations will apply even if the above
|
||||
stated remedy fails of its essential purpose.
|
||||
|
||||
8. Export Control. You may not use or otherwise export or reexport
|
||||
the Developer Software except as authorized by United States law
|
||||
and the laws of the jurisdiction in which the Apple Software was
|
||||
obtained. In particular, but without limitation, the Apple Software
|
||||
may not be exported or re-exported (a) into any U.S. embargoed
|
||||
countries or (b) to anyone on the U.S. Treasury Department's list
|
||||
of Specially Designated Nationals or the U.S. Department of Commerce
|
||||
Denied Persons List or Entity List. By using the Apple Software,
|
||||
you represent and warrant that you are not located in any such
|
||||
country or on any such list. You also agree that you will not use
|
||||
these products for any purposes prohibited by United States law,
|
||||
including, without limitation, the development, design, manufacture
|
||||
or production of nuclear, missiles, or chemical or biological
|
||||
weapons.
|
||||
|
||||
9. Government End Users. The Developer Software and related
|
||||
documentation are Commercial Items, as that term is defined at 48
|
||||
C.F.R. 2.101, consisting of Commercial Computer Software and
|
||||
Commercial Computer Software Documentation, as such terms are used
|
||||
in 48 C.F.R. 12.212 or 48 C.F.R. 227.7202, as applicable. Consistent
|
||||
with 48 C.F.R. 12.212 or 48 C.F.R. 227.7202-1through 227.7202-4,
|
||||
as applicable, the Commercial Computer Software and Commercial
|
||||
Computer Software Documentation are being licensed to U.S. Government
|
||||
end users (a) only as Commercial Items and (b) with only those
|
||||
rights as are granted to all other end users pursuant to the terms
|
||||
and conditions herein. Unpublished-rights reserved under the
|
||||
copyright laws of the United States.
|
||||
|
||||
10. Controlling Law and Severability. This License will be governed
|
||||
by and construed in accordance with the laws of the State of
|
||||
California, as applied to agreements entered into and to be performed
|
||||
entirely within California between California residents. This License
|
||||
shall not be governed by the United Nations Convention on Contracts
|
||||
for the International Sale of Goods, the application of which is
|
||||
expressly excluded. If for any reason a court of competent jurisdiction
|
||||
finds any provision, or portion thereof, to be unenforceable, the
|
||||
remainder of this License shall continue in full force and effect.
|
||||
|
||||
11. Complete Agreement. This License constitutes the entire agreement
|
||||
between the parties with respect to the use of the Developer Software
|
||||
licensed hereunder and supersedes all prior or contemporaneous
|
||||
understandings regarding such subject matter. No amendment to or
|
||||
modification of this License will be binding unless in writing and
|
||||
signed by Apple. The parties hereto confirm that they have requested
|
||||
that this License and all related documents be drafted in English.
|
||||
|
||||
12. Third Party Acknowledgements. A. Portions of the Developer
|
||||
Software utilize or include third party software and other copyrighted
|
||||
material. Acknowledgements, licensing terms and disclaimers for
|
||||
such material are contained in the online electronic documentation
|
||||
for the Developer Software or may otherwise accompany such material,
|
||||
and your use of such material is governed by their respective terms.
|
||||
|
||||
B. Certain software libraries and other third party software
|
||||
included with the Developer Software are free software and licensed
|
||||
under the terms of the GNU General Public License (GPL) or the GNU
|
||||
Library/Lesser General Public License (LGPL), as the case may be.
|
||||
You may obtain a complete machine-readable copy of the source code
|
||||
for such free software under the terms of the GPL or LGPL, as the
|
||||
case may be, without charge except for the cost of media, shipping,
|
||||
and handling, upon written request to Apple. The GPL/LGPL software
|
||||
is distributed in the hope that it will be useful, but WITHOUT ANY
|
||||
WARRANTY, without even the implied warranty of MERCHANTABILITY or
|
||||
FITNESS FOR A PARTICULAR PURPOSE. A copy of the GPL and LGPL is
|
||||
included with the Developer Software.
|
||||
|
||||
C. The Developer Software includes certain software developed by
|
||||
IBM Corporation (IBM) and licensed by Apple under the IBM Public
|
||||
License Version 1.0. A copy of the source code for the IBM software
|
||||
may be found in Apples Open Source repository. See Apple's Open
|
||||
Source web site (http://www.opensource.apple.com/) for information
|
||||
on how to obtain the source code. THE IBM SOFTWARE IS PROVIDED ON
|
||||
AN AS IS BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, EITHER
|
||||
EXPRESS OR IMPLIED INCLUDING, WITHOUT LIMITATION, ANY WARRANTIES
|
||||
OR CONDITIONS OF TITLE, NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
|
||||
FOR A PARTICULAR PURPOSE. NEITHER APPLE, IBM NOR ANY OTHER CONTRIBUTOR
|
||||
TO THE IBM SOFTWARE SHALL HAVE ANY LIABILITY FOR ANY DIRECT, INDIRECT,
|
||||
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
|
||||
WITHOUT LIMITATION, LOST PROFITS), HOWEVER CAUSED AND ON ANY THEORY
|
||||
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
|
||||
USE OR DISTRIBUTION OF THE IBM SOFTWARE OR THE EXERCISE OF ANY
|
||||
RIGHTS GRANTED HEREUNDER, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
SUCH DAMAGES.
|
||||
|
||||
EA0302 Rev B, 5/11/06
|
||||
|
||||
EOF_LICENSE
|
||||
|
||||
agreed=
|
||||
while [ x$agreed = x ]; do
|
||||
echo
|
||||
echo "Do you agree to the above license terms? [yes or no] "
|
||||
read reply leftover
|
||||
case $reply in
|
||||
y* | Y*)
|
||||
agreed=1
|
||||
;;
|
||||
n* | n*)
|
||||
echo
|
||||
echo "If you don't agree to the license you can't install this software"
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
done
|
||||
exit 0
|
|
@ -1,15 +0,0 @@
|
|||
*****************************************************************************
|
||||
|
||||
The WebObjects Runtime is now installed.
|
||||
|
||||
Add wotaskd_enable="YES" and JavaMonitor_enable="YES" to rc.conf as required
|
||||
and start each application by running:
|
||||
%%PREFIX%%/etc/rc.d/wotaskd start
|
||||
%%PREFIX%%/etc/rc.d/JavaMonitor start
|
||||
|
||||
Your WebObjectDocumentRoot has been created in %%PREFIX%%/%%WODOCROOT%%/WebObjects
|
||||
You will need to direct your webserver to use this path for /WebObjects URI's
|
||||
|
||||
Logs for all WebObjects applications can be found in /var/log/webobjects
|
||||
|
||||
*****************************************************************************
|
|
@ -1,54 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# $FreeBSD$
|
||||
#
|
||||
# PROVIDE: wotaskd
|
||||
# REQUIRE: NETWORKING SERVERS
|
||||
# BEFORE: DAEMON
|
||||
# KEYWORD: shutdown
|
||||
#
|
||||
# Define these wotaskd_* variables in one of these files:
|
||||
# /etc/rc.conf
|
||||
# /etc/rc.conf.local
|
||||
#
|
||||
# DO NOT CHANGE THESE DEFAULT VALUES HERE
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="wotaskd"
|
||||
rcvar=wotaskd_enable
|
||||
|
||||
load_rc_config "$name"
|
||||
load_rc_config NEXT
|
||||
|
||||
wotaskd_enable="${wotaskd_enable-"NO"}"
|
||||
wotaskd_user="${wotaskd_user-%%USER%%}"
|
||||
wotaskd_pidfile="${wotaskd_pidfile:-/var/run/webobjects/${name}.pid}"
|
||||
wotaskd_logfile="${wotaskd_logfile:-/var/log/webobjects/${name}.log}"
|
||||
NEXT_ROOT="${NEXT_ROOT-%%PREFIX%%/%%NEXT_ROOT%%}"
|
||||
|
||||
pidfile="${wotaskd_pidfile}"
|
||||
logfile="${wotaskd_logfile}"
|
||||
runuser="${wotaskd_user}"
|
||||
|
||||
procname=`basename %%JAVA%%`
|
||||
log_args=">>${logfile} 2>&1 "
|
||||
run_command="${NEXT_ROOT}/Library/WebObjects/JavaApplications/${name}.woa/${name}"
|
||||
flags="-p ${pidfile} ${run_command} ${wotaskd_flags}"
|
||||
command="/usr/sbin/daemon"
|
||||
command_args="${log_args}"
|
||||
|
||||
export NEXT_ROOT=${NEXT_ROOT}
|
||||
|
||||
start_precmd="start_precmd"
|
||||
|
||||
start_precmd()
|
||||
{
|
||||
if [ "x${runuser}" = "xroot" ]; then
|
||||
err 1 "You have to set ${name}_user to a non-root user for security reasons"
|
||||
fi
|
||||
touch ${pidfile} && chown ${runuser} ${pidfile}
|
||||
touch ${logfile} && chown ${runuser} ${logfile}
|
||||
}
|
||||
|
||||
run_rc_command "$1"
|
|
@ -1,7 +0,0 @@
|
|||
WebObjects runtime is the deployment environment for Apple WebObjects
|
||||
Applications.
|
||||
|
||||
WebObjects is a suite of tools and object-oriented frameworks that enable
|
||||
you to create and deploy web applications and web services using Java.
|
||||
|
||||
WWW: http://www.apple.com/webobjects
|
Loading…
Reference in a new issue