Import of libxalloc version 1.0.3.

A memory allocation library with error checking.

PR:		6474
Submitted by:	Andrey Zakhvatov <andy@icc.surw.chel.su>
This commit is contained in:
Steve Price 1999-04-03 01:23:32 +00:00
parent 0f4a701afd
commit 93071141f4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17581
6 changed files with 74 additions and 0 deletions

26
devel/libxalloc/Makefile Normal file
View file

@ -0,0 +1,26 @@
# New ports collection makefile for: libxalloc
# Version required: 1.0.3
# Date created: 12 April 1998
# Whom: Andrey Zakhvatov
#
# $Id$
#
DISTNAME= xalloc-1.0.3
PKGNAME= libxalloc-1.0.3
CATEGORIES= devel
MASTER_SITES= http://home.sol.no/~sverrehu/pub-unix/files/
MAINTAINER= andy@icc.surw.chel.su
USE_GMAKE= yes
post-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/libxalloc
@ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/libxalloc
@ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/libxalloc
.endif
.include <bsd.port.mk>

1
devel/libxalloc/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (xalloc-1.0.3.tar.gz) = 64ba37476b6b47c9fc2ea63c1e1f53d5

View file

@ -0,0 +1,35 @@
--- Makefile.orig Sun Jul 5 12:15:59 1998
+++ Makefile Fri Apr 2 15:26:22 1999
@@ -8,10 +8,10 @@
###########################################################################
# Define SHARED as 1 for Linux shared ELF library
-#SHARED = 1
+SHARED = 1
ifeq ($(SHARED),1)
-LIBTARGET = lib$(DIST).so.$(VERSION)
+LIBTARGET = lib$(DIST).so.$(VERMAJ)
LIBTARGETSO = lib$(DIST).so
LIBTARGETSOMAJ = $(LIBTARGETSO).$(VERMAJ)
CCSHRD = -fPIC
@@ -27,7 +27,7 @@
INSTBASEDIR = /usr/local
INSTLIBDIR = $(INSTBASEDIR)/lib
INSTINCDIR = $(INSTBASEDIR)/include
-INSTALL = install -m 644
+INSTALL = install -c -m 644
MKDIRP = install -d -m 755
###########################################################################
@@ -66,9 +66,7 @@
$(INSTALL) $(LIBTARGET) $(INSTLIBDIR)
$(INSTALL) $(LIBHEAD) $(INSTINCDIR)
ifeq ($(SHARED),1)
- ln -sf $(LIBTARGET) $(INSTLIBDIR)/$(LIBTARGETSOMAJ)
- ln -sf $(LIBTARGETSOMAJ) $(INSTLIBDIR)/$(LIBTARGETSO)
- echo "If you use GNU/Linux, remember to run ldconfig"
+ ln -sf $(LIBTARGET) $(INSTLIBDIR)/$(LIBTARGETSO)
endif
clean:

View file

@ -0,0 +1 @@
A memory allocation library with error checking.

View file

@ -0,0 +1,3 @@
xalloc is a memory allocation library with error checking.
It contains wrappers including error checking for memory
allocating C-functions.

View file

@ -0,0 +1,8 @@
include/xalloc.h
lib/libxalloc.so
lib/libxalloc.so.1
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/doc/libxalloc/CREDITS
share/doc/libxalloc/README
@dirrm share/doc/libxalloc