Add httpry:
"httpry is a specialized packet sniffer designed for displaying and logging HTTP traffic. It is not intended to perform analysis itself, but to capture, parse, and log the traffic for later analysis. It can be run in real-time displaying the traffic as it is parsed, or as a daemon process that logs to an output file. It is written to be as lightweight and flexible as possible, so that it can be easily adaptable to different applications." WWW: http://dumpsterventures.com/jason/httpry/ Submitted by: Richard Bejtlich (private mail)
This commit is contained in:
parent
af0631e91b
commit
9308e76c8e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=214799
7 changed files with 130 additions and 0 deletions
|
@ -213,6 +213,7 @@
|
|||
SUBDIR += htpdate
|
||||
SUBDIR += http_ping
|
||||
SUBDIR += httping
|
||||
SUBDIR += httpry
|
||||
SUBDIR += iaxmodem
|
||||
SUBDIR += icmpinfo
|
||||
SUBDIR += icpld
|
||||
|
|
50
net/httpry/Makefile
Normal file
50
net/httpry/Makefile
Normal file
|
@ -0,0 +1,50 @@
|
|||
# New ports collection makefile for: httpry
|
||||
# Date created: 12 June 2008
|
||||
# Whom: Wesley Shields <wxs@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= httpry
|
||||
PORTVERSION= 0.1.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://dumpsterventures.com/jason/httpry/
|
||||
|
||||
MAINTAINER= wxs@FreeBSD.org
|
||||
COMMENT= Packet sniffer designed for displaying and logging HTTP traffic
|
||||
|
||||
MAN1= httpry.1
|
||||
|
||||
USE_RC_SUBR= httpry
|
||||
|
||||
OPTIONS= EXTRASCRIPTS "Install additional scripts" Off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_EXTRASCRIPTS)
|
||||
PLIST_SUB= EXTRASCRIPTS=""
|
||||
USE_PERL5_RUN= yes
|
||||
RUN_DEPENDS= ${SITE_PERL}/IO/Compress/Gzip.pm:${PORTSDIR}/archivers/p5-IO-Compress-Zlib \
|
||||
${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
|
||||
.else
|
||||
PLIST_SUB= EXTRASCRIPTS="@comment "
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -E -e 's#^(\/etc.*)#${PREFIX}\1#' ${WRKSRC}/scripts/process_logs
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
|
||||
.if defined(WITH_EXTRASCRIPTS)
|
||||
${MKDIR} ${PREFIX}/bin/httpry-scripts
|
||||
(cd ${WRKSRC}/scripts/ && \
|
||||
${COPYTREE_BIN} \* ${PREFIX}/bin/httpry-scripts "! -name *.bak")
|
||||
.endif
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/perl-tools ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/format-string ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
net/httpry/distinfo
Normal file
3
net/httpry/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (httpry-0.1.3.tar.gz) = 3d91e672272054e0bebd9ef9bab38a50
|
||||
SHA256 (httpry-0.1.3.tar.gz) = ca3c464a95f4b70b9b857e0df7288bdab7eaa95d0a0f26a096e0cb01fb068ea0
|
||||
SIZE (httpry-0.1.3.tar.gz) = 40720
|
30
net/httpry/files/httpry.in
Normal file
30
net/httpry/files/httpry.in
Normal file
|
@ -0,0 +1,30 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
# PROVIDE: httpry
|
||||
# REQUIRE: DAEMON
|
||||
# KEYWORD: shutdown
|
||||
#
|
||||
# Add the following lines to /etc/rc.conf to enable httpry:
|
||||
#
|
||||
# httpry_enable (bool): Set it to "YES" to enable httpry
|
||||
# Default is "NO".
|
||||
# httpry_flags (flags): Set extra flags to httpry
|
||||
# Default is "-d -q -o /var/log/httpry.log".
|
||||
# See httpry(1) for more information.
|
||||
#
|
||||
|
||||
. %%RC_SUBR%%
|
||||
|
||||
name=httpry
|
||||
rcvar=${name}_enable
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
: ${httpry_enable="NO"}
|
||||
: ${httpry_flags="-d -q -o /var/log/httpry.log"}
|
||||
|
||||
command=%%PREFIX%%/bin/httpry
|
||||
|
||||
run_rc_command "$1"
|
12
net/httpry/files/patch-Makefile
Normal file
12
net/httpry/files/patch-Makefile
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- ./Makefile.orig 2008-02-08 00:48:09.000000000 -0500
|
||||
+++ ./Makefile 2008-06-12 18:53:14.000000000 -0400
|
||||
@@ -6,8 +6,7 @@
|
||||
# Copyright (c) 2005-2008 Jason Bittel <jason.bittel@gmail.com>
|
||||
#
|
||||
|
||||
-CC = gcc
|
||||
-CCFLAGS = -Wall -O3 -funroll-loops -I/usr/include/pcap -I/usr/local/include/pcap
|
||||
+CCFLAGS = ${CFLAGS} -I/usr/include/pcap -I/usr/local/include/pcap
|
||||
DEBUGFLAGS = -Wall -g -DDEBUG -I/usr/include/pcap -I/usr/local/include/pcap
|
||||
LIBS = -lpcap
|
||||
PROG = httpry
|
8
net/httpry/pkg-descr
Normal file
8
net/httpry/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
"httpry is a specialized packet sniffer designed for displaying and logging
|
||||
HTTP traffic. It is not intended to perform analysis itself, but to capture,
|
||||
parse, and log the traffic for later analysis. It can be run in real-time
|
||||
displaying the traffic as it is parsed, or as a daemon process that logs to an
|
||||
output file. It is written to be as lightweight and flexible as possible, so
|
||||
that it can be easily adaptable to different applications."
|
||||
|
||||
WWW: http://dumpsterventures.com/jason/httpry/
|
26
net/httpry/pkg-plist
Normal file
26
net/httpry/pkg-plist
Normal file
|
@ -0,0 +1,26 @@
|
|||
bin/httpry
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/parse_log.pl
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/rotate_log.pl
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/process_logs
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/db_dump.mysql
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/find_proxies.pm
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/db_dump.cfg
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/content_analysis.pm
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/hostnames.pm
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/search_terms.pm
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/find_proxies.cfg
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/log_summary.pm
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/xml_output.css
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/hostnames.cfg
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/xml_output.pm
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/xml_output.cfg
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/db_dump.pm
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/content_analysis.cfg
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/search_terms.cfg
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/sample_plugin.pm
|
||||
%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/log_summary.cfg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/perl-tools
|
||||
%%PORTDOCS%%%%DOCSDIR%%/format-string
|
||||
%%EXTRASCRIPTS%%@dirrm bin/httpry-scripts/plugins
|
||||
%%EXTRASCRIPTS%%@dirrm bin/httpry-scripts
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue