- Use DISTVERSIONPREFIX instead of DISTNAME

- Do not touch PREFIX/lib/node_modules and leave it for www/npm
- Strip binary executable
- Remove duplicate ECHO_MSG in post-install: since pkg-message presents
- Use @(owner,group,mode) syntax instead of CHMOD
- Regenerate patch file with makepatch:
- Bump PORTREVISION for package change

Submitted by:	sunpoet (myself)
Approved by:	Jin-Sih Lin <linpct@gmail.com> (maintainer)
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2015-06-01 20:13:42 +00:00
parent 06e009b18e
commit 93a9debe4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=388277
3 changed files with 9 additions and 15 deletions

View file

@ -3,11 +3,11 @@
PORTNAME= node
PORTVERSION= 0.10.38
PORTREVISION= 1
DISTVERSIONPREFIX= v
PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
PKGNAMESUFFIX= 010
DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= linpct@gmail.com
COMMENT= V8 JavaScript for client and server
@ -52,11 +52,6 @@ post-patch:
${WRKSRC}/deps/v8/tools/gyp/v8.gyp
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/node_modules/
${TOUCH} ${STAGEDIR}${PREFIX}/lib/node_modules/.keepme
${CHMOD} ${MANMODE} ${STAGEDIR}${PREFIX}/man/man1/node.1
@${ECHO_MSG}
@${ECHO_MSG} "Note: If you need npm (Node Package Manager), please install www/npm."
@${ECHO_MSG}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/node
.include <bsd.port.post.mk>

View file

@ -1,6 +1,6 @@
--- deps/v8/src/platform-freebsd.cc.orig 2015-05-09 09:01:07.000000000 +0800
+++ deps/v8/src/platform-freebsd.cc 2015-05-09 09:02:25.000000000 +0800
@@ -343,7 +343,7 @@
--- deps/v8/src/platform-freebsd.cc.orig 2015-03-23 19:23:33 UTC
+++ deps/v8/src/platform-freebsd.cc
@@ -343,7 +343,7 @@ VirtualMemory::VirtualMemory(size_t size
void* reservation = mmap(OS::GetRandomMmapAddr(),
request_size,
PROT_NONE,
@ -9,7 +9,7 @@
kMmapFd,
kMmapFdOffset);
if (reservation == MAP_FAILED) return;
@@ -415,7 +415,7 @@
@@ -415,7 +415,7 @@ void* VirtualMemory::ReserveRegion(size_
void* result = mmap(OS::GetRandomMmapAddr(),
size,
PROT_NONE,
@ -18,7 +18,7 @@
kMmapFd,
kMmapFdOffset);
@@ -445,7 +445,7 @@
@@ -445,7 +445,7 @@ bool VirtualMemory::UncommitRegion(void*
return mmap(base,
size,
PROT_NONE,

View file

@ -26,5 +26,4 @@ include/node/v8-profiler.h
include/node/v8-testing.h
include/node/v8.h
include/node/v8stdint.h
lib/node_modules/.keepme
man/man1/node.1.gz
@(,,444) man/man1/node.1.gz