devel/bazel: Update to 0.26.0

PR:		238185
Submitted by:	Klaus Aehlig <aehlig@linta.de> (maintainer)
This commit is contained in:
Steve Wills 2019-05-28 11:31:20 +00:00
parent 935bc51e78
commit 93b477def5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=502889
3 changed files with 6 additions and 17 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bazel
DISTVERSION= 0.25.0
DISTVERSION= 0.26.0
CATEGORIES= devel java
MASTER_SITES= https://storage.googleapis.com/bazel/${PORTVERSION}/rc${FINALRC}/
DISTNAME= bazel-${PORTVERSION}rc${FINALRC}-dist
@ -24,7 +24,7 @@ BUILD_DEPENDS= bash:shells/bash \
# In bazel, a release is always code-wise identical to the final release candidate.
# Hence we can also download that one and so have a simple way to also test earlier release
# candidates.
FINALRC= 8
FINALRC= 16
USES= shebangfix zip:infozip python
SHEBANG_REGEX= .*(sh|txt|_stub|stub_.*|bazel|get_workspace_status|protobuf_support|_so)
@ -41,7 +41,7 @@ STRIP= # The bazel binary is also a zip archive (extracted by the elf part), it
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
EXTRA_PATCHES+= ${FILESDIR}/extra-i386_src_BUILD ${FILESDIR}/extra-i386_tools_cpp_BUILD.static.freebsd
EXTRA_PATCHES+= ${FILESDIR}/extra-i386_tools_cpp_BUILD.static.freebsd
.endif
# Have the location of the system-wide rc file reside ${ETCDIR}.

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1556707468
SHA256 (bazel-0.25.0rc8-dist.zip) = 68bd06162f79cdca0c7932725eee0db22a432b73fbab1821391706eaa473f18b
SIZE (bazel-0.25.0rc8-dist.zip) = 275800512
TIMESTAMP = 1558938094
SHA256 (bazel-0.26.0rc16-dist.zip) = e7db1cd14b0905f766dfdbf13b802c1d9ebd1c08dd2c646b4216d4d746ada87f
SIZE (bazel-0.26.0rc16-dist.zip) = 244629965

View file

@ -1,11 +0,0 @@
--- src/BUILD.orig 1980-01-01 00:00:00.000000000 +0000
+++ src/BUILD 2019-02-06 14:36:18.532824000 +0000
@@ -131,7 +131,7 @@
] + select({
"//src/conditions:arm": [],
"//conditions:default": [
- "//src/tools/singlejar:singlejar_local",
+ "//src/java_tools/singlejar:SingleJar_deploy.jar",
],
})