graphics/netpbm: Update to 11.04.01

https://sourceforge.net/p/netpbm/code/4700/tree/advanced/doc/HISTORY

Changes since 11.04.00:

 - pjtoppm: fix crash based on uninitialized variable. Introduced
   in Netpbm 11.04 (two days ago).

 - Build: Fix compile error on systems without 'asprintf'. Introduced
   in Netpbm 11.04 (yesterday).

Changes since 11.03.06:

 - pamaddnoise: add -salt.

 - pamaddnoise: reject options that aren't meaningful for the type
   of noise specified rather than just ignore them.

 - ppmtosixel: Add -7bit, so it works on more terminals, including
   xterms.  Thanks Scott Pakin.

 - g3topbm: Add -correctlong

 - build: Add COMPILED_BY environment variable to control the
   "compiled by" value from --version common option.  This helps
   with creating reproducible builds.

 - pnmtojpeg: minor improvement to error messages about bad files.

 - pammixmulti: Remove disclaimer of patent license.

 - pgmtexture: Fix bug: ignores -d.  Introduced in Netpbm 10.56
   (September 2011).

 - pbmtopgm: Fix error message for excessive -width.

 - tifftopnm: Fix incorrect output with insanely wide/deep rows.

 - thinkjettopbm: Fix incorrect output with insanely wide rows.

 - ybmtopbm: Fix incorrect output with insanely wide rows.

 - pjtoppm: Fix incorrect output with insanely large number of rows.

 - library: add check of maxval for computable size.

 - Build: Include LDFLAGS in link of shared library.

Also: Remove obsolete patches.
This commit is contained in:
Craig Leres 2023-09-29 15:10:55 -07:00
parent 1525b56085
commit 93c4589950
6 changed files with 6 additions and 85 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= netpbm
DISTVERSION= 11.03.06
DISTVERSION= 11.04.02
CATEGORIES= graphics
MASTER_SITES= LOCAL/leres/netpbm
@ -22,7 +22,7 @@ USES= cpe gmake jpeg perl5 shebangfix tar:xz
USE_LDCONFIG= yes
CPE_VENDOR= netpbm_project
SVN_REV= r4687
SVN_REV= r4709
SHEBANG_FILES= buildtools/makeman converter/pbm/pbmtox10bm \
editor/pnmflip editor/pnmquant editor/ppmfade \
@ -52,7 +52,6 @@ X11_USE= xorg=x11,xau,xcb,xdmcp
post-patch:
${REINPLACE_CMD} -e 's|misc|share/netpbm|g' ${WRKSRC}/common.mk
${REINPLACE_CMD} -e 's|pkg-config|false|g' ${WRKSRC}/GNUmakefile
.ifdef WITH_PIE
.for dn in buildtools test
${REINPLACE_CMD} -e '/^all:/s/^/CFLAGS_FOR_BUILD+=${PIE_CFLAGS}\n/' \

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1695684831
SHA256 (netpbm-11.03.06.tar.xz) = 1c1adfc1f6168942f6ab8df66db5954f2eaa2f052192414e2a4a99080121a3f9
SIZE (netpbm-11.03.06.tar.xz) = 2428526
TIMESTAMP = 1696025133
SHA256 (netpbm-11.04.02.tar.xz) = c7af684a300a20285e67f8900537828681994e74f5870155f84bfb9daa75e99e
SIZE (netpbm-11.04.02.tar.xz) = 2432352

View file

@ -1,23 +0,0 @@
psocket.c:123:15: warning: implicit declaration of function 'ntohl' is invalid in C99 [-Wimplicit-function-declaration]
*valueP = ntohl(converter.value);
^
psocket.c:196:23: warning: implicit declaration of function 'htonl' is invalid in C99 [-Wimplicit-function-declaration]
converter.value = htonl(value);
^
psocket.c:295:34: warning: implicit declaration of function 'htons' is invalid in C99 [-Wimplicit-function-declaration]
nameEntry.sin_port = htons(tempShort);
^
psocket.c:358:32: warning: implicit declaration of function 'htons' is invalid in C99 [-Wimplicit-function-declaration]
nameEntry.sin_port = htons(trialPortNum);
^
--- converter/ppm/ppmtompeg/psocket.c.orig 2020-03-27 19:26:06 UTC
+++ converter/ppm/ppmtompeg/psocket.c
@@ -9,7 +9,6 @@
============================================================================*/
-#define _XOPEN_SOURCE 500 /* Make sure stdio.h contains pclose() */
/* _ALL_SOURCE is needed on AIX to make the C library include the
socket services (e.g. define struct sockaddr)

View file

@ -1,22 +0,0 @@
--- converter/other/jpeg2000/jpeg2ktopam.c.orig 2020-07-22 20:35:17 UTC
+++ converter/other/jpeg2000/jpeg2ktopam.c
@@ -17,6 +17,8 @@
but plenty of source files of libjasper do to0, and they did not have
_XOPEN_SOURCE 600, so it would seem to be superfluous here too.
*/
+#include <stddef.h>
+typedef __max_align_t max_align_t;
#include <string.h>
#include <jasper/jasper.h>
--- converter/other/jpeg2000/pamtojpeg2k.c.orig 2020-07-22 20:35:17 UTC
+++ converter/other/jpeg2000/pamtojpeg2k.c
@@ -18,6 +18,8 @@
_XOPEN_SOURCE 600, so it would seem to be superfluous here too.
*/
+#include <stddef.h>
+typedef __max_align_t max_align_t;
#include <string.h>
#include <jasper/jasper.h>

View file

@ -1,33 +0,0 @@
libpm.c:836:12: warning: implicit declaration of function 'arc4random' is invalid in C99
[-Wimplicit-function-declaration]
return arc4random();
^
--- lib/libpm.c.orig 2020-03-27 19:09:35 UTC
+++ lib/libpm.c
@@ -9,7 +9,7 @@
**************************************************************************/
#define _DEFAULT_SOURCE /* New name for SVID & BSD source defines */
-#define _XOPEN_SOURCE 500 /* Make sure ftello, fseeko are defined */
+#define _BSD_SOURCE 1
#include "netpbm/pm_config.h"
@@ -17,6 +17,7 @@
#include <unistd.h>
#include <stdio.h>
#include <stdarg.h>
+#include <stdlib.h>
#include <string.h>
#include <errno.h>
#include <setjmp.h>
@@ -832,7 +833,7 @@ pm_arg0toprogname(const char arg0[]) {
unsigned int
pm_randseed(void) {
- return time(NULL) ^ getpid();
+ return arc4random();
}

View file

@ -404,7 +404,7 @@ include/netpbm/runlength.h
include/netpbm/shhopt.h
lib/libnetpbm.so
lib/libnetpbm.so.11
lib/libnetpbm.so.11.103
lib/libnetpbm.so.11.104
%%DATADIR%%/palmcolor8.map
%%DATADIR%%/palmgray1.map
%%DATADIR%%/palmgray2.map