autodetected DB3, but fails to find includes
PR: 21411 Submitted by: Scot W. Hetzel <hetzels@westbend.net> MAINTAINER
This commit is contained in:
parent
97e6ae70a3
commit
94124a586b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34158
6 changed files with 138 additions and 24 deletions
|
@ -43,12 +43,18 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
|
|||
--enable-static \
|
||||
--enable-login \
|
||||
--with-pwcheck=/var/pwcheck \
|
||||
--with-dblib=ndbm \
|
||||
--with-rc4=openssl
|
||||
|
||||
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
|
||||
PREFIX="${PREFIX}" \
|
||||
TOUCH="${TOUCH}" \
|
||||
MKDIR="${MKDIR}"
|
||||
MKDIR="${MKDIR}" \
|
||||
ENABLE_DB3="${ENABLE_DB3}" \
|
||||
ENABLE_MYSQL="${ENABLE_MYSQL}" \
|
||||
ENABLE_LDAP="${ENABLE_LDAP}"
|
||||
|
||||
# ENABLE_* variables can be used by depending ports to enable options.
|
||||
|
||||
# JavaSASL needs someone to look at to get it to build
|
||||
#JAVADIR= jdk1.1.8
|
||||
|
@ -65,16 +71,16 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
|
|||
#.endif
|
||||
|
||||
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
|
||||
CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
|
||||
CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-gssapi
|
||||
CONFIGURE_ARGS+= --disable-gssapi
|
||||
GSSAPI= "@comment "
|
||||
.endif
|
||||
|
||||
.if exists(/usr/lib/libkrb.a)
|
||||
CONFIGURE_ARGS+= --enable-krb4
|
||||
CONFIGURE_ARGS+= --enable-krb4
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-krb4
|
||||
CONFIGURE_ARGS+= --disable-krb4
|
||||
EBONES= "@comment "
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- configure.in.orig Thu Jul 20 21:35:01 2000
|
||||
+++ configure.in Sat Sep 16 13:58:02 2000
|
||||
+++ configure.in Tue Sep 19 21:51:11 2000
|
||||
@@ -66,8 +66,9 @@
|
||||
dnl check for -R, etc. switch
|
||||
CMU_GUESS_RUNPATH_SWITCH
|
||||
|
@ -12,7 +12,21 @@
|
|||
|
||||
AM_DISABLE_STATIC
|
||||
|
||||
@@ -310,6 +311,88 @@
|
||||
@@ -232,6 +233,13 @@
|
||||
SASL_DB_BACKEND="db_${dblib}.lo"
|
||||
AC_DEFINE(SASL_BERKELEYDB)
|
||||
SASL_DB_LIB="-ldb"
|
||||
+ for db3loc in ${prefix} /usr/local /usr
|
||||
+ do
|
||||
+ if test -d ${db3loc}/include/db3; then
|
||||
+ CPPFLAGS="-I${db3loc}/include/db3 $CPPFLAGS"
|
||||
+ break
|
||||
+ fi
|
||||
+ done
|
||||
;;
|
||||
*)
|
||||
AC_MSG_WARN([Disabling SASL authentication database support])
|
||||
@@ -310,6 +318,88 @@
|
||||
fi
|
||||
AM_CONDITIONAL(PWCHECK, test "$with_pwcheck" != no)
|
||||
|
||||
|
@ -101,7 +115,7 @@
|
|||
dnl CRAM-MD5
|
||||
AC_ARG_ENABLE(cram, [ --enable-cram enable CRAM-MD5 authentication [yes] ],
|
||||
cram=$enableval,
|
||||
@@ -434,11 +517,15 @@
|
||||
@@ -434,11 +524,15 @@
|
||||
fi
|
||||
|
||||
if test "$with_des" != no; then
|
||||
|
|
|
@ -6,13 +6,43 @@ if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
|
|||
fi
|
||||
|
||||
if [ "${BATCH}" ]; then
|
||||
exit
|
||||
if [ "x${ENABLE_DB3}" = "xYES" ]; then
|
||||
OPTIONS=\"DB3\"
|
||||
fi
|
||||
if [ "x${ENABLE_MYSQL}" = "xYES" ]; then
|
||||
OPTIONS="${OPTIONS} \"MySQL\""
|
||||
fi
|
||||
if [ "x${ENABLE_LDAP}" = "xYES" ]; then
|
||||
OPTIONS="${OPTIONS} \"OpenLDAP\""
|
||||
fi
|
||||
if [ "x${OPTIONS}" != "x" ]; then
|
||||
set ${OPTIONS}
|
||||
fi
|
||||
else
|
||||
/usr/bin/dialog --title "Additional pwcheck methods" --clear \
|
||||
|
||||
if [ "x${ENABLE_DB3}" = "xYES" -o -f ${PREFIX}/lib/libdb3.so ] ; then
|
||||
SET_DB3="ON"
|
||||
else
|
||||
SET_DB3="OFF"
|
||||
fi
|
||||
if [ "x${ENABLE_MYSQL}" = "xYES" -o -f ${PREFIX}/lib/libmysqlclient.so ] ; then
|
||||
SET_MYSQL="ON"
|
||||
else
|
||||
SET_MYSQL="OFF"
|
||||
fi
|
||||
if [ "x${ENABLE_LDAP}" = "xYES" -o \
|
||||
-f ${PREFIX}/lib/libldap.so -a -f ${PREFIX}/lib/liblber.so ] ; then
|
||||
SET_LDAP="ON"
|
||||
else
|
||||
SET_LDAP="OFF"
|
||||
fi
|
||||
|
||||
/usr/bin/dialog --title "Additional SASL options" --clear \
|
||||
--checklist "\n\
|
||||
Please select desired options:" -1 -1 16 \
|
||||
MySQL "MySQL password Authentication" OFF \
|
||||
OpenLDAP "OpenLDAP password Authentication" OFF \
|
||||
DB3 "Berkeley DB package, revision 3" ${SET_DB3} \
|
||||
MySQL "MySQL password Authentication" ${SET_MYSQL} \
|
||||
OpenLDAP "OpenLDAP password Authentication" ${SET_LDAP} \
|
||||
2> /tmp/checklist.tmp.$$
|
||||
|
||||
retval=$?
|
||||
|
@ -40,6 +70,13 @@ echo "PREFIX= ${PREFIX}"
|
|||
|
||||
while [ "$1" ]; do
|
||||
case $1 in
|
||||
\"DB3\")
|
||||
#Can't use LIB_DEPENDS - no libdb3.so.1 in db3 port
|
||||
#echo "LIB_DEPENDS+= db3.1:\${PORTSDIR}/databases/db3"
|
||||
echo "BUILD_DEPENDS+= \${LOCALBASE}/lib/libdb3.1.so:\${PORTSDIR}/databases/db3"
|
||||
echo "RUN_DEPENDS+= \${LOCALBASE}/lib/libdb3.1.so:\${PORTSDIR}/databases/db3"
|
||||
echo "CONFIGURE_ARGS+=--with-dblib=berkeley"
|
||||
;;
|
||||
\"MySQL\")
|
||||
echo "LIB_DEPENDS+= mysqlclient.6:\${PORTSDIR}/databases/mysql322-client"
|
||||
echo "CONFIGURE_ARGS+=--with-mysql=\${PREFIX}"
|
||||
|
|
|
@ -43,12 +43,18 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
|
|||
--enable-static \
|
||||
--enable-login \
|
||||
--with-pwcheck=/var/pwcheck \
|
||||
--with-dblib=ndbm \
|
||||
--with-rc4=openssl
|
||||
|
||||
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
|
||||
PREFIX="${PREFIX}" \
|
||||
TOUCH="${TOUCH}" \
|
||||
MKDIR="${MKDIR}"
|
||||
MKDIR="${MKDIR}" \
|
||||
ENABLE_DB3="${ENABLE_DB3}" \
|
||||
ENABLE_MYSQL="${ENABLE_MYSQL}" \
|
||||
ENABLE_LDAP="${ENABLE_LDAP}"
|
||||
|
||||
# ENABLE_* variables can be used by depending ports to enable options.
|
||||
|
||||
# JavaSASL needs someone to look at to get it to build
|
||||
#JAVADIR= jdk1.1.8
|
||||
|
@ -65,16 +71,16 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
|
|||
#.endif
|
||||
|
||||
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
|
||||
CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
|
||||
CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-gssapi
|
||||
CONFIGURE_ARGS+= --disable-gssapi
|
||||
GSSAPI= "@comment "
|
||||
.endif
|
||||
|
||||
.if exists(/usr/lib/libkrb.a)
|
||||
CONFIGURE_ARGS+= --enable-krb4
|
||||
CONFIGURE_ARGS+= --enable-krb4
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-krb4
|
||||
CONFIGURE_ARGS+= --disable-krb4
|
||||
EBONES= "@comment "
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- configure.in.orig Thu Jul 20 21:35:01 2000
|
||||
+++ configure.in Sat Sep 16 13:58:02 2000
|
||||
+++ configure.in Tue Sep 19 21:51:11 2000
|
||||
@@ -66,8 +66,9 @@
|
||||
dnl check for -R, etc. switch
|
||||
CMU_GUESS_RUNPATH_SWITCH
|
||||
|
@ -12,7 +12,21 @@
|
|||
|
||||
AM_DISABLE_STATIC
|
||||
|
||||
@@ -310,6 +311,88 @@
|
||||
@@ -232,6 +233,13 @@
|
||||
SASL_DB_BACKEND="db_${dblib}.lo"
|
||||
AC_DEFINE(SASL_BERKELEYDB)
|
||||
SASL_DB_LIB="-ldb"
|
||||
+ for db3loc in ${prefix} /usr/local /usr
|
||||
+ do
|
||||
+ if test -d ${db3loc}/include/db3; then
|
||||
+ CPPFLAGS="-I${db3loc}/include/db3 $CPPFLAGS"
|
||||
+ break
|
||||
+ fi
|
||||
+ done
|
||||
;;
|
||||
*)
|
||||
AC_MSG_WARN([Disabling SASL authentication database support])
|
||||
@@ -310,6 +318,88 @@
|
||||
fi
|
||||
AM_CONDITIONAL(PWCHECK, test "$with_pwcheck" != no)
|
||||
|
||||
|
@ -101,7 +115,7 @@
|
|||
dnl CRAM-MD5
|
||||
AC_ARG_ENABLE(cram, [ --enable-cram enable CRAM-MD5 authentication [yes] ],
|
||||
cram=$enableval,
|
||||
@@ -434,11 +517,15 @@
|
||||
@@ -434,11 +524,15 @@
|
||||
fi
|
||||
|
||||
if test "$with_des" != no; then
|
||||
|
|
|
@ -6,13 +6,43 @@ if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
|
|||
fi
|
||||
|
||||
if [ "${BATCH}" ]; then
|
||||
exit
|
||||
if [ "x${ENABLE_DB3}" = "xYES" ]; then
|
||||
OPTIONS=\"DB3\"
|
||||
fi
|
||||
if [ "x${ENABLE_MYSQL}" = "xYES" ]; then
|
||||
OPTIONS="${OPTIONS} \"MySQL\""
|
||||
fi
|
||||
if [ "x${ENABLE_LDAP}" = "xYES" ]; then
|
||||
OPTIONS="${OPTIONS} \"OpenLDAP\""
|
||||
fi
|
||||
if [ "x${OPTIONS}" != "x" ]; then
|
||||
set ${OPTIONS}
|
||||
fi
|
||||
else
|
||||
/usr/bin/dialog --title "Additional pwcheck methods" --clear \
|
||||
|
||||
if [ "x${ENABLE_DB3}" = "xYES" -o -f ${PREFIX}/lib/libdb3.so ] ; then
|
||||
SET_DB3="ON"
|
||||
else
|
||||
SET_DB3="OFF"
|
||||
fi
|
||||
if [ "x${ENABLE_MYSQL}" = "xYES" -o -f ${PREFIX}/lib/libmysqlclient.so ] ; then
|
||||
SET_MYSQL="ON"
|
||||
else
|
||||
SET_MYSQL="OFF"
|
||||
fi
|
||||
if [ "x${ENABLE_LDAP}" = "xYES" -o \
|
||||
-f ${PREFIX}/lib/libldap.so -a -f ${PREFIX}/lib/liblber.so ] ; then
|
||||
SET_LDAP="ON"
|
||||
else
|
||||
SET_LDAP="OFF"
|
||||
fi
|
||||
|
||||
/usr/bin/dialog --title "Additional SASL options" --clear \
|
||||
--checklist "\n\
|
||||
Please select desired options:" -1 -1 16 \
|
||||
MySQL "MySQL password Authentication" OFF \
|
||||
OpenLDAP "OpenLDAP password Authentication" OFF \
|
||||
DB3 "Berkeley DB package, revision 3" ${SET_DB3} \
|
||||
MySQL "MySQL password Authentication" ${SET_MYSQL} \
|
||||
OpenLDAP "OpenLDAP password Authentication" ${SET_LDAP} \
|
||||
2> /tmp/checklist.tmp.$$
|
||||
|
||||
retval=$?
|
||||
|
@ -40,6 +70,13 @@ echo "PREFIX= ${PREFIX}"
|
|||
|
||||
while [ "$1" ]; do
|
||||
case $1 in
|
||||
\"DB3\")
|
||||
#Can't use LIB_DEPENDS - no libdb3.so.1 in db3 port
|
||||
#echo "LIB_DEPENDS+= db3.1:\${PORTSDIR}/databases/db3"
|
||||
echo "BUILD_DEPENDS+= \${LOCALBASE}/lib/libdb3.1.so:\${PORTSDIR}/databases/db3"
|
||||
echo "RUN_DEPENDS+= \${LOCALBASE}/lib/libdb3.1.so:\${PORTSDIR}/databases/db3"
|
||||
echo "CONFIGURE_ARGS+=--with-dblib=berkeley"
|
||||
;;
|
||||
\"MySQL\")
|
||||
echo "LIB_DEPENDS+= mysqlclient.6:\${PORTSDIR}/databases/mysql322-client"
|
||||
echo "CONFIGURE_ARGS+=--with-mysql=\${PREFIX}"
|
||||
|
|
Loading…
Reference in a new issue