Add mxp (Mandelbrot explorer). Mxp is an X application for computing and exploring
Mandelbrot sets. Features of mxp include: - zoom and un-zoom - dynamic resizing of drawing window - setup save/load - asynchronous image generation (buttons always work) - GIF output - animation - nine color schemes - color rotation - color change options - detailed statistics WWW: http://www.ibiblio.org/pub/Linux/apps/math/fractals/ and also fix category Approved by: portmgr(marcus) Submitted by: kris
This commit is contained in:
parent
e9d88cc1dd
commit
943ad93280
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=131934
7 changed files with 124 additions and 0 deletions
|
@ -324,6 +324,7 @@
|
|||
SUBDIR += morpheus
|
||||
SUBDIR += mrsidviewer
|
||||
SUBDIR += multivideo
|
||||
SUBDIR += mxp
|
||||
SUBDIR += netpbm
|
||||
SUBDIR += nip
|
||||
SUBDIR += nurbs++
|
||||
|
|
37
graphics/mxp/Makefile
Normal file
37
graphics/mxp/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
# New ports collection makefile for: mxp
|
||||
# Date Created: 18 March 2004
|
||||
# Whom: NAKATA Maho <maho@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mxp
|
||||
PORTVERSION= 1.3
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SUNSITE}
|
||||
MASTER_SITE_SUBDIR=apps/math/fractals
|
||||
|
||||
MAINTAINER= maho@FreeBSD.org
|
||||
COMMENT= Application for computing/exploring Mandelbrot set
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
USE_XPM= yes
|
||||
USE_REINPLACE= yes
|
||||
ALL_TARGET=
|
||||
|
||||
post-extract:
|
||||
@${CP} ${WRKSRC}/Makefile.noimake ${WRKSRC}/Makefile
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
|
||||
s|%%X11BASE%%|${X11BASE}|g ; \
|
||||
s|%%CFLAGS%%|${CFLAGS}|g ; \
|
||||
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
|
||||
s|%%CC%%|${CC}|g' ${WRKSRC}/Makefile
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/mxp ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
graphics/mxp/distinfo
Normal file
2
graphics/mxp/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (mxp-1.3.tar.gz) = c53f8b91fcbb09c4ad885bb7c34d2dd0
|
||||
SIZE (mxp-1.3.tar.gz) = 43291
|
50
graphics/mxp/files/patch-Makefile
Normal file
50
graphics/mxp/files/patch-Makefile
Normal file
|
@ -0,0 +1,50 @@
|
|||
--- Makefile.orig Sat Feb 12 16:42:03 2005
|
||||
+++ Makefile Sat Feb 12 16:42:45 2005
|
||||
@@ -1,30 +1,30 @@
|
||||
# Makefile file for mxp - Mandelbrot Explorer
|
||||
|
||||
# Compiler - uncomment for gcc
|
||||
-# CC = gcc
|
||||
+CC = %%CC%%
|
||||
|
||||
# Since this is a compute intensive program, be sure to use
|
||||
# compiler optimization. It makes a big difference.
|
||||
# For gcc on linux "-O2 -m486" works well.
|
||||
-# OPT = -O2 -m486
|
||||
+OPT = %%CFLAGS%%
|
||||
|
||||
# If X is not installed in the standard places you will need to set the
|
||||
# following 2 defines.
|
||||
-XLIBS = -L/usr/openwin/lib
|
||||
-XINC = -I/usr/openwin/include
|
||||
+XLIBS = -L%%X11BASE%%/lib
|
||||
+XINC = -I%%X11BASE%%/include
|
||||
|
||||
# Specify where your Xpm installation directories are
|
||||
# If you have the XPM libraries uncomment and adjust the following lines
|
||||
# to use color icons.
|
||||
-#XPM_DEF = -DXPM
|
||||
-#XPM_INCLUDE = -I/usr/local/include
|
||||
-#XPM_LIB = -L$(LIBDIR)/xpm -lXpm
|
||||
+XPM_DEF = -DXPM
|
||||
+XPM_INCLUDE = #-I/usr/local/include
|
||||
+XPM_LIB = -lXpm #-L$(LIBDIR)/xpm
|
||||
|
||||
# If you are using FVWM 2.0 then the following must be set to 2
|
||||
SIZE_INC = 1
|
||||
|
||||
# Specify install directory
|
||||
-BINDIR = /usr/local/bin
|
||||
+BINDIR = %%PREFIX%%/bin
|
||||
|
||||
INCLUDES = $(XPM_INCLUDE) $(XINC) -Ilug
|
||||
|
||||
@@ -34,7 +34,7 @@
|
||||
OBJS = $(M_OBJS) $(L_OBJS)
|
||||
|
||||
mxp: $(OBJS)
|
||||
- $(CC) -o $@ $(OBJS) $(XPM_LIB) -L/X/X11/lib -lm -lXaw -lXt -lXmu -lX11 -lXdmcp -lXext
|
||||
+ $(CC) -o $@ $(OBJS) $(XPM_LIB) $(XLIBS) -lm -lXaw -lXt -lXmu -lX11 -lXdmcp -lXext
|
||||
|
||||
$(OBJS): mxp.h
|
||||
|
16
graphics/mxp/files/patch-lugfnts.h
Normal file
16
graphics/mxp/files/patch-lugfnts.h
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- lug/lugfnts.h.old Sat Aug 18 13:33:46 2001
|
||||
+++ lug/lugfnts.h Sat Feb 12 16:30:29 2005
|
||||
@@ -1057,13 +1057,6 @@
|
||||
);
|
||||
|
||||
extern int
|
||||
-isnumber(
|
||||
-#ifdef USE_PROTOTYPES
|
||||
- char *
|
||||
-#endif
|
||||
-);
|
||||
-
|
||||
-extern int
|
||||
Uncompress(
|
||||
#ifdef USE_PROTOTYPES
|
||||
char *,
|
14
graphics/mxp/pkg-descr
Normal file
14
graphics/mxp/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
|||
Mxp (Mandelbrot explorer) is an X application for computing and exploring
|
||||
Mandelbrot sets. Features of mxp include:
|
||||
- zoom and un-zoom
|
||||
- dynamic resizing of drawing window
|
||||
- setup save/load
|
||||
- asynchronous image generation (buttons always work)
|
||||
- GIF output
|
||||
- animation
|
||||
- nine color schemes
|
||||
- color rotation
|
||||
- color change options
|
||||
- detailed statistics
|
||||
|
||||
WWW: http://www.ibiblio.org/pub/Linux/apps/math/fractals/
|
4
graphics/mxp/pkg-plist
Normal file
4
graphics/mxp/pkg-plist
Normal file
|
@ -0,0 +1,4 @@
|
|||
bin/mxp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
Loading…
Reference in a new issue