New port wmxss version 0.1: Run xscreensaver modules inside a
WindowMaker dock PR: 42073 Submitted by: Bruce M Simpson <bms@spc.org>
This commit is contained in:
parent
3b53fe79c8
commit
943cfe1f34
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82173
6 changed files with 89 additions and 0 deletions
|
@ -120,6 +120,7 @@
|
|||
SUBDIR += wmmatrix
|
||||
SUBDIR += wmmenu
|
||||
SUBDIR += wmoldmenu2new
|
||||
SUBDIR += wmxss
|
||||
SUBDIR += wrapper
|
||||
SUBDIR += wscan
|
||||
SUBDIR += wterm
|
||||
|
|
28
x11/wmxss/Makefile
Normal file
28
x11/wmxss/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# New ports collection makefile for: wmxss
|
||||
# Date created: 27 August 2002
|
||||
# Whom: Bruce M Simpson <bms@spc.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= wmxss
|
||||
PORTVERSION= 0.1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://nis-www.lanl.gov/~mgh/WindowMaker/
|
||||
|
||||
MAINTAINER= bms@spc.org
|
||||
COMMENT= Run xscreensaver modules inside a WindowMaker dock
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_REINPLACE= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/Src
|
||||
|
||||
post-extract:
|
||||
@( cd ${WRKSRC} ; ${MAKE} clean ; ${RM} -f .nfs* )
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's|-O2||' \
|
||||
${BUILD_WRKSRC}/${MAKEFILE}
|
||||
|
||||
.include <bsd.port.mk>
|
1
x11/wmxss/distinfo
Normal file
1
x11/wmxss/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (wmxss-0.1.tar.gz) = 26d4f00c3a3d1b2306ba4924a9fbb0fa
|
50
x11/wmxss/files/patch-Src::Makefile
Normal file
50
x11/wmxss/files/patch-Src::Makefile
Normal file
|
@ -0,0 +1,50 @@
|
|||
--- Makefile.orig Wed Aug 11 22:29:02 1999
|
||||
+++ Makefile Tue Aug 27 10:23:17 2002
|
||||
@@ -1,36 +1,19 @@
|
||||
-CC = gcc
|
||||
-CFLAGS = -O2 -Wall
|
||||
-INCDIR = -I/usr/X11R6/include/X11 -I/usr/X11R6/include
|
||||
-DESTDIR= /usr/X11R6
|
||||
-LIBDIR = -L/usr/X11R6/lib
|
||||
+#
|
||||
+# Makefile for xmms (FreeBSD) -bms
|
||||
+#
|
||||
|
||||
-# for Linux
|
||||
-LIBS = -lXpm -lX11 -lXext
|
||||
+PROG= wmxss
|
||||
|
||||
-# for Solaris
|
||||
-#LIBS = -lXpm -lX11 -lXext -lsocket -lnsl
|
||||
+SRCS= wmxss.c xutils.c
|
||||
|
||||
-OBJS = wmxss.o \
|
||||
- xutils.o
|
||||
+CFLAGS+= -I${X11BASE}/include -O2 -Wall
|
||||
+LDADD+= -lXpm -lX11 -lXext
|
||||
+LDADD+= -L${X11BASE}/lib
|
||||
|
||||
+NOMAN=
|
||||
|
||||
-.c.o:
|
||||
- $(CC) $(CFLAGS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
|
||||
-
|
||||
-
|
||||
-all: wmxss.o wmxss
|
||||
+BINDIR?= ${PREFIX}/bin
|
||||
|
||||
wmxss.o: wmxss_master.xpm wmxss_mask.xbm
|
||||
-wmxss: $(OBJS)
|
||||
- $(CC) $(COPTS) $(SYSTEM) -o wmxss $^ $(INCDIR) $(LIBDIR) $(LIBS)
|
||||
-
|
||||
-clean:
|
||||
- for i in $(OBJS) ; do \
|
||||
- rm -f $$i; \
|
||||
- done
|
||||
- rm -f wmxss
|
||||
-
|
||||
-install:: wmxss
|
||||
- install -c -s -m 0755 wmxss $(DESTDIR)/bin
|
||||
- install -c -m 0644 wmxss.1 $(DESTDIR)/man/man1
|
||||
|
||||
+.include <bsd.prog.mk>
|
8
x11/wmxss/pkg-descr
Normal file
8
x11/wmxss/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
wmxss is a small program to run xscreensaver modules (such as those
|
||||
bundled with xlockmore) in a WindowMaker dock.
|
||||
|
||||
WWW: http://nis-www.lanl.gov/~mgh/WindowMaker/DockApps.shtml
|
||||
|
||||
--
|
||||
Bruce
|
||||
bms@spc.org
|
1
x11/wmxss/pkg-plist
Normal file
1
x11/wmxss/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/wmxss
|
Loading…
Reference in a new issue