- Gnome is default icons theme [1]
Not switched to Adwaita, because Thunar and some Xfce's widgets still use stock item (deprecated since GTK 3.10, and not available in x11-themes/adwaita-icon-theme) - Add support of GTK3 bookmarks files [2] - Bump PORTREVISION PR: 183690 [1] Requested by: Rostislav Krasny Obtained from: Xfce upstream repository [2]
This commit is contained in:
parent
0377ed6824
commit
9471176d7e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=376146
4 changed files with 81 additions and 1 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= Thunar
|
||||
PORTVERSION= 1.6.3
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= x11-fm xfce
|
||||
MASTER_SITES= ${MASTER_SITE_XFCE}
|
||||
MASTER_SITE_SUBDIR= src/xfce/${PORTNAME:tl}/${PORTVERSION:R}
|
||||
|
@ -126,4 +126,8 @@ CONFIGURE_ARGS+=--disable-startup-notification
|
|||
USE_GNOME+=gvfs
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|internet-mail|mail-send|' \
|
||||
${WRKSRC}/plugins/thunar-sendto-email/thunar-sendto-email.desktop.in.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
13
x11-fm/thunar/files/patch-thunar__thunar-gio-extensions.c
Normal file
13
x11-fm/thunar/files/patch-thunar__thunar-gio-extensions.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
Add support for the GTK3 bookmarks file (bug #10627)
|
||||
|
||||
--- ./thunar/thunar-gio-extensions.c.orig 2013-05-05 16:37:23.000000000 +0000
|
||||
+++ ./thunar/thunar-gio-extensions.c 2014-07-26 15:25:12.000000000 +0000
|
||||
@@ -77,7 +77,7 @@
|
||||
gchar *filename;
|
||||
GFile *bookmarks;
|
||||
|
||||
- filename = g_build_filename (xfce_get_homedir (), ".gtk-bookmarks", NULL);
|
||||
+ filename = g_build_filename (g_get_user_config_dir (), "gtk-3.0", "bookmarks", NULL);
|
||||
bookmarks = g_file_new_for_path (filename);
|
||||
g_free (filename);
|
||||
|
35
x11-fm/thunar/files/patch-thunar__thunar-shortcuts-model.c
Normal file
35
x11-fm/thunar/files/patch-thunar__thunar-shortcuts-model.c
Normal file
|
@ -0,0 +1,35 @@
|
|||
Add support for the GTK3 bookmarks file (bug #10627)
|
||||
|
||||
--- ./thunar/thunar-shortcuts-model.c.orig 2013-05-05 16:37:23.000000000 +0000
|
||||
+++ ./thunar/thunar-shortcuts-model.c 2014-07-26 15:25:27.000000000 +0000
|
||||
@@ -1364,6 +1364,7 @@
|
||||
gchar *uri;
|
||||
GList *lp;
|
||||
GError *err = NULL;
|
||||
+ GFile *parent = NULL;
|
||||
|
||||
_thunar_return_if_fail (THUNAR_IS_SHORTCUTS_MODEL (model));
|
||||
|
||||
@@ -1389,6 +1390,22 @@
|
||||
}
|
||||
}
|
||||
|
||||
+ /* create folder if it does not exist */
|
||||
+ parent = g_file_get_parent (model->bookmarks_file);
|
||||
+ if (!g_file_make_directory_with_parents (parent, NULL, &err))
|
||||
+ {
|
||||
+ if (g_error_matches (err, G_IO_ERROR, G_IO_ERROR_EXISTS))
|
||||
+ {
|
||||
+ g_clear_error (&err);
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ g_warning ("Failed to create bookmarks folder: %s", err->message);
|
||||
+ g_error_free (err);
|
||||
+ }
|
||||
+ }
|
||||
+ g_clear_object (&parent);
|
||||
+
|
||||
/* write data to the disk */
|
||||
bookmarks_path = g_file_get_path (model->bookmarks_file);
|
||||
if (!g_file_set_contents (bookmarks_path, contents->str, contents->len, &err))
|
28
x11-fm/thunar/files/patch-thunar__thunar-util.c
Normal file
28
x11-fm/thunar/files/patch-thunar__thunar-util.c
Normal file
|
@ -0,0 +1,28 @@
|
|||
Add support for the GTK3 bookmarks file (bug #10627)
|
||||
|
||||
--- ./thunar/thunar-util.c.orig 2013-05-05 16:37:23.000000000 +0000
|
||||
+++ ./thunar/thunar-util.c 2014-07-26 15:25:35.000000000 +0000
|
||||
@@ -84,6 +84,15 @@
|
||||
|
||||
/* append the GTK+ bookmarks (if any) */
|
||||
fp = fopen (bookmarks_path, "r");
|
||||
+ g_free (bookmarks_path);
|
||||
+
|
||||
+ if (G_UNLIKELY (fp == NULL))
|
||||
+ {
|
||||
+ bookmarks_path = g_build_filename (g_get_home_dir (), ".gtk-bookmarks", NULL);
|
||||
+ fp = fopen(bookmarks_path, "r");
|
||||
+ g_free(bookmarks_path);
|
||||
+ }
|
||||
+
|
||||
if (G_LIKELY (fp != NULL))
|
||||
{
|
||||
while (fgets (line, sizeof (line), fp) != NULL)
|
||||
@@ -119,7 +128,6 @@
|
||||
fclose (fp);
|
||||
}
|
||||
|
||||
- g_free (bookmarks_path);
|
||||
}
|
||||
|
||||
|
Loading…
Reference in a new issue