Update to 0.4, and add support for gstreamer-0.8.

PR:		65330
Submitted by:	maintainer
This commit is contained in:
Joe Marcus Clarke 2004-04-08 18:16:23 +00:00
parent f75143ea53
commit 94a57f0605
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106505
6 changed files with 107 additions and 19 deletions

View file

@ -6,11 +6,10 @@
#
PORTNAME= jamboree
PORTVERSION= 0.3
PORTREVISION= 3
PORTVERSION= 0.4
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.3
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION}
MAINTAINER= jylefort@brutele.be
COMMENT= A simple GNOME music player
@ -21,12 +20,28 @@ LIB_DEPENDS+= id3tag:${PORTSDIR}/audio/libid3tag \
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libglade2 gstreamerplugins
USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui libglade2
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --disable-dbus
BROKEN= "Needs update for gstreamer-0.8"
OPTIONS= XINE "use xine instead of GStreamer" off
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.if defined(WITH_XINE)
LIB_DEPENDS+= xine.9:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+= --enable-xine
.else
USE_GNOME+= gstreamerplugins
.endif
post-patch:
@${REINPLACE_CMD} -Ee \
's/GST_VER=0\.7\.4/GST_VER=0.8/; s/(gstreamer(-[a-z]+)?|gst-inspect)-0\.7/\1-0.8/g' \
${WRKSRC}/configure
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
MD5 (jamboree-0.3.tar.bz2) = f95185fcb460cee5601584a8936df162
SIZE (jamboree-0.3.tar.bz2) = 349973
MD5 (jamboree-0.4.tar.bz2) = 37e70e22f8abf6f7ce0b2c21c8090d2a
SIZE (jamboree-0.4.tar.bz2) = 407718

View file

@ -0,0 +1,51 @@
--- ltmain.sh.orig Sat Feb 7 05:49:19 2004
+++ ltmain.sh Thu Apr 8 11:15:20 2004
@@ -1349,7 +1349,7 @@
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
- *-*-openbsd* | *-*-freebsd*)
+ *-*-openbsd* | *-*-freebsd4*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -1364,8 +1364,16 @@
continue
;;
+ -pthread)
+ compile_command="$compile_command -pthread"
+ finalize_command="$finalize_command -pthread"
+ compiler_flags="$compiler_flags -pthread"
+ continue
+ ;;
+
-module)
module=yes
+ build_old_libs=no
continue
;;
@@ -3059,6 +3067,9 @@
# problems, so we reset it completely
verstring=
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
verstring="0.0"
;;
@@ -5531,10 +5542,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -0,0 +1,11 @@
--- src/main-window.c.orig Thu Apr 8 17:49:42 2004
+++ src/main-window.c Thu Apr 8 17:51:01 2004
@@ -2337,7 +2337,7 @@
GTK_STOCK_ADD, GTK_RESPONSE_ACCEPT,
NULL);
- gtk_file_chooser_set_folder_mode (GTK_FILE_CHOOSER (dialog), TRUE);
+ gtk_file_chooser_set_action (GTK_FILE_CHOOSER (dialog), GTK_FILE_CHOOSER_ACTION_SELECT_FOLDER);
start_dir = gconf_client_get_string (gconf_client,
GCONF_PATH "/default_add_folder",

View file

@ -1,10 +0,0 @@
--- test/Makefile.in.orig Wed Oct 8 17:27:16 2003
+++ test/Makefile.in Wed Oct 8 17:27:32 2003
@@ -215,6 +215,7 @@
jb_util_LDADD = \
$(JAMBOREE_LIBS) \
$(ID3TAG_LIBS) \
+ $(VORBIS_LIBS) \
$(VORBISFILE_LIBS) \
-lgdbm \
-lpopt

View file

@ -1,8 +1,12 @@
bin/jamboree
etc/gconf/gconf.xml.defaults/apps/jamboree/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/jamboree/columns/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/jamboree/control/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/jamboree/ui/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/jamboree/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/jamboree/columns/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/jamboree/control/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/jamboree/ui/%gconf.xml
etc/gconf/schemas/jamboree.schemas
share/gnome/applications/jamboree.desktop
share/gnome/jamboree/column-chooser.glade
@ -26,9 +30,26 @@ share/gnome/jamboree/jamboree.glade
share/gnome/jamboree/master-out.png
share/gnome/jamboree/smart-playlist-dialog.glade
share/gnome/pixmaps/jamboree.png
share/locale/az/LC_MESSAGES/jamboree.mo
share/locale/ca/LC_MESSAGES/jamboree.mo
share/locale/cs/LC_MESSAGES/jamboree.mo
share/locale/de/LC_MESSAGES/jamboree.mo
share/locale/es/LC_MESSAGES/jamboree.mo
share/locale/fi/LC_MESSAGES/jamboree.mo
share/locale/fr/LC_MESSAGES/jamboree.mo
share/locale/hr/LC_MESSAGES/jamboree.mo
share/locale/nl/LC_MESSAGES/jamboree.mo
share/locale/no/LC_MESSAGES/jamboree.mo
share/locale/pt/LC_MESSAGES/jamboree.mo
share/locale/sr/LC_MESSAGES/jamboree.mo
share/locale/sr@Latn/LC_MESSAGES/jamboree.mo
share/locale/sv/LC_MESSAGES/jamboree.mo
@dirrm etc/gconf/gconf.xml.defaults/apps/jamboree/columns
@dirrm etc/gconf/gconf.xml.defaults/apps/jamboree/control
@dirrm etc/gconf/gconf.xml.defaults/apps/jamboree/ui
@dirrm etc/gconf/gconf.xml.defaults/apps/jamboree
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/jamboree/columns
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/jamboree/control
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/jamboree/ui
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/jamboree
@dirrm share/gnome/jamboree