- Update to 1.38.4

- Add LICENSE
- Use PLIST_FILES, PLIST_DIRS and PLIST_DIRSTRY instead of PLIST

Changes:

1.38.4:
- Add Italian translation (thanks to Sergio Zanchetta).
- Don't double encode $date in the header.
- Use UTF-8 encoding for all manual pages.
- Add Greek translation (thanks to Michael Kotsarinis).
- Update French translation (thanks to David Prévot, closes: #590580).
- Update German translation (thanks to Helge Kreutzmann, closes: #590975).
- Use INSTALL_SCRIPT to install Perl script.
- Remove deprecated DH_COMPAT in debian/rules, adding debian/compat.
- Add ${misc:Depends}.
- Don't ignore errors from distclean.
- Fix Brazilian, Russian and Italian translations (placement of period was
  causing text to be interpreted as a macro).
- Update standards version to 3.9.1.
- Add missing dependency on dpkg/install-info.
- Strip bindtextdomain.so preload.
- Install preload into $(libdir)/help2man.

1.38.3:
- Apply patch from Mike Frysinger to allow "make install -j" to work.
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2011-01-01 12:21:55 +00:00
parent 2f511adfb5
commit 94b1417ff9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=267248
4 changed files with 30 additions and 69 deletions

View file

@ -1,4 +1,3 @@
# ex:ts=8
# Ports collection makefile for: help2man
# Date created: Jan 30, 2002
# Whom: ijliao
@ -7,36 +6,44 @@
#
PORTNAME= help2man
PORTVERSION= 1.38.2
PORTREVISION= 1
PORTVERSION= 1.38.4
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MASTER_SITES= GNU/${PORTNAME}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Automatically generating simple manual pages from program output
.if !defined(WITHOUT_NLS)
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
CFLAGS+= -lintl
INSTALL_TARGET= install install_l10n
MANLANG= "" de fi fr pl pt_BR ru sv vi
PLIST_SUB+= NLS=""
USE_GETTEXT= yes
.else
CONFIGURE_ARGS+=--disable-nls
INSTALL_TARGET= install
PLIST_SUB+= NLS="@comment "
.endif
LICENSE= GPLv3
CFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5= yes
INFO= help2man
MAN1= help2man.1
INFO= ${PORTNAME}
MAN1= ${PORTNAME}.1
PLIST_FILES= bin/${PORTNAME}
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS= --disable-nls
.else
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
CFLAGS+= -lintl
MANLANG= "" ${LANGS}
USE_GETTEXT= yes
LANGS= de el fi fr it pl pt_BR ru sv vi
PLIST_FILES+= lib/bindtextdomain.so
.for lang in ${LANGS}
PLIST_FILES+= share/locale/${lang}/LC_MESSAGES/${PORTNAME}.mo
PLIST_DIRSTRY+= man/${lang}/man1 man/${lang}
.endfor
.endif
post-patch:
@${REINPLACE_CMD} -e '/^pkglibdir/ s|/${PORTNAME}$$||' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>

View file

@ -1,3 +1,2 @@
MD5 (help2man-1.38.2.tar.gz) = 426671c6fe79e5ef2233303367eab5a6
SHA256 (help2man-1.38.2.tar.gz) = 952c29561bce8b233aa10af7f0e0c79c8243712810bf8ddf01e6efd82ce250d1
SIZE (help2man-1.38.2.tar.gz) = 136509
SHA256 (help2man-1.38.4.tar.gz) = 5eccc9a1e7f15bfc92482f35d8b9b8f0ab21e3cad3d97f818dfa9eddc5ee3349
SIZE (help2man-1.38.4.tar.gz) = 149314

View file

@ -1,19 +0,0 @@
--- Makefile.in.orig 2010-04-26 18:41:13.000000000 +0800
+++ Makefile.in 2010-04-30 14:22:44.000000000 +0800
@@ -23,6 +23,7 @@
LIBS = @LIBS@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_DATA = @INSTALL_DATA@
INSTALL_INFO = @INSTALL_INFO@
MAKEINFO = @MAKEINFO@
@@ -45,7 +46,7 @@
$(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man1
$(MKINSTALLDIRS) $(DESTDIR)$(infodir)
- $(INSTALL_PROGRAM) $(target) $(DESTDIR)$(bindir)
+ $(INSTALL_SCRIPT) $(target) $(DESTDIR)$(bindir)
$(INSTALL_DATA) $(call vpath_file,$(target).1) $(DESTDIR)$(mandir)/man1
$(INSTALL_DATA) $(call vpath_file,/$(target).info) \
$(DESTDIR)$(infodir)/$(target).info

View file

@ -1,26 +0,0 @@
bin/help2man
%%NLS%%lib/bindtextdomain.so
%%NLS%%share/locale/de/LC_MESSAGES/help2man.mo
%%NLS%%share/locale/fi/LC_MESSAGES/help2man.mo
%%NLS%%share/locale/fr/LC_MESSAGES/help2man.mo
%%NLS%%share/locale/pl/LC_MESSAGES/help2man.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/help2man.mo
%%NLS%%share/locale/ru/LC_MESSAGES/help2man.mo
%%NLS%%share/locale/sv/LC_MESSAGES/help2man.mo
%%NLS%%share/locale/vi/LC_MESSAGES/help2man.mo
%%NLS%%@dirrmtry man/de/man1
%%NLS%%@dirrmtry man/de
%%NLS%%@dirrmtry man/fi/man1
%%NLS%%@dirrmtry man/fi
%%NLS%%@dirrmtry man/fr/man1
%%NLS%%@dirrmtry man/fr
%%NLS%%@dirrmtry man/pl/man1
%%NLS%%@dirrmtry man/pl
%%NLS%%@dirrmtry man/pt_BR/man1
%%NLS%%@dirrmtry man/pt_BR
%%NLS%%@dirrmtry man/ru/man1
%%NLS%%@dirrmtry man/ru
%%NLS%%@dirrmtry man/sv/man1
%%NLS%%@dirrmtry man/sv
%%NLS%%@dirrmtry man/vi/man1
%%NLS%%@dirrmtry man/vi