deskutils/budgie-desktop-view: Disable predefined optimization

Disable optimization set by upstream which overrides framework and also
tries to clever by breaking meson's internal handling of optimization

Reported by:	jbeich
Approved by:	portmgr (blanket)
This commit is contained in:
Daniel Engberg 2023-07-05 19:48:21 +02:00
parent 17c30e448b
commit 94dd820deb
2 changed files with 37 additions and 2 deletions

View file

@ -1,6 +1,17 @@
--- meson.build.orig 2022-03-06 16:37:45 UTC
--- meson.build.orig 2023-01-29 14:42:17 UTC
+++ meson.build
@@ -75,7 +75,7 @@ if xdg_appdir == ''
@@ -4,10 +4,8 @@ project(
version: '1.2.1',
license: [ 'Apache-2.0' ],
default_options: [
- 'b_lto=false',
'c_std=c11',
'buildtype=release',
- 'optimization=3',
'werror=true',
'warning_level=3',
],
@@ -75,7 +73,7 @@ if xdg_appdir == ''
if with_stateless == true
xdg_appdir = join_paths(datadir, 'xdg', 'autostart')
else

View file

@ -0,0 +1,24 @@
--- src/meson.build.orig 2023-07-05 17:42:24 UTC
+++ src/meson.build
@@ -21,14 +21,6 @@ desktop_view_deps = [
c_flags = []
-optimization_level = get_option('optimization')
-
-if optimization_level == '0'
- warning('We recommend setting an optimization level')
-else
- c_flags += '-O'+optimization_level
-endif
-
executable(
'org.buddiesofbudgie.budgie-desktop-view',
desktop_view_sources,
@@ -42,4 +34,4 @@ executable(
install: true,
install_dir: join_paths(get_option('prefix'), get_option('bindir')),
c_args: c_flags,
-)
\ No newline at end of file
+)