- Update to 1.5.3
- Pass maintainership to submitter PR: ports/145771 Submitted by: Ashish SHUKLA <wahjava@gmail.com>
This commit is contained in:
parent
181dc31424
commit
9531afff43
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=252900
8 changed files with 142 additions and 67 deletions
|
@ -7,41 +7,53 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= eukleides
|
PORTNAME= eukleides
|
||||||
PORTVERSION= 1.0.3
|
PORTVERSION= 1.5.3
|
||||||
PORTREVISION= 5
|
|
||||||
CATEGORIES= math
|
CATEGORIES= math
|
||||||
MASTER_SITES= http://www.eukleides.org/download/
|
MASTER_SITES= http://www.eukleides.org/files/
|
||||||
DISTNAME= ${PORTNAME}.${PORTVERSION}
|
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
MAINTAINER= wahjava@gmail.com
|
||||||
COMMENT= A Euclidean geometry drawing language
|
COMMENT= A Euclidean geometry drawing language
|
||||||
|
|
||||||
|
LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
|
||||||
RUN_DEPENDS= pstoedit:${PORTSDIR}/graphics/pstoedit \
|
RUN_DEPENDS= pstoedit:${PORTSDIR}/graphics/pstoedit \
|
||||||
epstopdf:${PORTSDIR}/print/teTeX-base
|
epstopdf:${PORTSDIR}/print/teTeX-base
|
||||||
|
|
||||||
|
USE_BZIP2= yes
|
||||||
USE_BISON= build
|
USE_BISON= build
|
||||||
USE_GMAKE= yes
|
USE_GMAKE= yes
|
||||||
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -c"
|
USE_GETTEXT= yes
|
||||||
ALL_TARGET= eukleides info
|
USE_ICONV= yes
|
||||||
|
|
||||||
MAN1= eukleides.1
|
MAN1= eukleides.1 euktoeps.1 euktopdf.1 euktopst.1 euktotex.1
|
||||||
MLINKS= eukleides.1 euk2eps.1 \
|
PORTEXAMPLES= greenwich.euk sundial.euk vonkoch.euk
|
||||||
eukleides.1 euk2edit.1
|
|
||||||
|
.ifndef NOPORTDOCS
|
||||||
|
BUILD_DEPENDS= pdflatex:${PORTSDIR}/print/teTeX-base
|
||||||
|
PORTDOCS= de.pdf fr.pdf
|
||||||
INFO= eukleides
|
INFO= eukleides
|
||||||
|
.endif
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
|
${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
|
||||||
's|#!/bin/bash|#!/bin/sh|g'
|
's|#!/bin/bash|#!/bin/sh|g'
|
||||||
|
${GREP} -lR "ginstall-info" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
|
||||||
do-install:
|
's|ginstall-info|install-info|g'
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/eukleides ${PREFIX}/bin
|
${GREP} -lR "%%[[:alpha:]]\+%%" ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
|
||||||
${INSTALL_SCRIPT} ${WRKSRC}/euk2edit ${PREFIX}/bin
|
-e "s|%%PREFIX%%|${PREFIX}|g" \
|
||||||
${INSTALL_SCRIPT} ${WRKSRC}/euk2eps ${PREFIX}/bin
|
-e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
|
||||||
${INSTALL_MAN} ${WRKSRC}/eukleides.1 ${MANPREFIX}/man/man1
|
-e "s|%%EXAMPLESDIR%%|${EXAMPLESDIR}|g" \
|
||||||
${INSTALL_DATA} ${WRKSRC}/eukleides.info ${PREFIX}/${INFO_PATH}
|
-e "s|%%DOCSDIR%%|${DOCSDIR}|g"
|
||||||
.if !defined(NOPORTDOCS)
|
.ifdef NOPORTDOCS
|
||||||
@${MKDIR} ${EXAMPLESDIR}
|
${REINPLACE_CMD} -e '/^install:/ s/install_doc//g' \
|
||||||
${INSTALL_DATA} ${WRKSRC}/samples/*.euk ${EXAMPLESDIR}
|
-e '/^all:/ s/doc//g' ${WRKSRC}/Makefile
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
|
pre-install:
|
||||||
|
${MKDIR} ${EXAMPLESDIR}
|
||||||
|
|
||||||
|
post-install:
|
||||||
|
for i in euktoeps euktopdf euktotex; do \
|
||||||
|
${RM} ${PREFIX}/bin/$${i}.bak; \
|
||||||
|
done
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (eukleides.1.0.3.tar.gz) = a0ab145109bd3804d9550b3bf3306c05
|
MD5 (eukleides-1.5.3.tar.bz2) = 5bcc9c18b3565100010456079937f01a
|
||||||
SHA256 (eukleides.1.0.3.tar.gz) = 13d1f959c3c352939d763db96f0aac6be286825919cc156c3c702624a0e53fb0
|
SHA256 (eukleides-1.5.3.tar.bz2) = a9c2f08497d3cb48832fb332784fb4f53a0b1e38f98ce44031773873d97ac32c
|
||||||
SIZE (eukleides.1.0.3.tar.gz) = 50915
|
SIZE (eukleides-1.5.3.tar.bz2) = 77439
|
||||||
|
|
35
math/eukleides/files/patch-Config
Normal file
35
math/eukleides/files/patch-Config
Normal file
|
@ -0,0 +1,35 @@
|
||||||
|
|
||||||
|
$FreeBSD$
|
||||||
|
|
||||||
|
--- Config.orig
|
||||||
|
+++ Config
|
||||||
|
@@ -2,13 +2,13 @@
|
||||||
|
# Copyright (c) Christian Obrecht 2004-2010
|
||||||
|
|
||||||
|
# Installation prefix
|
||||||
|
-PREFIX=/usr/local
|
||||||
|
+PREFIX=%%PREFIX%%
|
||||||
|
|
||||||
|
BINARIES = eukleides euktopst
|
||||||
|
|
||||||
|
# Localized keywords
|
||||||
|
# Uncomment to enable this feature.
|
||||||
|
-# LOCALES = de fr
|
||||||
|
+LOCALES = de fr
|
||||||
|
|
||||||
|
# Documentation
|
||||||
|
# Alternative targets are 'pdf' and 'html'.
|
||||||
|
@@ -27,9 +27,9 @@
|
||||||
|
BIN_DIR = $(PREFIX)/bin
|
||||||
|
SHARE_DIR = $(PREFIX)/share
|
||||||
|
MO_DIR = $(SHARE_DIR)/locale
|
||||||
|
-DOC_DIR = $(SHARE_DIR)/doc/eukleides
|
||||||
|
-EXM_DIR = $(DOC_DIR)/examples
|
||||||
|
-MAN_DIR = $(SHARE_DIR)/man/man1
|
||||||
|
-INFO_DIR = $(SHARE_DIR)/info
|
||||||
|
+DOC_DIR = %%DOCSDIR%%
|
||||||
|
+EXM_DIR = %%EXAMPLESDIR%%
|
||||||
|
+MAN_DIR = $(PREFIX)/man/man1
|
||||||
|
+INFO_DIR = $(PREFIX)/info
|
||||||
|
TEX_DIR = $(SHARE_DIR)/texmf/tex/latex/eukleides
|
||||||
|
|
20
math/eukleides/files/patch-build_Makefile
Normal file
20
math/eukleides/files/patch-build_Makefile
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
|
||||||
|
$FreeBSD$
|
||||||
|
|
||||||
|
--- build/Makefile.orig
|
||||||
|
+++ build/Makefile
|
||||||
|
@@ -12,12 +12,12 @@
|
||||||
|
YACC = bison
|
||||||
|
YFLAGS = -d
|
||||||
|
CC = gcc
|
||||||
|
-IFLAGS = -I$(COMMON_DIR) -I$(MAIN_DIR) -I$(BUILD_DIR)
|
||||||
|
+IFLAGS = -I$(COMMON_DIR) -I$(MAIN_DIR) -I$(BUILD_DIR) "-I%%LOCALBASE%%/include"
|
||||||
|
ifneq ($(strip $(LOCALES)),)
|
||||||
|
MOFLAGS = -DMO_DIR=\"$(MO_DIR)\"
|
||||||
|
endif
|
||||||
|
CFLAGS = -Wall -D__$(BINARY)__ $(IFLAGS) $(MOFLAGS)
|
||||||
|
-LDFLAGS = -lncurses -lreadline -lm
|
||||||
|
+LDFLAGS = -lncurses -lreadline -lm "-L%%LOCALBASE%%/lib" -lintl
|
||||||
|
VPATH = $(COMMON_DIR):$(MAIN_DIR):$(BUILD_DIR)
|
||||||
|
|
||||||
|
$(BINARY):
|
20
math/eukleides/files/patch-build_Makefile~
Normal file
20
math/eukleides/files/patch-build_Makefile~
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
|
||||||
|
$FreeBSD$
|
||||||
|
|
||||||
|
--- build/Makefile.orig
|
||||||
|
+++ build/Makefile
|
||||||
|
@@ -12,12 +12,12 @@
|
||||||
|
YACC = bison
|
||||||
|
YFLAGS = -d
|
||||||
|
CC = gcc
|
||||||
|
-IFLAGS = -I$(COMMON_DIR) -I$(MAIN_DIR) -I$(BUILD_DIR)
|
||||||
|
+IFLAGS = -I$(COMMON_DIR) -I$(MAIN_DIR) -I$(BUILD_DIR) "-I%%LOCALBASE%%/../include" "-I%%LOCALBASE%%/include"
|
||||||
|
ifneq ($(strip $(LOCALES)),)
|
||||||
|
MOFLAGS = -DMO_DIR=\"$(MO_DIR)\"
|
||||||
|
endif
|
||||||
|
CFLAGS = -Wall -D__$(BINARY)__ $(IFLAGS) $(MOFLAGS)
|
||||||
|
-LDFLAGS = -lncurses -lreadline -lm
|
||||||
|
+LDFLAGS = -lncurses -lreadline -lm "-L%%LOCALBASE%%/lib" -lintl
|
||||||
|
VPATH = $(COMMON_DIR):$(MAIN_DIR):$(BUILD_DIR)
|
||||||
|
|
||||||
|
$(BINARY):
|
20
math/eukleides/files/patch-man_Makefile
Normal file
20
math/eukleides/files/patch-man_Makefile
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
|
||||||
|
$FreeBSD$
|
||||||
|
|
||||||
|
--- man/Makefile.orig
|
||||||
|
+++ man/Makefile
|
||||||
|
@@ -3,13 +3,10 @@
|
||||||
|
|
||||||
|
include ../Config
|
||||||
|
|
||||||
|
-MAN_PAGES := $(addsuffix .gz, $(wildcard *.1))
|
||||||
|
+MAN_PAGES := $(wildcard *.1)
|
||||||
|
|
||||||
|
man: $(MAN_PAGES)
|
||||||
|
|
||||||
|
-%.1.gz: %.1
|
||||||
|
- @gzip -c $< > $@
|
||||||
|
-
|
||||||
|
install: $(MAN_PAGES)
|
||||||
|
@install -d $(MAN_DIR)
|
||||||
|
@install -m 0644 $^ $(MAN_DIR)
|
|
@ -1,21 +0,0 @@
|
||||||
--- parser.y.orig 2009-03-13 18:38:32.000000000 +0100
|
|
||||||
+++ parser.y 2009-03-13 18:38:19.000000000 +0100
|
|
||||||
@@ -29,7 +29,6 @@
|
|
||||||
int warning(char *);
|
|
||||||
int yyerror(char *);
|
|
||||||
|
|
||||||
-int drawing_style = FULL;
|
|
||||||
symrec* tracevar;
|
|
||||||
double tracestep, tracebegin;
|
|
||||||
int tracestyle, traceind = -1;
|
|
||||||
@@ -93,6 +92,10 @@
|
|
||||||
%type <flag> drawing_flag segment_marking_flag angle_marking_flag color_flag
|
|
||||||
%type <string> ident
|
|
||||||
|
|
||||||
+%{
|
|
||||||
+int drawing_style = FULL;
|
|
||||||
+%}
|
|
||||||
+
|
|
||||||
%%
|
|
||||||
|
|
||||||
input:
|
|
|
@ -1,24 +1,13 @@
|
||||||
bin/euk2edit
|
|
||||||
bin/euk2eps
|
|
||||||
bin/eukleides
|
bin/eukleides
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/abdul_al_wafa.euk
|
bin/euktoeps
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/agnesi.euk
|
bin/euktopdf
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/angles.euk
|
bin/euktopst
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/archimedes.euk
|
bin/euktotex
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/bisectors.euk
|
share/locale/de/LC_MESSAGES/eukleides.mo
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/gravity_center.euk
|
share/locale/fr/LC_MESSAGES/eukleides.mo
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/inequality.euk
|
share/texmf/tex/latex/eukleides/eukleides.sty
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/intercept.euk
|
share/texmf/tex/latex/eukleides/eukleides.tex
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/intersection.euk
|
@dirrm share/texmf/tex/latex/eukleides
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/lines_and_circles.euk
|
@dirrmtry share/texmf/tex/latex
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/locus.euk
|
@dirrmtry share/texmf/tex
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/morley.euk
|
@dirrmtry share/texmf
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/orthocenter.euk
|
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/parallelogram.euk
|
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/pascal.euk
|
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/perdigal.euk
|
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/pstexample.euk
|
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/quadrilateral.euk
|
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/similar.euk
|
|
||||||
%%PORTDOCS%%%%EXAMPLESDIR%%/vecten.euk
|
|
||||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
|
|
||||||
|
|
Loading…
Reference in a new issue