devel/glog: Update to 0.7.0

- Convert to USES=cmake:testing
- Sort PLIST
- Bump PORTREVISION of dependent ports for shlib change
  Broken ports are skipped:
  - graphics/colmap [1]
  - graphics/hiptext [2]
  - graphics/openmvs
  - sysutils/apache-mesos

[2] This port was being skipped on package building cluster due to its LICENSE
    "License NONE needs confirmation, but BATCH is defined"

Changes:	https://github.com/google/glog/releases
Reference:	https://pkg-status.freebsd.org/beefy12/data/140amd64-default/84a61d95b0a5/logs/colmap-3.8_5.log [1]
This commit is contained in:
Po-Chuan Hsieh 2024-03-09 21:44:52 +08:00
parent 1fb20025d7
commit 95323d15a8
No known key found for this signature in database
GPG Key ID: 9A4BD10F002DD04B
27 changed files with 74 additions and 103 deletions

View File

@ -1,8 +1,11 @@
PORTNAME= librime
PORTVERSION= 1.7.3
PORTREVISION= 8
PORTREVISION= 9
CATEGORIES= chinese textproc
PATCH_SITES= https://github.com/rime/librime/commit/
PATCHFILES= c34c9ea4069bdba9d0f829e615769d79549701a9.patch:-p1
MAINTAINER= khng@FreeBSD.org
COMMENT= Rime Input Method Engine, the core library
WWW= https://rime.github.io/
@ -27,6 +30,7 @@ CMAKE_OFF= BUILD_TEST
USE_CXXSTD= c++14
USE_LDCONFIG= yes
USE_XORG= xorgproto
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
LDFLAGS+= -lintl
USE_GITHUB= yes
GH_ACCOUNT= rime

View File

@ -1,3 +1,5 @@
TIMESTAMP = 1638225885
TIMESTAMP = 1709459567
SHA256 (rime-librime-1.7.3_GH0.tar.gz) = c76b937a27d7b9352c3eea9eb3adaebf70c93457104c7d47d40c006009092c20
SIZE (rime-librime-1.7.3_GH0.tar.gz) = 2859513
SHA256 (c34c9ea4069bdba9d0f829e615769d79549701a9.patch) = a2600c1e70e9d009552a69c71f16d7e73586a1ac42be44afad80b3157841f83d
SIZE (c34c9ea4069bdba9d0f829e615769d79549701a9.patch) = 1751

View File

@ -1,6 +1,7 @@
PORTNAME= fbthrift
DISTVERSIONPREFIX= v
DISTVERSION= 2024.03.04.00
PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@ -39,6 +40,7 @@ CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_TESTING_ON= enable_tests
CXXFLAGS+= -fPIC # https://github.com/facebook/fbthrift/issues/399
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
post-install: # https://github.com/facebook/fbthrift/issues/393
@${FIND} ${STAGEDIR}${PREFIX}/include -type d -empty -delete

View File

@ -1,6 +1,7 @@
PORTNAME= folly
DISTVERSIONPREFIX= v
DISTVERSION= 2024.03.04.00
PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@ -43,6 +44,7 @@ CMAKE_OFF= FREEBSD_BUILD_EXAMPLES FREEBSD_FOLLY_USE_SYMBOLIZER # enabling symbol
#CMAKE_OFF+= FOLLY_USE_JEMALLOC # Build fails with FOLLY_USE_JEMALLOC=OFF, see https://github.com/facebook/folly/issues/1893
CXXFLAGS+= -fPIC
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
CXXFLAGS_powerpc64= -DFOLLY_QUOTIENT_MULTI_SET_SUPPORTED=0
do-test: # tests fail to compile, see https://github.com/facebook/folly/issues/2032

View File

@ -0,0 +1,10 @@
--- folly/experimental/symbolizer/Elf.cpp.orig 2024-02-16 02:33:47 UTC
+++ folly/experimental/symbolizer/Elf.cpp
@@ -19,6 +19,7 @@
#include <fcntl.h>
#include <sys/stat.h>
#include <sys/types.h>
+#include <unistd.h>
#include <cstring>
#include <string>

View File

@ -1,5 +1,5 @@
PORTNAME= glog
PORTVERSION= 0.6.0
PORTVERSION= 0.7.0
DISTVERSIONPREFIX= v
CATEGORIES= devel
@ -12,15 +12,16 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgflags.so:devel/gflags \
libunwind.so:devel/libunwind
TEST_DEPENDS= googletest>=0:devel/googletest
USES= cmake compiler:c++11-lang pkgconfig
CMAKE_ON= BUILD_SHARED_LIBS WITH_CUSTOM_PREFIX WITH_GFLAGS WITH_PKGCONFIG WITH_SYMBOLIZE WITH_THREADS WITH_TLS WITH_UNWIND
CMAKE_OFF= PRINT_UNSYMBOLIZED_STACK_TRACES WITH_GTEST
USES= cmake:testing compiler:c++14-lang
CMAKE_ARGS= -DWITH_FUZZING=none -DWITH_UNWIND=libunwind
CMAKE_OFF= PRINT_UNSYMBOLIZED_STACK_TRACES WITH_GMOCK WITH_GTEST
CMAKE_ON= BUILD_SHARED_LIBS WITH_GFLAGS WITH_PKGCONFIG WITH_SYMBOLIZE WITH_TLS
CMAKE_TESTING_ON= WITH_GMOCK WITH_GTEST
LDFLAGS+= -lexecinfo
TEST_TARGET= test
USE_CXXSTD= c++11
USE_CXXSTD= c++14
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}

View File

@ -1,3 +1,5 @@
TIMESTAMP = 1650084662
SHA256 (google-glog-v0.6.0_GH0.tar.gz) = 8a83bf982f37bb70825df71a9709fa90ea9f4447fb3c099e1d720a439d88bad6
SIZE (google-glog-v0.6.0_GH0.tar.gz) = 193267
TIMESTAMP = 1709390360
SHA256 (google-glog-v0.7.0_GH0.tar.gz) = 375106b5976231b92e66879c1a92ce062923b9ae573c42b56ba28b112ee4cc11
SIZE (google-glog-v0.7.0_GH0.tar.gz) = 182654
SHA256 (5a7856ab964356990b948e5ea98b55938ed271c7.patch) = fc7c4d2af7c658fa408c60136d60aa3967db20b239c71281060e492e54d4c188
SIZE (5a7856ab964356990b948e5ea98b55938ed271c7.patch) = 2712

View File

@ -1,23 +1,11 @@
--- CMakeLists.txt.orig 2021-05-07 23:05:04 UTC
--- CMakeLists.txt.orig 2024-02-17 17:49:26 UTC
+++ CMakeLists.txt
@@ -113,8 +113,6 @@ check_include_file_cxx (unistd.h HAVE_UNISTD_H)
check_include_file_cxx ("ext/hash_map" HAVE_EXT_HASH_MAP)
check_include_file_cxx ("ext/hash_set" HAVE_EXT_HASH_SET)
check_include_file_cxx ("ext/slist" HAVE_EXT_SLIST)
-check_include_file_cxx ("tr1/unordered_map" HAVE_TR1_UNORDERED_MAP)
-check_include_file_cxx ("tr1/unordered_set" HAVE_TR1_UNORDERED_SET)
check_include_file_cxx ("unordered_map" HAVE_UNORDERED_MAP)
check_include_file_cxx ("unordered_set" HAVE_UNORDERED_SET)
@@ -970,7 +970,7 @@ if (WITH_PKGCONFIG)
if (WITH_PKGCONFIG)
install (
FILES "${glog_BINARY_DIR}/libglog.pc"
- DESTINATION "${_glog_CMake_LIBDIR}/pkgconfig"
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig"
)
endif (WITH_PKGCONFIG)
@@ -678,11 +676,6 @@ if (BUILD_TESTING)
target_compile_definitions (stl_logging_unittest PRIVATE
GLOG_STL_LOGGING_FOR_UNORDERED)
endif (HAVE_UNORDERED_MAP AND HAVE_UNORDERED_SET)
-
- if (HAVE_TR1_UNORDERED_MAP AND HAVE_TR1_UNORDERED_SET)
- target_compile_definitions (stl_logging_unittest PRIVATE
- GLOG_STL_LOGGING_FOR_TR1_UNORDERED)
- endif (HAVE_TR1_UNORDERED_MAP AND HAVE_TR1_UNORDERED_SET)
if (HAVE_EXT_HASH_MAP AND HAVE_EXT_HASH_SET)
target_compile_definitions (stl_logging_unittest PRIVATE

View File

@ -1,44 +0,0 @@
--- src/glog/stl_logging.h.in.orig 2021-05-07 23:05:04 UTC
+++ src/glog/stl_logging.h.in
@@ -39,7 +39,6 @@
// need to define macros before including this file:
//
// - GLOG_STL_LOGGING_FOR_UNORDERED - <unordered_map> and <unordered_set>
-// - GLOG_STL_LOGGING_FOR_TR1_UNORDERED - <tr1/unordered_(map|set)>
// - GLOG_STL_LOGGING_FOR_EXT_HASH - <ext/hash_(map|set)>
// - GLOG_STL_LOGGING_FOR_EXT_SLIST - <ext/slist>
//
@@ -64,11 +63,6 @@
# include <unordered_set>
#endif
-#ifdef GLOG_STL_LOGGING_FOR_TR1_UNORDERED
-# include <tr1/unordered_map>
-# include <tr1/unordered_set>
-#endif
-
#ifdef GLOG_STL_LOGGING_FOR_EXT_HASH
# include <ext/hash_set>
# include <ext/hash_map>
@@ -134,10 +128,6 @@ OUTPUT_FOUR_ARG_CONTAINER(std::multimap)
OUTPUT_FOUR_ARG_CONTAINER(std::unordered_set)
OUTPUT_FOUR_ARG_CONTAINER(std::unordered_multiset)
#endif
-#ifdef GLOG_STL_LOGGING_FOR_TR1_UNORDERED
-OUTPUT_FOUR_ARG_CONTAINER(std::tr1::unordered_set)
-OUTPUT_FOUR_ARG_CONTAINER(std::tr1::unordered_multiset)
-#endif
#ifdef GLOG_STL_LOGGING_FOR_EXT_HASH
OUTPUT_FOUR_ARG_CONTAINER(__gnu_cxx::hash_set)
OUTPUT_FOUR_ARG_CONTAINER(__gnu_cxx::hash_multiset)
@@ -156,10 +146,6 @@ inline std::ostream& operator<<(std::ostream& out, \
#ifdef GLOG_STL_LOGGING_FOR_UNORDERED
OUTPUT_FIVE_ARG_CONTAINER(std::unordered_map)
OUTPUT_FIVE_ARG_CONTAINER(std::unordered_multimap)
-#endif
-#ifdef GLOG_STL_LOGGING_FOR_TR1_UNORDERED
-OUTPUT_FIVE_ARG_CONTAINER(std::tr1::unordered_map)
-OUTPUT_FIVE_ARG_CONTAINER(std::tr1::unordered_multimap)
#endif
#ifdef GLOG_STL_LOGGING_FOR_EXT_HASH
OUTPUT_FIVE_ARG_CONTAINER(__gnu_cxx::hash_map)

View File

@ -1,11 +1,11 @@
--- src/stacktrace_powerpc-inl.h.orig 2019-12-01 18:35:43 UTC
--- src/stacktrace_powerpc-inl.h.orig 2024-02-17 17:49:26 UTC
+++ src/stacktrace_powerpc-inl.h
@@ -107,7 +107,7 @@ int GetStackTrace(void** result, int max_depth, int sk
@@ -111,7 +111,7 @@ int GetStackTrace(void** result, int max_depth, int sk
// Link Register is. For DARWIN and AIX (used by apple and
// linux ppc64), it's in sp[2]. For SYSV (used by linux ppc),
// it's in sp[1].
-#if defined(_CALL_AIX) || defined(_CALL_DARWIN)
+#if defined(_CALL_AIX) || defined(_CALL_DARWIN) || defined(_CALL_ELF)
result[n++] = *(sp+2);
result[n++] = *(sp + 2);
#elif defined(_CALL_SYSV)
result[n++] = *(sp+1);
result[n++] = *(sp + 1);

View File

@ -1,12 +0,0 @@
--- src/stl_logging_unittest.cc.orig 2021-05-07 23:05:04 UTC
+++ src/stl_logging_unittest.cc
@@ -52,9 +52,6 @@
# ifndef GLOG_STL_LOGGING_FOR_EXT_SLIST
# define GLOG_STL_LOGGING_FOR_EXT_SLIST
# endif
-# ifndef GLOG_STL_LOGGING_FOR_TR1_UNORDERED
-# define GLOG_STL_LOGGING_FOR_TR1_UNORDERED
-# endif
# endif
#endif

View File

@ -1,9 +1,11 @@
include/glog/export.h
include/glog/flags.h
include/glog/log_severity.h
include/glog/logging.h
include/glog/platform.h
include/glog/raw_logging.h
include/glog/stl_logging.h
include/glog/types.h
include/glog/vlog_is_on.h
lib/cmake/glog/glog-config-version.cmake
lib/cmake/glog/glog-config.cmake
@ -11,7 +13,7 @@ lib/cmake/glog/glog-modules.cmake
lib/cmake/glog/glog-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/glog/glog-targets.cmake
lib/libglog.so
lib/libglog.so.1
lib/libglog.so.%%PORTVERSION%%
lib/libglog.so.2
libdata/pkgconfig/libglog.pc
%%DATADIR%%/cmake/FindUnwind.cmake

View File

@ -1,6 +1,6 @@
PORTNAME= blender
DISTVERSION= 3.6.1
PORTREVISION= 7
PORTREVISION= 8
CATEGORIES= graphics multimedia
MASTER_SITES= http://download.blender.org/source/ \
http://mirror.cs.umn.edu/blender.org/source/ \
@ -42,6 +42,7 @@ SHEBANG_FILES= scripts/modules/bl_i18n_utils/merge_po.py \
CFLAGS+= ${CFLAGS_${CHOSEN_COMPILER_TYPE}}
CFLAGS_gcc= -Wno-float-conversion
CFLAGS_i386= -march=i586
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
CXXFLAGS_i386= -march=i586
PLIST_SUB+= VER=${DISTVERSION:R}

View File

@ -1,6 +1,6 @@
PORTNAME= opencv
DISTVERSION= 4.6.0
PORTREVISION= 16
PORTREVISION= 17
CATEGORIES= graphics
PATCH_SITES= https://github.com/${PORTNAME}/${PORTNAME}/commit/

View File

@ -1,5 +1,6 @@
PORTNAME= s2
PORTVERSION= 0.11.1
PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= graphics

View File

@ -1,6 +1,6 @@
PORTNAME= ceres-solver
DISTVERSION= 2.2.0
PORTREVISION= 7
PORTREVISION= 8
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org

View File

@ -1,7 +1,7 @@
PORTNAME= openturns
DISTVERSIONPREFIX= v
DISTVERSION= 1.22
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org

View File

@ -1,7 +1,7 @@
PORTNAME= or-tools
DISTVERSIONPREFIX= v
DISTVERSION= 9.5
PORTREVISION= 7
PORTREVISION= 8
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org

View File

@ -1,7 +1,7 @@
PORTNAME= or-tools
DISTVERSIONPREFIX= v
DISTVERSION= 9.5
PORTREVISION= 7
PORTREVISION= 8
CATEGORIES= math
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View File

@ -1,7 +1,7 @@
PORTNAME= caffe
DISTVERSION= 1.0-136
DISTVERSIONSUFFIX= -g9b891540
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= misc # machine-learning
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@ -46,6 +46,7 @@ GH_ACCOUNT= BVLC
CMAKE_ARGS= -DBLAS=Open \
-DPYTHON_EXECUTABLE=${PYTHON_CMD} \
-DFREEBSD_PYTHONPREFIX_SITELIBDIR=${PYTHONPREFIX_SITELIBDIR}
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
LDFLAGS+= -lpython${PYTHON_VER}
PORTSCOUT= limit:^[0-9].*[0-9]$$ # should begin and end with a digit to prevent tags like rcnn-release and rc5

View File

@ -1,7 +1,7 @@
PORTNAME= openmvg
DISTVERSIONPREFIX= v
DISTVERSION= 2.1
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= misc science
MAINTAINER= yuri@FreeBSD.org

View File

@ -1,6 +1,7 @@
PORTNAME= fb303
DISTVERSIONPREFIX= v
DISTVERSION= 2024.03.04.00
PORTREVISION= 1
CATEGORIES= net
MAINTAINER= yuri@FreeBSD.org
@ -36,6 +37,7 @@ USE_GITHUB= yes
GH_ACCOUNT= facebook
CXXFLAGS+= -fPIC
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= PYTHON_EXTENSIONS

View File

@ -1,7 +1,7 @@
PORTNAME= fbzmq
DISTVERSIONPREFIX= v
DISTVERSION= 2022.05.30.00
PORTREVISION= 7
PORTREVISION= 8
CATEGORIES= net
MAINTAINER= yuri@FreeBSD.org
@ -38,5 +38,6 @@ CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= BUILD_TESTS
CXXFLAGS+= -I${LOCALBASE}/include/libepoll-shim -fPIC
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
.include <bsd.port.mk>

View File

@ -1,6 +1,7 @@
PORTNAME= mvfst
DISTVERSIONPREFIX= v
DISTVERSION= 2024.03.04.00
PORTREVISION= 1
CATEGORIES= net
MAINTAINER= yuri@FreeBSD.org
@ -39,5 +40,6 @@ CMAKE_OFF= BUILD_TESTS
CMAKE_TESTING_ON= BUILD_TESTS # several tests fail, see https://github.com/facebookincubator/mvfst/issues/275
CXXFLAGS+= -fPIC
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
.include <bsd.port.mk>

View File

@ -1,6 +1,7 @@
PORTNAME= wangle
DISTVERSIONPREFIX= v
DISTVERSION= 2024.03.04.00
PORTREVISION= 1
CATEGORIES= net
MAINTAINER= yuri@FreeBSD.org
@ -35,6 +36,7 @@ WRKSRC_SUBDIR= ${PORTNAME}
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= BUILD_TESTS
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
post-install: # https://github.com/facebook/wangle/issues/179
cd ${STAGEDIR}${PREFIX} && \

View File

@ -1,6 +1,7 @@
PORTNAME= fizz
DISTVERSIONPREFIX= v
DISTVERSION= 2024.03.04.00
PORTREVISION= 1
CATEGORIES= security
MAINTAINER= yuri@FreeBSD.org
@ -38,6 +39,7 @@ WRKSRC_SUBDIR= ${PORTNAME}
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= BUILD_TESTS BUILD_EXAMPLES
CMAKE_TESTING_ON= BUILD_TESTS
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
post-install: # https://github.com/facebookincubator/fizz/issues/55
cd ${STAGEDIR}${PREFIX} && ${RMDIR} include/fizz/tool/test include/fizz/util/test

View File

@ -1,6 +1,7 @@
PORTNAME= proxygen
DISTVERSIONPREFIX= v
DISTVERSION= 2024.03.04.00
PORTREVISION= 1
CATEGORIES= www
MAINTAINER= yuri@FreeBSD.org
@ -37,6 +38,7 @@ GH_ACCOUNT= facebook
USE_LDCONFIG= yes
CXXFLAGS+= -fPIC
CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
LDFLAGS+= -lexecinfo
CMAKE_ON= BUILD_SHARED_LIBS