Update to 0.4.1
PR: 42132 Submitted by: Bob Bomar <bob@bomar.us>
This commit is contained in:
parent
04cefd4b0c
commit
955f0be219
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72762
8 changed files with 80 additions and 130 deletions
|
@ -6,15 +6,15 @@
|
|||
#
|
||||
|
||||
PORTNAME= qwt
|
||||
PORTVERSION= 0.4.0
|
||||
PORTVERSION= 0.4.1
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR=qwt
|
||||
|
||||
MAINTAINER= bob@fly.homeunix.org
|
||||
|
||||
USE_QT_VER= 2
|
||||
MAINTAINER= bob@bomar.us
|
||||
|
||||
USE_QT_VER= 3
|
||||
USE_BZIP2= yes
|
||||
MAKE_ENV= CXXFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
|
||||
INCPATH="-I${X11BASE}/include/qt2" \
|
||||
LIBS="-L${X11BASE}/lib" \
|
||||
|
@ -24,21 +24,24 @@ MAKE_ENV= CXXFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
|
|||
MAN3= Qwt.3 \
|
||||
QwtArrowButton.3 \
|
||||
QwtAutoScale.3 \
|
||||
QwtColorFilter.3 \
|
||||
QwtCounter.3 \
|
||||
QwtCurve.3 \
|
||||
QwtDblRange.3 \
|
||||
QwtDiMap.3 \
|
||||
QwtFltrDim.3 \
|
||||
QwtFltrGray.3 \
|
||||
QwtFltrInv.3 \
|
||||
QwtGrid.3 \
|
||||
QwtKnob.3 \
|
||||
QwtLegend.3 \
|
||||
QwtLegendItem.3 \
|
||||
QwtMarker.3 \
|
||||
QwtPixFrame.3 \
|
||||
QwtPlot.3 \
|
||||
QwtPlotCanvas.3 \
|
||||
QwtPlotCurve.3 \
|
||||
QwtPlotGrid.3 \
|
||||
QwtPlotItem.3 \
|
||||
QwtPlotMappedItem.3 \
|
||||
QwtPlotMarker.3 \
|
||||
QwtPlotPrintFilter.3 \
|
||||
QwtRect.3 \
|
||||
QwtScale.3 \
|
||||
QwtScaleDiv.3 \
|
||||
QwtScaleDraw.3 \
|
||||
|
@ -49,18 +52,17 @@ MAN3= Qwt.3 \
|
|||
QwtSymbol.3 \
|
||||
QwtThermo.3 \
|
||||
QwtWheel.3 \
|
||||
bug.3 \
|
||||
changes.3 \
|
||||
install.3 \
|
||||
qwt_math.h.3 \
|
||||
screenshots.3
|
||||
|
||||
pre-build:
|
||||
${LN} -fs ${WRKSRC}/makefiles/freebsd-g++ ${WRKSRC}/Makefile
|
||||
cd ${WRKSRC}; qmake qwt.pro -o Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/libqwt.so.0.4.0 ${PREFIX}/lib
|
||||
${LN} -fs libqwt.so.0.4.0 ${PREFIX}/lib/libqwt.so
|
||||
${INSTALL_DATA} ${WRKSRC}/lib/libqwt.so.0.4.1 ${PREFIX}/lib
|
||||
${LN} -fs libqwt.so.0.4.1 ${PREFIX}/lib/libqwt.so
|
||||
${MKDIR} ${PREFIX}/include/qwt
|
||||
${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/qwt
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/man/man3/* ${PREFIX}/man/man3
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (qwt-0.4.0.tar.gz) = 3ca757793fa02ab691a7bfbbe531b1d8
|
||||
MD5 (qwt-0.4.1.tar.bz2) = 45c64b0382c8963cfde026a6d2324f6d
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
--- makefiles/freebsd-g++.orig Mon Oct 22 12:38:06 2001
|
||||
+++ makefiles/freebsd-g++ Tue Mar 12 17:40:28 2002
|
||||
@@ -7,17 +7,17 @@
|
||||
|
||||
####### Compiler, tools and options
|
||||
|
||||
-CC = gcc
|
||||
-CXX = g++
|
||||
-CFLAGS = -pipe -O2 -fPIC -DNO_DEBUG
|
||||
-CXXFLAGS= -pipe -O2 -fPIC -DNO_DEBUG
|
||||
-INCPATH = -I/usr/local/include -I$(QTDIR)/include
|
||||
+CC ?= gcc
|
||||
+CXX ?= g++
|
||||
+CFLAGS ?= -pipe -O2 -fPIC -DNO_DEBUG
|
||||
+CXXFLAGS?= -pipe -O2 -fPIC -DNO_DEBUG
|
||||
+INCPATH ?= -I/usr/local/include -I$(QTDIR)/include
|
||||
LINK = g++
|
||||
LFLAGS = -shared
|
||||
-LIBS = $(SUBLIBS) -L/usr/local/lib -L$(QTDIR)/lib -L/usr/X11R6/lib -lqt -lXext -lX11 -lm
|
||||
+LIBS = $(SUBLIBS) -L/usr/local/lib -L$(QTDIR)/lib -L/usr/X11R6/lib -lqt2 -lXext -lX11 -lm
|
||||
AR = ar cqs
|
||||
RANLIB =
|
||||
-MOC = $(QTDIR)/bin/moc
|
||||
+MOC ?= $(QTDIR)/bin/moc
|
||||
UIC = $(QTDIR)/bin/uic
|
||||
|
||||
TAR = tar -cf
|
|
@ -1,33 +1,33 @@
|
|||
include/qwt/qwt.h
|
||||
include/qwt/qwt_arrbtn.h
|
||||
include/qwt/qwt_autoscl.h
|
||||
include/qwt/qwt_clrfltr.h
|
||||
include/qwt/qwt_counter.h
|
||||
include/qwt/qwt_curve.h
|
||||
include/qwt/qwt_dimap.h
|
||||
include/qwt/qwt_drange.h
|
||||
include/qwt/qwt_grid.h
|
||||
include/qwt/qwt_knob.h
|
||||
include/qwt/qwt_legend.h
|
||||
include/qwt/qwt_sldbase.h
|
||||
include/qwt/qwt_plot_classes.h
|
||||
include/qwt/qwt_scale.h
|
||||
include/qwt/qwt_sclif.h
|
||||
include/qwt/qwt_rect.h
|
||||
include/qwt/qwt_thermo.h
|
||||
include/qwt/qwt_marker.h
|
||||
include/qwt/qwt_math.h
|
||||
include/qwt/qwt_pixframe.h
|
||||
include/qwt/qwt_plot.h
|
||||
include/qwt/qwt_plot_classes.h
|
||||
include/qwt/qwt_plot_dict.h
|
||||
include/qwt/qwt_plot_item.h
|
||||
include/qwt/qwt_plot_pixframe.h
|
||||
include/qwt/qwt_rect.h
|
||||
include/qwt/qwt_scale.h
|
||||
include/qwt/qwt_scldiv.h
|
||||
include/qwt/qwt_global.h
|
||||
include/qwt/qwt_curve.h
|
||||
include/qwt/qwt_autoscl.h
|
||||
include/qwt/qwt.h
|
||||
include/qwt/qwt_scldraw.h
|
||||
include/qwt/qwt_sclif.h
|
||||
include/qwt/qwt_sldbase.h
|
||||
include/qwt/qwt_dimap.h
|
||||
include/qwt/qwt_counter.h
|
||||
include/qwt/qwt_scldiv.h
|
||||
include/qwt/qwt_slider.h
|
||||
include/qwt/qwt_spline.h
|
||||
include/qwt/qwt_plot_item.h
|
||||
include/qwt/qwt_plot.h
|
||||
include/qwt/qwt_plot_dict.h
|
||||
include/qwt/qwt_symbol.h
|
||||
include/qwt/qwt_thermo.h
|
||||
include/qwt/qwt_plot_printfilter.h
|
||||
include/qwt/qwt_plot_canvas.h
|
||||
include/qwt/qwt_arrbtn.h
|
||||
include/qwt/qwt_wheel.h
|
||||
include/qwt/qwt_grid.h
|
||||
include/qwt/qwt_knob.h
|
||||
include/qwt/qwt_drange.h
|
||||
include/qwt/qwt_legend.h
|
||||
lib/libqwt.so
|
||||
lib/libqwt.so.0.4.0
|
||||
lib/libqwt.so.0.4.1
|
||||
@dirrm include/qwt
|
||||
|
|
|
@ -6,15 +6,15 @@
|
|||
#
|
||||
|
||||
PORTNAME= qwt
|
||||
PORTVERSION= 0.4.0
|
||||
PORTVERSION= 0.4.1
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR=qwt
|
||||
|
||||
MAINTAINER= bob@fly.homeunix.org
|
||||
|
||||
USE_QT_VER= 2
|
||||
MAINTAINER= bob@bomar.us
|
||||
|
||||
USE_QT_VER= 3
|
||||
USE_BZIP2= yes
|
||||
MAKE_ENV= CXXFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
|
||||
INCPATH="-I${X11BASE}/include/qt2" \
|
||||
LIBS="-L${X11BASE}/lib" \
|
||||
|
@ -24,21 +24,24 @@ MAKE_ENV= CXXFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
|
|||
MAN3= Qwt.3 \
|
||||
QwtArrowButton.3 \
|
||||
QwtAutoScale.3 \
|
||||
QwtColorFilter.3 \
|
||||
QwtCounter.3 \
|
||||
QwtCurve.3 \
|
||||
QwtDblRange.3 \
|
||||
QwtDiMap.3 \
|
||||
QwtFltrDim.3 \
|
||||
QwtFltrGray.3 \
|
||||
QwtFltrInv.3 \
|
||||
QwtGrid.3 \
|
||||
QwtKnob.3 \
|
||||
QwtLegend.3 \
|
||||
QwtLegendItem.3 \
|
||||
QwtMarker.3 \
|
||||
QwtPixFrame.3 \
|
||||
QwtPlot.3 \
|
||||
QwtPlotCanvas.3 \
|
||||
QwtPlotCurve.3 \
|
||||
QwtPlotGrid.3 \
|
||||
QwtPlotItem.3 \
|
||||
QwtPlotMappedItem.3 \
|
||||
QwtPlotMarker.3 \
|
||||
QwtPlotPrintFilter.3 \
|
||||
QwtRect.3 \
|
||||
QwtScale.3 \
|
||||
QwtScaleDiv.3 \
|
||||
QwtScaleDraw.3 \
|
||||
|
@ -49,18 +52,17 @@ MAN3= Qwt.3 \
|
|||
QwtSymbol.3 \
|
||||
QwtThermo.3 \
|
||||
QwtWheel.3 \
|
||||
bug.3 \
|
||||
changes.3 \
|
||||
install.3 \
|
||||
qwt_math.h.3 \
|
||||
screenshots.3
|
||||
|
||||
pre-build:
|
||||
${LN} -fs ${WRKSRC}/makefiles/freebsd-g++ ${WRKSRC}/Makefile
|
||||
cd ${WRKSRC}; qmake qwt.pro -o Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/libqwt.so.0.4.0 ${PREFIX}/lib
|
||||
${LN} -fs libqwt.so.0.4.0 ${PREFIX}/lib/libqwt.so
|
||||
${INSTALL_DATA} ${WRKSRC}/lib/libqwt.so.0.4.1 ${PREFIX}/lib
|
||||
${LN} -fs libqwt.so.0.4.1 ${PREFIX}/lib/libqwt.so
|
||||
${MKDIR} ${PREFIX}/include/qwt
|
||||
${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/qwt
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/man/man3/* ${PREFIX}/man/man3
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (qwt-0.4.0.tar.gz) = 3ca757793fa02ab691a7bfbbe531b1d8
|
||||
MD5 (qwt-0.4.1.tar.bz2) = 45c64b0382c8963cfde026a6d2324f6d
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
--- makefiles/freebsd-g++.orig Mon Oct 22 12:38:06 2001
|
||||
+++ makefiles/freebsd-g++ Tue Mar 12 17:40:28 2002
|
||||
@@ -7,17 +7,17 @@
|
||||
|
||||
####### Compiler, tools and options
|
||||
|
||||
-CC = gcc
|
||||
-CXX = g++
|
||||
-CFLAGS = -pipe -O2 -fPIC -DNO_DEBUG
|
||||
-CXXFLAGS= -pipe -O2 -fPIC -DNO_DEBUG
|
||||
-INCPATH = -I/usr/local/include -I$(QTDIR)/include
|
||||
+CC ?= gcc
|
||||
+CXX ?= g++
|
||||
+CFLAGS ?= -pipe -O2 -fPIC -DNO_DEBUG
|
||||
+CXXFLAGS?= -pipe -O2 -fPIC -DNO_DEBUG
|
||||
+INCPATH ?= -I/usr/local/include -I$(QTDIR)/include
|
||||
LINK = g++
|
||||
LFLAGS = -shared
|
||||
-LIBS = $(SUBLIBS) -L/usr/local/lib -L$(QTDIR)/lib -L/usr/X11R6/lib -lqt -lXext -lX11 -lm
|
||||
+LIBS = $(SUBLIBS) -L/usr/local/lib -L$(QTDIR)/lib -L/usr/X11R6/lib -lqt2 -lXext -lX11 -lm
|
||||
AR = ar cqs
|
||||
RANLIB =
|
||||
-MOC = $(QTDIR)/bin/moc
|
||||
+MOC ?= $(QTDIR)/bin/moc
|
||||
UIC = $(QTDIR)/bin/uic
|
||||
|
||||
TAR = tar -cf
|
|
@ -1,33 +1,33 @@
|
|||
include/qwt/qwt.h
|
||||
include/qwt/qwt_arrbtn.h
|
||||
include/qwt/qwt_autoscl.h
|
||||
include/qwt/qwt_clrfltr.h
|
||||
include/qwt/qwt_counter.h
|
||||
include/qwt/qwt_curve.h
|
||||
include/qwt/qwt_dimap.h
|
||||
include/qwt/qwt_drange.h
|
||||
include/qwt/qwt_grid.h
|
||||
include/qwt/qwt_knob.h
|
||||
include/qwt/qwt_legend.h
|
||||
include/qwt/qwt_sldbase.h
|
||||
include/qwt/qwt_plot_classes.h
|
||||
include/qwt/qwt_scale.h
|
||||
include/qwt/qwt_sclif.h
|
||||
include/qwt/qwt_rect.h
|
||||
include/qwt/qwt_thermo.h
|
||||
include/qwt/qwt_marker.h
|
||||
include/qwt/qwt_math.h
|
||||
include/qwt/qwt_pixframe.h
|
||||
include/qwt/qwt_plot.h
|
||||
include/qwt/qwt_plot_classes.h
|
||||
include/qwt/qwt_plot_dict.h
|
||||
include/qwt/qwt_plot_item.h
|
||||
include/qwt/qwt_plot_pixframe.h
|
||||
include/qwt/qwt_rect.h
|
||||
include/qwt/qwt_scale.h
|
||||
include/qwt/qwt_scldiv.h
|
||||
include/qwt/qwt_global.h
|
||||
include/qwt/qwt_curve.h
|
||||
include/qwt/qwt_autoscl.h
|
||||
include/qwt/qwt.h
|
||||
include/qwt/qwt_scldraw.h
|
||||
include/qwt/qwt_sclif.h
|
||||
include/qwt/qwt_sldbase.h
|
||||
include/qwt/qwt_dimap.h
|
||||
include/qwt/qwt_counter.h
|
||||
include/qwt/qwt_scldiv.h
|
||||
include/qwt/qwt_slider.h
|
||||
include/qwt/qwt_spline.h
|
||||
include/qwt/qwt_plot_item.h
|
||||
include/qwt/qwt_plot.h
|
||||
include/qwt/qwt_plot_dict.h
|
||||
include/qwt/qwt_symbol.h
|
||||
include/qwt/qwt_thermo.h
|
||||
include/qwt/qwt_plot_printfilter.h
|
||||
include/qwt/qwt_plot_canvas.h
|
||||
include/qwt/qwt_arrbtn.h
|
||||
include/qwt/qwt_wheel.h
|
||||
include/qwt/qwt_grid.h
|
||||
include/qwt/qwt_knob.h
|
||||
include/qwt/qwt_drange.h
|
||||
include/qwt/qwt_legend.h
|
||||
lib/libqwt.so
|
||||
lib/libqwt.so.0.4.0
|
||||
lib/libqwt.so.0.4.1
|
||||
@dirrm include/qwt
|
||||
|
|
Loading…
Reference in a new issue