- Update to 1.9.94.r87113

- Remove useless dependency to libumem [1]
- Adapt USES following recent changes

PR:		ports/181402 [1]
Submitted by:	David Demelier <demelier.david@gmail.com> [1]
This commit is contained in:
Ganael LAPLANCHE 2013-09-13 08:24:10 +00:00
parent e12106d98a
commit 95ad37e392
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=327135
7 changed files with 83 additions and 16 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pcsxr
PORTVERSION= 1.9.92.r84102
PORTVERSION= 1.9.94.r87113
CATEGORIES= emulators
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
@ -30,8 +30,8 @@ USE_LDCONFIG= yes
USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.(c|h|cpp|hpp|am)
USE_GNOME= gtk30 desktopfileutils glib20
USES= iconv gmake pkgconfig
USE_GNOME= gtk30 glib20
USES= iconv gmake pkgconfig desktop-file-utils
USE_XORG= x11 xv xext xxf86vm xtst
USE_SDL= sdl
USE_GL= gl
@ -75,6 +75,5 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
.endfor
.endif
@-update-desktop-database
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (pcsxr-1.9.92.r84102.tar.bz2) = 88c86c5221f16b2d9d3c88191b7e5e08f4f62c71e17c084188497abb0e6c3295
SIZE (pcsxr-1.9.92.r84102.tar.bz2) = 1451311
SHA256 (pcsxr-1.9.94.r87113.tar.bz2) = cb24b2c0711f62acb866e4483dba085e90fc0cb9e4025d165fd5a618882da938
SIZE (pcsxr-1.9.94.r87113.tar.bz2) = 1389412

View file

@ -1,5 +1,5 @@
--- configure.ac.orig 2011-01-25 06:54:07.000000000 +0100
+++ configure.ac 2011-01-26 14:35:39.236296066 +0100
--- configure.ac.orig 2013-09-10 11:55:59.000000000 +0200
+++ configure.ac 2013-09-13 09:42:28.018735076 +0200
@@ -8,6 +8,7 @@
AC_CONFIG_HEADERS([include/config.h:include/config.h.in])
@ -8,3 +8,12 @@
AM_PROG_CC_C_O
AC_PROG_INSTALL
AC_STDC_HEADERS
@@ -54,7 +55,7 @@
AC_CHECK_LIB(dl, dlsym, [LIBS="$LIBS -ldl"], [])
AC_CHECK_LIB(socket, socket, [LIBS="$LIBS -lsocket"], [])
AC_CHECK_LIB(nsl, gethostbyname, [LIBS="$LIBS -lnsl"], [])
-AC_CHECK_LIB(umem, umem_alloc, [LIBS="$LIBS -lumem"], [])
+dnl AC_CHECK_LIB(umem, umem_alloc, [LIBS="$LIBS -lumem"], [])
AM_CONDITIONAL(SOUND_OSS, false)
AM_CONDITIONAL(SOUND_SDL, false)

View file

@ -0,0 +1,10 @@
--- plugins/bladesio1/connection.c.orig 2013-09-12 09:19:20.862489051 +0200
+++ plugins/bladesio1/connection.c 2013-09-12 09:20:25.386489200 +0200
@@ -25,6 +25,7 @@
#if defined _WINDOWS
#include <winsock2.h>
#else
+#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <netinet/tcp.h>

View file

@ -0,0 +1,46 @@
--- plugins/bladesio1/gui.c.orig 2013-09-10 15:56:22.000000000 +0200
+++ plugins/bladesio1/gui.c 2013-09-10 15:59:32.000000000 +0200
@@ -26,8 +26,6 @@
#include <gtk/gtk.h>
#include <sys/socket.h>
-#include <sys/ioctl.h>
-#include <linux/if.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include <netdb.h>
@@ -40,6 +38,11 @@
/***************************************************************************/
+#ifdef __linux__
+
+#include <sys/ioctl.h>
+#include <linux/if.h>
+
#define MAXINTERFACES 16
void sockGetIP(char *IPAddress) {
@@ -67,6 +70,22 @@
}
}
+#else
+
+void sockGetIP(char *IPAddress) {
+ struct hostent *host;
+ char str[256];
+
+ gethostname(str, 256);
+ host = gethostbyname(str);
+
+ if (host != NULL)
+ strcpy(IPAddress, inet_ntoa(*((struct in_addr *)host->h_addr_list[0])));
+ else strcpy(IPAddress, "127.0.0.1");
+}
+
+#endif
+
void cfgSysMessage(const char *fmt, ...) {
GtkWidget *MsgDlg;
va_list list;

View file

@ -1,5 +1,5 @@
--- plugins/dfinput/Makefile.am.orig 2012-11-07 17:22:21.000000000 +0100
+++ plugins/dfinput/Makefile.am 2012-11-07 17:24:22.000000000 +0100
--- plugins/dfinput/Makefile.am.orig 2013-09-10 15:40:15.000000000 +0200
+++ plugins/dfinput/Makefile.am 2013-09-10 15:43:00.000000000 +0200
@@ -1,14 +1,14 @@
-bindir = @libdir@/games/psemu/
-libdir = @libdir@/games/psemu/
@ -10,18 +10,18 @@
libDFInput_la_SOURCES = cfg.c pad.c pad.h sdljoy.c xkb.c analog.c util.c util.h
-libDFInput_la_LDFLAGS = -module -avoid-version
-libDFInput_la_LIBADD = -lpthread -lX11 $(SDL_LIBS)
-libDFInput_la_LIBADD = -lpthread -lX11 $(SDL2_LIBS) $(SDL_LIBS)
+libDFInput_la_LDFLAGS = -module -avoid-version -pthread
+libDFInput_la_LIBADD = -lX11 $(SDL_LIBS)
+libDFInput_la_LIBADD = -lX11 $(SDL2_LIBS) $(SDL_LIBS)
AM_CPPFLAGS = -DLOCALE_DIR=\"${datadir}/locale/\" \
- -DDATADIR=\"${datadir}/psemu/\" \
+ -DDATADIR=\"${datadir}/pcsxr/\" \
$(GTK3_CFLAGS) \
-I../../include -I../../libpcsxcore $(SDL_CFLAGS)
-I../../include -I../../libpcsxcore $(SDL2_CFLAGS) $(SDL_CFLAGS)
@@ -17,5 +17,5 @@
cfgDFInput_LDADD = $(GTK3_LIBS) $(SDL_LIBS) -lX11
cfgDFInput_LDADD = $(GTK3_LIBS) $(SDL2_LIBS) $(SDL_LIBS) -lX11
glade_DATA = dfinput.ui
-gladedir = $(datadir)/psemu/

View file

@ -19,6 +19,7 @@ share/pcsxr/gpu.png
share/pcsxr/dfsound.ui
share/pcsxr/spu.png
share/pcsxr/sio1.png
share/pcsxr/sio1.ui
share/pcsxr/cd.png
share/pcsxr/iso-reopen.png
share/pcsxr/cdr.png
@ -32,12 +33,16 @@ share/pcsxr/pcsxr.png
share/pixmaps/pcsxr-icon.png
share/applications/pcsxr.desktop
@dirrmtry share/applications
lib/pcsxr/cfgBladeSio1
lib/pcsxr/cfgDFXVideo
lib/pcsxr/cfgpeopsxgl
lib/pcsxr/cfgDFInput
lib/pcsxr/cfgDFCdrom
lib/pcsxr/cfgDFSound
lib/pcsxr/cfgDFNet
lib/pcsxr/libBladeSio1.a
lib/pcsxr/libBladeSio1.la
lib/pcsxr/libBladeSio1.so
lib/pcsxr/libDFXVideo.a
lib/pcsxr/libDFXVideo.la
lib/pcsxr/libDFXVideo.so
@ -57,5 +62,3 @@ lib/pcsxr/libDFNet.a
lib/pcsxr/libDFNet.la
lib/pcsxr/libDFNet.so
@dirrm lib/pcsxr
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true