Update to 2.1.0.
PR: ports/167636 Submitted by: sunpoet (with modifications) Approved by: kuriyama (maintainer)
This commit is contained in:
parent
8237cf0232
commit
95ca67ef5a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323896
6 changed files with 12 additions and 44 deletions
|
@ -1,13 +1,8 @@
|
|||
# New ports collection makefile for: expat
|
||||
# Date created: Thu Aug 26 14:38:07 CEST 1999
|
||||
# Whom: Dirk Froemberg <dirk@FreeBSD.org>
|
||||
#
|
||||
# Created by: Dirk Froemberg <dirk@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= expat
|
||||
PORTVERSION= 2.0.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 2.1.0
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= SF
|
||||
|
||||
|
@ -16,14 +11,20 @@ COMMENT= XML 1.0 parser written in C
|
|||
|
||||
GNU_CONFIGURE= yes
|
||||
ALL_TARGET= default
|
||||
USES= pathfix
|
||||
USE_LDCONFIG= yes
|
||||
MAN1= xmlwf.1
|
||||
|
||||
# Increment only when there are incompatible API changes.
|
||||
SHLIB_MAJOR= 6
|
||||
|
||||
MAKE_ENV= LIBCURRENT="${SHLIB_MAJOR}"
|
||||
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's/@LIBCURRENT.*@/${SHLIB_MAJOR}/' \
|
||||
-e '/^DESTDIR =/d' ${WRKSRC}/Makefile.in
|
||||
|
||||
list-depend-ports:
|
||||
cd ${PORTSDIR}; \
|
||||
${FIND} . -mindepth 3 -maxdepth 3 -name Makefile -execdir ${SH} -c \
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (expat-2.0.1.tar.gz) = 847660b4df86e707c9150e33cd8c25bc5cd828f708c7418e765e3e983a2e5e93
|
||||
SIZE (expat-2.0.1.tar.gz) = 446456
|
||||
SHA256 (expat-2.1.0.tar.gz) = 823705472f816df21c8f6aa026dd162b280806838bb55b3432b0fb1fcca7eb86
|
||||
SIZE (expat-2.1.0.tar.gz) = 562616
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.in.orig Sun Jun 10 21:10:33 2007
|
||||
+++ Makefile.in Sun Jun 10 21:11:18 2007
|
||||
@@ -44,8 +44,6 @@
|
||||
APIHEADER = $(srcdir)/lib/expat.h $(srcdir)/lib/expat_external.h
|
||||
LIBRARY = libexpat.la
|
||||
|
||||
-DESTDIR = $(INSTALL_ROOT)
|
||||
-
|
||||
default: buildlib xmlwf/xmlwf
|
||||
|
||||
buildlib: $(LIBRARY)
|
|
@ -1,12 +0,0 @@
|
|||
--- lib/xmlparse.c.orig 2007-05-08 11:25:35.000000000 +0900
|
||||
+++ lib/xmlparse.c 2011-08-29 23:22:09.007745673 +0900
|
||||
@@ -3703,6 +3703,9 @@
|
||||
return XML_ERROR_UNCLOSED_TOKEN;
|
||||
case XML_TOK_PARTIAL_CHAR:
|
||||
return XML_ERROR_PARTIAL_CHAR;
|
||||
+ case -XML_TOK_PROLOG_S:
|
||||
+ tok = -tok;
|
||||
+ break;
|
||||
case XML_TOK_NONE:
|
||||
#ifdef XML_DTD
|
||||
/* for internal PE NOT referenced between declarations */
|
|
@ -1,11 +0,0 @@
|
|||
--- lib/xmltok_impl.c.orig 2009-12-08 10:16:58.047943029 +0900
|
||||
+++ lib/xmltok_impl.c 2009-12-08 10:17:13.228143919 +0900
|
||||
@@ -1744,7 +1744,7 @@
|
||||
const char *end,
|
||||
POSITION *pos)
|
||||
{
|
||||
- while (ptr != end) {
|
||||
+ while (ptr < end) {
|
||||
switch (BYTE_TYPE(enc, ptr)) {
|
||||
#define LEAD_CASE(n) \
|
||||
case BT_LEAD ## n: \
|
|
@ -5,3 +5,4 @@ lib/libexpat.a
|
|||
lib/libexpat.la
|
||||
lib/libexpat.so
|
||||
lib/libexpat.so.%%SHLIB_MAJOR%%
|
||||
libdata/pkgconfig/expat.pc
|
||||
|
|
Loading…
Reference in a new issue