Make lang/nawk building on -current again.
I didn't really take the patches from the PR, since 95% of them where tab to space conversions. Also tweaked the makefile to use ${CC} instead of cc. The distinfo change is because of the rollout of a new version, of which the Makefile was already changed but the distinfo not. PR: ports/44281 Submitted by: Steven G. Kargl <kargl@troutmask.apl.washington.edu>
This commit is contained in:
parent
6661d5ac11
commit
95e90fe8b8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=69097
3 changed files with 15 additions and 7 deletions
|
@ -1 +1 @@
|
|||
MD5 (awk.tar.gz) = 65f0afae31a1ed77dd21de5a15be570d
|
||||
MD5 (awk.tar.gz) = 1e2ef4bce7e538c8bf513ac21120bb26
|
||||
|
|
|
@ -1,18 +1,26 @@
|
|||
--- makefile.orig Tue Jan 1 06:50:28 2002
|
||||
+++ makefile Mon Feb 18 01:45:54 2002
|
||||
@@ -25,3 +25,3 @@
|
||||
--- makefile.orig Sat Jun 29 03:30:04 2002
|
||||
+++ makefile Tue Oct 29 22:22:31 2002
|
||||
@@ -22,15 +22,15 @@
|
||||
# THIS SOFTWARE.
|
||||
# ****************************************************************/
|
||||
|
||||
-CFLAGS = -g
|
||||
-CFLAGS = -O2
|
||||
-CFLAGS =
|
||||
+#CFLAGS = -g
|
||||
+#CFLAGS = -O2
|
||||
+CFLAGS ?= -O
|
||||
@@ -29,4 +29,4 @@
|
||||
|
||||
-CC = gcc -Wall -g -Wwrite-strings
|
||||
-CC = gcc -Wall -g
|
||||
-CC = /opt/SUNWspro/bin/cc
|
||||
-CC = /opt/pure/purify/purify cc
|
||||
-CC = cc
|
||||
+CC ?= cc
|
||||
+CC := ${CC} -Wall -g -Wwrite-strings
|
||||
+#CC = gcc -Wall -g
|
||||
+#CC = /opt/SUNWspro/bin/cc
|
||||
+#CC = /opt/pure/purify/purify cc
|
||||
+CC ?= cc
|
||||
|
||||
YACC = bison -y
|
||||
YACC = yacc
|
||||
|
|
|
@ -32,7 +32,7 @@
|
|||
+}
|
||||
+#endif
|
||||
+
|
||||
fa *makedfa(char *s, int anchor) /* returns dfa for reg expr s */
|
||||
fa *makedfa(const char *s, int anchor) /* returns dfa for reg expr s */
|
||||
{
|
||||
int i, use, nuse;
|
||||
@@ -287,6 +308,9 @@
|
||||
|
|
Loading…
Reference in a new issue