- Update to 3.1.0

- Fix MASTER_SITE/URL
- Update maintainer's address

PR:		ports/74202
Submitted by:	maintainer
This commit is contained in:
Volker Stolz 2004-12-13 09:56:41 +00:00
parent 67a36a218d
commit 96030435fa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=123904
5 changed files with 6 additions and 92 deletions

View file

@ -6,14 +6,13 @@
#
PORTNAME= tide
PORTVERSION= 2.1.0
PORTVERSION= 3.1.0
CATEGORIES= devel
MASTER_SITES= http://t3x.dyndns.org/files/ \
http://www.t3x.org/files/
MASTER_SITES= http://www.holm-und-jeschag.de/files/
DISTNAME= tide-${PORTVERSION:S/.//g}
MAINTAINER= nmh@t3x.org
COMMENT= T3X Integrated Development Environment and tools
MAINTAINER= nils@holm-und-jeschag.de
COMMENT= A collection of classes for the T3X language
BUILD_DEPENDS= tx:${PORTSDIR}/lang/t3x
RUN_DEPENDS= ${BUILD_DEPENDS}
@ -22,7 +21,4 @@ ONLY_FOR_ARCHS= i386
MAKE_ENV+= T3XDIR=${LOCALBASE}/t3x/r8
do-configure:
@(cd ${WRKSRC}; make unix)
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (tide-210.tar.gz) = fb5f017dbd2c21871e4550c2b78d00bf
MD5 (tide-310.tar.gz) = 05e149707b17026a6ec1e0f5d34b618d

View file

@ -1,34 +0,0 @@
--- ports/unix/install.sh.orig Sun Sep 28 03:46:54 2003
+++ ports/unix/install.sh Sun Sep 28 03:47:48 2003
@@ -15,7 +15,7 @@
echo "that supports shell functions."
echo
echo "On your system, you may try one out of these shells:"
- for p in /bin /usr/bin /usr/local/bin; do
+ for p in /bin /usr/bin ${LOCALBASE}/bin; do
for s in ksh bash; do
if [ -f $p/$s ]; then echo $p/$s; fi
done
@@ -98,7 +98,7 @@
strip tools/sdfmt
fi
-rm -f /usr/local/bin/tide /usr/local/bin/sdfmt
+rm -f ${PREFIX}/bin/tide ${PREFIX}/bin/sdfmt
(cd classes;
txcm -i config
@@ -146,9 +146,9 @@
install -o bin -g bin -C -m 0644 docs/Changes.sd $T3XDIR/doc/tool-changes.sd
if [ $SYMLINK = yes ]; then
- ln -fs $T3XDIR/tide/tide /usr/local/bin/tide
- ln -fs $T3XDIR/bin/sdfmt /usr/local/bin/sdfmt
+ ln -fs $T3XDIR/tide/tide ${PREFIX}/bin/tide
+ ln -fs $T3XDIR/bin/sdfmt ${PREFIX}/bin/sdfmt
else
- binlink $T3XDIR/tide/tide /usr/local/bin/tide
- binlink $T3XDIR/bin/sdfmt /usr/local/bin/sdfmt
+ binlink $T3XDIR/tide/tide ${PREFIX}/bin/tide
+ binlink $T3XDIR/bin/sdfmt ${PREFIX}/bin/sdfmt
fi

View file

@ -1,19 +1 @@
TIDE is a collection of tools and add-on classes for the T3X
compiler. It includes
- TIDE, the T3X Integrated Development Environment
- SDFMT, a structured document (re-)formatter
as well as tool classes for the following tasks:
- configuration file management
- visual ASCII editing
- non-visual ASCII editing
- directory navigation and file selection
- on-screen forms
- menues
- one-line prompts
- structured I/O
- file services (copying/moving files, etc)
WWW: http://www.t3x.org/T3X/
A collection of classes for the T3X language.

View file

@ -1,6 +1,3 @@
bin/sdfmt
bin/tide
t3x/r8/bin/sdfmt
t3x/r8/classes/2/config.cls
t3x/r8/classes/2/editor.cls
t3x/r8/classes/2/filebox.cls
@ -9,7 +6,6 @@ t3x/r8/classes/2/form.cls
t3x/r8/classes/2/menu.cls
t3x/r8/classes/2/prompt.cls
t3x/r8/classes/2/pstruct.cls
t3x/r8/classes/2/tblio.cls
t3x/r8/classes/2/vedit.cls
t3x/r8/classes/config.cls
t3x/r8/classes/config.dir
@ -27,34 +23,10 @@ t3x/r8/classes/prompt.cls
t3x/r8/classes/prompt.dir
t3x/r8/classes/pstruct.cls
t3x/r8/classes/pstruct.dir
t3x/r8/classes/tblio.cls
t3x/r8/classes/tblio.dir
t3x/r8/classes/vedit.cls
t3x/r8/classes/vedit.dir
t3x/r8/doc/tide.sd
t3x/r8/doc/tool-changes.sd
t3x/r8/doc/tool-classes.sd
t3x/r8/doc/tool-commands.sd
t3x/r8/examples/apfel.t
t3x/r8/examples/bottles.t
t3x/r8/examples/fac.t
t3x/r8/examples/hello.t
t3x/r8/examples/hello2.t
t3x/r8/examples/hello3.t
t3x/r8/examples/hello4.t
t3x/r8/examples/permute.t
t3x/r8/examples/primes.t
t3x/r8/examples/ttt.t
t3x/r8/examples/ttt_oo.t
t3x/r8/examples/ttt_plain.t
t3x/r8/tide.rc
t3x/r8/tide/default.cs
t3x/r8/tide/helpfile
t3x/r8/tide/monochrm.cs
t3x/r8/tide/tide
@exec echo 'config:t3x,iostream,string,ttyctl' >>%D/t3x/r8/classes/CLASSNDX
@exec echo 'editor:t3x,string' >>%D/t3x/r8/classes/CLASSNDX
@exec echo 'tblio:t3x,string,iostream' >>%D/t3x/r8/classes/CLASSNDX
@exec echo 'filebox:t3x,string,system,ttyctl' >>%D/t3x/r8/classes/CLASSNDX
@exec echo 'filesrv:t3x,string' >>%D/t3x/r8/classes/CLASSNDX
@exec echo 'form:t3x,ttyctl,menu,prompt' >>%D/t3x/r8/classes/CLASSNDX
@ -64,5 +36,3 @@ t3x/r8/tide/tide
@exec echo 'vedit:t3x,string,ttyctl,editor' >>%D/t3x/r8/classes/CLASSNDX
@unexec sed -e '/^config:/,/^vedit:/d' <%D/t3x/r8/classes/CLASSNDX >%D/t3x/ndx.tmp && mv %D/t3x/ndx.tmp %D/t3x/r8/classes/CLASSNDX
@unexec sed -e '/^config:/,/^vedit:/d' <%D/t3x/r8/classes/2/CLASSNDX >%D/t3x/ndx.tmp && mv %D/t3x/ndx.tmp %D/t3x/r8/classes/2/CLASSNDX
@dirrm t3x/r8/examples
@dirrm t3x/r8/tide