Update to 1.30

This commit is contained in:
Lars Thegler 2007-12-30 16:06:52 +00:00
parent 58aa25768a
commit 962cc78704
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=204713
3 changed files with 23 additions and 15 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= POE-Component-Server-SimpleHTTP
PORTVERSION= 1.23
PORTVERSION= 1.30
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-

View file

@ -1,3 +1,3 @@
MD5 (POE-Component-Server-SimpleHTTP-1.23.tar.gz) = c3925f05644c550c5cea0e3f1c2aaa45
SHA256 (POE-Component-Server-SimpleHTTP-1.23.tar.gz) = 3f1c6acade80e19cad3501ca5bc61ae4ae4285fc5e42c8275c5730187ba3e7ba
SIZE (POE-Component-Server-SimpleHTTP-1.23.tar.gz) = 38961
MD5 (POE-Component-Server-SimpleHTTP-1.30.tar.gz) = e45f32723485de6af929c7fd3bc55743
SHA256 (POE-Component-Server-SimpleHTTP-1.30.tar.gz) = 147f0734e12dca1ed4756c5e189971e628775cbe5ed1981c249a82c15541f23b
SIZE (POE-Component-Server-SimpleHTTP-1.30.tar.gz) = 47285

View file

@ -1,25 +1,33 @@
--- ./Makefile.PL.orig Thu Mar 22 20:26:42 2007
+++ ./Makefile.PL Thu Mar 22 20:27:01 2007
@@ -17,22 +17,4 @@
--- ./Makefile.PL.orig Wed Dec 26 15:47:34 2007
+++ ./Makefile.PL Wed Dec 26 15:49:41 2007
@@ -17,30 +17,4 @@
requires 'HTTP::Request' => 0;
requires 'HTTP::Response' => 0;
-build_requires 'Test::More' => 0;
-build_requires 'POE::Component::Client::HTTP' => 0;
-build_requires 'Test::More' => 0.47;
-build_requires 'LWP::UserAgent' => 0;
-build_requires 'LWP::ConnCache' => 0;
-
-my $value = prompt( 'Do you want to test streaming ( requires POE::Component::Client::HTTP ) [y/N]?', 'N' );
-build_requires 'POE::Component::Client::HTTP' => 0 if $value =~ /^Y$/i;
-
-# Ask users if they want SSL support
-my $value = prompt( 'Do you want SSL support ( requires POE::Component::SSLify ) [Y/n]?', 'N' );
-$value = prompt( 'Do you want SSL support ( requires POE::Component::SSLify ) [y/N]?', 'N' );
-
-# Add to the prereqs PoCo::SSLify?
-if ( $value =~ /^Y$/i ) {
- requires 'POE::Component::SSLify' => '0.04';
-}
-requires 'POE::Component::SSLify' => '0.04' if $value =~ /^Y$/i;
-
-# Ask users if they want PreFork support
-$value = prompt( 'Do you want PreFork support ( requires IPC::Shareable ) [Y/n]?', 'N' );
-$value = prompt( 'Do you want PreFork support ( requires IPC::Shareable ) [y/N]?', 'N' );
-
-# Add to the prereqs IPC::Shareable?
-if ( $value =~ /^Y$/i ) {
- requires 'IPC::Shareable' => '0';
- requires 'IPC::Shareable' => '0';
- build_requires 'POE::Component::Client::HTTP' => 0;
-}
-
-# Sanity check
-eval { require IPC::Shareable; };
-build_requires 'POE::Component::Client::HTTP' => 0 unless $@;
-
WriteAll();