print/pdfmixtool: Fix build after ImageMagick7 7.1.1 update.

iAfter the update to ImageMagick7 7.1.1, build would fail and complain about
MAGICKCORE_HDRI_ENABLE not being defined. While pkgconf clearly propagates these
additional CFLAGS, the CMakeLists.txt of pdfmixtool does not use them.

PR:		276362
Reported by:	dev@submerge.ch (maintainer)
This commit is contained in:
Florian Walpen 2024-01-17 09:30:10 +01:00 committed by Fernando Apesteguía
parent cab98f16d3
commit 963ccdb8eb
2 changed files with 16 additions and 1 deletions

View File

@ -1,6 +1,6 @@
PORTNAME= pdfmixtool
DISTVERSION= 1.1.1
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= print graphics editors
PKGNAMESUFFIX= -${FLAVOR}

View File

@ -0,0 +1,15 @@
--- CMakeLists.txt.orig 2024-01-16 00:28:44 UTC
+++ CMakeLists.txt
@@ -142,6 +142,12 @@ target_link_libraries (
${QT_LIBRARIES}
)
+target_compile_options(
+ pdfmixtool
+ PUBLIC
+ ${MAGICK_CFLAGS_OTHER}
+)
+
INSTALL(TARGETS pdfmixtool RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
INSTALL(FILES resources/eu.scarpetta.PDFMixTool.desktop DESTINATION ${CMAKE_INSTALL_DATADIR}/applications)
INSTALL(FILES resources/eu.scarpetta.PDFMixTool.appdata.xml DESTINATION ${CMAKE_INSTALL_DATADIR}/metainfo)