net/mosquitto: Fails to build with WS option enabled
PR: 220827 Submitted by: stl@koffein.net Approved by: joe@thrallingpenguin.com (maintainer)
This commit is contained in:
parent
22283b152a
commit
964f439c25
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=448259
2 changed files with 44 additions and 3 deletions
33
net/mosquitto/files/patch-lib_mosquitto__internal.h
Normal file
33
net/mosquitto/files/patch-lib_mosquitto__internal.h
Normal file
|
@ -0,0 +1,33 @@
|
|||
--- lib/mosquitto_internal.h.orig 2017-07-18 16:25:21 UTC
|
||||
+++ lib/mosquitto_internal.h
|
||||
@@ -30,11 +30,7 @@ Contributors:
|
||||
#endif
|
||||
#include <stdlib.h>
|
||||
|
||||
-#if defined(WITH_THREADING) && !defined(WITH_BROKER)
|
||||
-# include <pthread.h>
|
||||
-#else
|
||||
-# include <dummypthread.h>
|
||||
-#endif
|
||||
+#include <pthread.h>
|
||||
|
||||
#ifdef WITH_SRV
|
||||
# include <ares.h>
|
||||
@@ -184,7 +180,7 @@ struct mosquitto {
|
||||
#endif
|
||||
bool want_write;
|
||||
bool want_connect;
|
||||
-#if defined(WITH_THREADING) && !defined(WITH_BROKER)
|
||||
+
|
||||
pthread_mutex_t callback_mutex;
|
||||
pthread_mutex_t log_callback_mutex;
|
||||
pthread_mutex_t msgtime_mutex;
|
||||
@@ -195,7 +191,7 @@ struct mosquitto {
|
||||
pthread_mutex_t out_message_mutex;
|
||||
pthread_mutex_t mid_mutex;
|
||||
pthread_t thread_id;
|
||||
-#endif
|
||||
+
|
||||
bool clean_session;
|
||||
#ifdef WITH_BROKER
|
||||
bool is_dropping;
|
|
@ -1,6 +1,14 @@
|
|||
--- src/CMakeLists.txt.orig 2015-05-07 13:21:22 UTC
|
||||
--- src/CMakeLists.txt.orig 2016-08-17 11:05:14 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -86,7 +86,7 @@ if (UNIX)
|
||||
@@ -77,6 +77,7 @@ if (WIN32 OR CYGWIN)
|
||||
endif (WIN32 OR CYGWIN)
|
||||
|
||||
add_definitions (-DWITH_BROKER)
|
||||
+add_definitions (-DWITH_THREADING)
|
||||
|
||||
add_executable(mosquitto ${MOSQ_SRCS})
|
||||
|
||||
@@ -86,7 +87,7 @@ if (UNIX)
|
||||
if (APPLE)
|
||||
set (MOSQ_LIBS ${MOSQ_LIBS} dl m)
|
||||
else (APPLE)
|
||||
|
@ -9,7 +17,7 @@
|
|||
endif (APPLE)
|
||||
endif (UNIX)
|
||||
|
||||
@@ -127,6 +127,5 @@ if (${WITH_TLS} STREQUAL ON)
|
||||
@@ -127,6 +128,5 @@ if (${WITH_TLS} STREQUAL ON)
|
||||
endif (${WITH_TLS} STREQUAL ON)
|
||||
|
||||
if (UNIX)
|
||||
|
|
Loading…
Reference in a new issue