Remove xchat1, upstream support has been abandonned for a while and it is producing packages with a name
That can make user confuse with irc/xchat.
This commit is contained in:
parent
3e1eb5c8c3
commit
9654378046
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=327403
10 changed files with 2 additions and 182 deletions
2
MOVED
2
MOVED
|
@ -4939,3 +4939,5 @@ devel/deputy||2013-09-13|Obsolete
|
|||
textproc/liblinebreak|textproc/libunibreak|2013-09-14|Project was superceded by libunibreak
|
||||
sysutils/daemontools53|sysutils/daemontool|2013-09-16|sysutils/daemontools is more recent
|
||||
audio/ices0|audio/ices|2013-09-16|Unsupported version, consider using audio/ices
|
||||
irc/xchat1|irc/xchat|2013-09-16|Unsupported upstream, consider using irc/xchat
|
||||
japanese/xchat|irc/xchat|2013-09-16|Unsupported upstream, consider using irc/xchat
|
||||
|
|
|
@ -139,7 +139,6 @@
|
|||
SUBDIR += xchat-gnome
|
||||
SUBDIR += xchat-mircryption
|
||||
SUBDIR += xchat-ruby
|
||||
SUBDIR += xchat1
|
||||
SUBDIR += znc
|
||||
|
||||
.include <bsd.port.subdir.mk>
|
||||
|
|
|
@ -1,76 +0,0 @@
|
|||
# Created by: Jim Mock <jim@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xchat
|
||||
PORTVERSION= 1.8.11
|
||||
PORTREVISION= 12
|
||||
CATEGORIES+= irc gnome ipv6
|
||||
MASTER_SITES= http://xchat.org/files/source/1.8/ \
|
||||
http://xchat.linuxpower.org/files/source/1.8/
|
||||
|
||||
MAINTAINER?= ports@FreeBSD.org
|
||||
COMMENT= X11 IRC client using the GTK+ toolkit, and optionally, GNOME
|
||||
|
||||
# This port has a slave port japanese/xchat. Do not carelessly overwrite
|
||||
# the variables or the targets defined in it. When you need to, please
|
||||
# contact its maintainer.
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USES= iconv perl5
|
||||
USE_GNOME= gtk12
|
||||
WANT_GNOME= yes
|
||||
GNU_CONFIGURE= yes
|
||||
# Assign with `+=' for slave ports
|
||||
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl ${ICONV_LIB}"
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
CONFIGURE_ARGS+= --without-included-gettext \
|
||||
--enable-nls \
|
||||
--enable-ipv6 \
|
||||
--datadir="${PREFIX}/share" \
|
||||
--enable-perl
|
||||
LATEST_LINK?= xchat1
|
||||
|
||||
.if defined(WITH_SSL)
|
||||
USE_OPENSSL= YES
|
||||
CONFIGURE_ARGS+= --enable-openssl
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PYTHON)
|
||||
USE_PYTHON= yes
|
||||
CONFIGURE_ARGS+= --enable-python
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-python
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_TRANSPARENCY)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/bin/gdk-pixbuf-config:${PORTSDIR}/graphics/gdk-pixbuf
|
||||
CONFIGURE_ARGS+= --enable-gdk-pixbuf
|
||||
.endif
|
||||
|
||||
.if ${HAVE_GNOME:Mimlib}!=""
|
||||
USE_GNOME= imlib
|
||||
CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf \
|
||||
--enable-zvt
|
||||
MAKE_ARGS= icondir="${PREFIX}/share/pixmaps" \
|
||||
utildir="${PREFIX}/share/gnome/apps/Internet"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-gnome --disable-zvt
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -i '' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO_MSG} "===> Installing xchat docs in ${PREFIX}/share/doc/xchat"
|
||||
@${MKDIR} ${PREFIX}/share/doc/xchat && ${CHMOD} a+rx ${PREFIX}/share/doc/xchat
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/*.* ${PREFIX}/share/doc/xchat
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xchat
|
||||
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/xchat
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (xchat-1.8.11.tar.bz2) = b3d457e014649e4b25ba5241e6dde600ffe2c8c6c4d462b8d4392b9f38b5abed
|
||||
SIZE (xchat-1.8.11.tar.bz2) = 850453
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.orig Wed Jan 15 23:38:08 2003
|
||||
+++ configure Wed Jan 15 23:38:08 2003
|
||||
@@ -6017,4 +6017,4 @@
|
||||
#include "confdefs.h"
|
||||
#include <libintl.h>
|
||||
extern int _nl_msg_cat_cntr;
|
||||
-extern int *_nl_domain_bindings;
|
||||
+extern int *libintl_nl_domain_bindings;
|
||||
@@ -6031,2 +6031,2 @@
|
||||
-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings
|
||||
+return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings
|
|
@ -1,11 +0,0 @@
|
|||
--- src/common/cfgfiles.c.orig Mon Mar 29 15:46:01 2004
|
||||
+++ src/common/cfgfiles.c Mon Mar 29 15:46:20 2004
|
||||
@@ -600,7 +600,7 @@
|
||||
|
||||
prefs.autoresume = 1;
|
||||
prefs.show_away_once = 1;
|
||||
- prefs.show_away_message = 1;
|
||||
+ prefs.show_away_message = 0;
|
||||
prefs.indent_pixels = 80;
|
||||
prefs.dialog_indent_pixels = 80;
|
||||
prefs.indent_nicks = 1;
|
|
@ -1,6 +0,0 @@
|
|||
XChat is a graphical IRC client. It requires a computer running a
|
||||
UNIX-like OS and the X Window System (X11), and the GTK library. It can
|
||||
also (optionally) take advantage of GNOME and use Perl and Python
|
||||
scripts.
|
||||
|
||||
WWW: http://xchat.org/
|
|
@ -1,55 +0,0 @@
|
|||
bin/xchat
|
||||
bin/xchat-text
|
||||
%%NOGNOME:%%etc/X11/applnk/Internet/xchat.desktop
|
||||
%%PORTDOCS%%share/doc/xchat/ChangeLog
|
||||
%%PORTDOCS%%share/doc/xchat/README
|
||||
%%PORTDOCS%%share/doc/xchat/xchat-1.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat-10.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat-2.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat-3.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat-4.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat-5.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat-6.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat-7.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat-8.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat-9.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat.html
|
||||
%%PORTDOCS%%share/doc/xchat/xchat.sgml
|
||||
%%GNOME:%%share/gnome/apps/Internet/xchat.desktop
|
||||
%%GNOME:%%share/pixmaps/xchat.png
|
||||
%%PORTDOCS%%@dirrm share/doc/xchat
|
||||
share/locale/ca/LC_MESSAGES/xchat.mo
|
||||
share/locale/cs/LC_MESSAGES/xchat.mo
|
||||
share/locale/da/LC_MESSAGES/xchat.mo
|
||||
share/locale/de/LC_MESSAGES/xchat.mo
|
||||
share/locale/el/LC_MESSAGES/xchat.mo
|
||||
share/locale/es/LC_MESSAGES/xchat.mo
|
||||
share/locale/fi/LC_MESSAGES/xchat.mo
|
||||
share/locale/fr/LC_MESSAGES/xchat.mo
|
||||
share/locale/he/LC_MESSAGES/xchat.mo
|
||||
share/locale/hu/LC_MESSAGES/xchat.mo
|
||||
share/locale/it/LC_MESSAGES/xchat.mo
|
||||
share/locale/ja/LC_MESSAGES/xchat.mo
|
||||
share/locale/ko/LC_MESSAGES/xchat.mo
|
||||
share/locale/lt/LC_MESSAGES/xchat.mo
|
||||
share/locale/lv/LC_MESSAGES/xchat.mo
|
||||
share/locale/nl/LC_MESSAGES/xchat.mo
|
||||
share/locale/no/LC_MESSAGES/xchat.mo
|
||||
share/locale/pl/LC_MESSAGES/xchat.mo
|
||||
share/locale/pt/LC_MESSAGES/xchat.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/xchat.mo
|
||||
share/locale/ro/LC_MESSAGES/xchat.mo
|
||||
share/locale/ru/LC_MESSAGES/xchat.mo
|
||||
share/locale/sk/LC_MESSAGES/xchat.mo
|
||||
share/locale/sl/LC_MESSAGES/xchat.mo
|
||||
share/locale/sr/LC_MESSAGES/xchat.mo
|
||||
share/locale/sv/LC_MESSAGES/xchat.mo
|
||||
share/locale/tr/LC_MESSAGES/xchat.mo
|
||||
share/locale/uk/LC_MESSAGES/xchat.mo
|
||||
share/locale/vi/LC_MESSAGES/xchat.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/xchat.mo
|
||||
share/locale/zh_TW.Big5/LC_MESSAGES/xchat.mo
|
||||
%%NOGNOME:%%share/pixmaps/xchat.png
|
||||
%%NOGNOME:%%@dirrmtry etc/X11/applnk/Internet
|
||||
%%NOGNOME:%%@dirrmtry etc/X11/applnk
|
||||
%%NOGNOME:%%@dirrmtry etc/X11
|
|
@ -338,7 +338,6 @@
|
|||
SUBDIR += wordnet-fpw
|
||||
SUBDIR += wordpress
|
||||
SUBDIR += wwasw-fpw
|
||||
SUBDIR += xchat
|
||||
SUBDIR += xdtp
|
||||
SUBDIR += xdvik
|
||||
SUBDIR += xemacs21-canna
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
# New ports collection makefile for: xchat-ja
|
||||
# Date created: 30 Sep 2000
|
||||
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= japanese
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= X11 IRC client using the GTK+ toolkit, and optionally, GNOME
|
||||
|
||||
CONFIGURE_ARGS= --enable-japanese-conv
|
||||
LATEST_LINK= ja-xchat1
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../irc/xchat1
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
Loading…
Reference in a new issue