Add pciutils, a group of Linux utilities ported to FreeBSD that allow one

to list and manipulate PCI bus parameters.

Submitted by:	Samy Al Bahra <samy@kerneled.com>
This commit is contained in:
Joe Marcus Clarke 2003-06-13 18:48:01 +00:00
parent 760697b0d2
commit 9697cee695
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82947
8 changed files with 109 additions and 0 deletions

View file

@ -191,6 +191,7 @@
SUBDIR += p5-Unix-Syslog
SUBDIR += p5-User
SUBDIR += paicc
SUBDIR += pciutils
SUBDIR += pdumpfs
SUBDIR += pear-File
SUBDIR += pear-Log

View file

@ -0,0 +1,44 @@
# New ports collection makefile for: pciutils
# Date created: June 12, 2003
# Whom: Samy Al Bahra <samy@kerneled.com>
#
# $FreeBSD$
#
PORTNAME= pciutils
PORTVERSION= 2.1.11
CATEGORIES= sysutils
MASTER_SITES= http://www.kerneled.com/freebsd/ports/ \
ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/ \
ftp://ftp.kernel.org/pub/software/utils/pciutils/
MAINTAINER= samy@kerneled.com
COMMENT= PCI configuration utilities
USE_BZIP2= yes
USE_GMAKE= yes
MAN8= lspci.8 setpci.8 update-pciids.8
pre-everything::
@${ECHO} ""
@${ECHO} " W A R N I N G"
@${ECHO} "************************************************"
@${ECHO} "* pciutils requires that you have your kernel *"
@${ECHO} "* sources installed. If your kernel sources *"
@${ECHO} "* are somewhere other than /usr/src/sys, you *"
@${ECHO} "* may set the FREEBSD_SYS variable to the *"
@${ECHO} "* correct path. *"
@${ECHO} "************************************************"
@${ECHO} ""
do-install:
@${INSTALL_MAN} ${WRKSRC}/lspci.8 ${PREFIX}/man/man8
@${INSTALL_MAN} ${WRKSRC}/setpci.8 ${PREFIX}/man/man8
@${INSTALL_MAN} ${WRKSRC}/update-pciids.8 ${PREFIX}/man/man8
@${INSTALL_PROGRAM} ${WRKSRC}/lspci ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/setpci ${PREFIX}/bin
@${INSTALL_SCRIPT} ${WRKSRC}/update-pciids ${PREFIX}/sbin
@${INSTALL_DATA} ${WRKSRC}/pci.ids ${PREFIX}/share
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (pciutils-2.1.11.tar.bz2) = 2b3b2147b7bc91f362be55cb49fa1c4e

View file

@ -0,0 +1,13 @@
--- Makefile.orig Sat Jan 4 15:53:01 2003
+++ Makefile Fri Jun 13 21:20:28 2003
@@ -2,9 +2,7 @@
# Makefile for Linux PCI Utilities
# (c) 1998--2003 Martin Mares <mj@ucw.cz>
-OPT=-O2 -fomit-frame-pointer
-#OPT=-O2 -g
-CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes
+CFLAGS += -Wall -W -Wno-parentheses -Wstrict-prototypes
VERSION=2.1.11
#SUFFIX=-pre2

View file

@ -0,0 +1,12 @@
--- lib/Makefile.orig Thu Dec 26 22:28:33 2002
+++ lib/Makefile Thu Jun 12 02:46:13 2003
@@ -28,6 +28,9 @@
ifdef HAVE_PM_FBSD_DEVICE
OBJS += fbsd-device.o
CFLAGS += -I/usr/src/sys
+ifdef FREEBSD_SYS
+CFLAGS += -I${FREEBSD_SYS}
+endif
endif
ifdef HAVE_PM_AIX_DEVICE

View file

@ -0,0 +1,24 @@
--- lib/fbsd-device.c.orig Fri Jun 13 11:11:29 2003
+++ lib/fbsd-device.c Fri Jun 13 11:21:52 2003
@@ -14,9 +14,19 @@
#include <fcntl.h>
#include <string.h>
#include <unistd.h>
+#include <osreldate.h>
-#include <pci/pcivar.h>
-#include <pci/pci_ioctl.h>
+#if __FreeBSD_version < 500000
+# include <pci/pcivar.h>
+#else
+# include <dev/pci/pcivar.h>
+#endif
+
+#if __FreeBSD_version < 430000
+# include <pci/pci_ioctl.h>
+#else
+# include <sys/pciio.h>
+#endif
#include "internal.h"

View file

@ -0,0 +1,10 @@
The PCI Utilities package contains various utilities dealing
with the PCI bus, and also a library for portable access to
PCI configuration registers. It includes `lspci' for listing
all PCI devices (very useful for debugging of both kernel and
device drivers) and `setpci' for manual configuration of PCI
devices.
WWW: http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html
- Samy Al Bahra <samy@kerneled.com>

View file

@ -0,0 +1,4 @@
bin/lspci
bin/setpci
sbin/update-pciids
share/pci.ids