- Add patch to prevent a crashed when allocate dynamic memory. [1]

- Change BROKEN message to better show the problem.
- Bump PORTREVISION.

Submitted by:	Jens Rehsack <rehsack@web.de> [1]
Approved by:	stas (mentor, implicit)
Obtained from:	http://bugzilla.gnome.org/show_bug.cgi?id=468685
This commit is contained in:
Marcelo Araujo 2008-01-06 15:20:58 +00:00
parent 348ae1db44
commit 9698a97592
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=205105
2 changed files with 18 additions and 3 deletions

View file

@ -7,7 +7,7 @@
PORTNAME= gnome-commander
PORTVERSION= 1.2.4
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-commander/1.2
@ -37,8 +37,8 @@ MAN1= gnome-commander.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
BROKEN= Does not compile
.if ${OSVERSION} >= 700000 && ${ARCH} == "amd64"
BROKEN= Does not run on amd64 and 7.X or greater
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,15 @@
--- ./src/gnome-cmd-python-plugin.cc.orig 2007-09-10 07:38:08.000000000
+0000
+++ ./src/gnome-cmd-python-plugin.cc 2007-09-11 00:29:03.000000000 +0000
@@ -54,6 +54,11 @@
}
long dir_size = pathconf(".", _PC_PATH_MAX);
+ if( -1 == dir_size )
+ {
+ g_warning ( "pathconf(.): %s", strerror(errno) );
+ return;
+ }
gchar *prev_dir = (gchar *) g_malloc (dir_size);
if (!prev_dir)