games/eif: Document and fix ncurses requirement, use errno.h
The ncurses work is covered by the ncurses infrastructure blanket and the use of errno.h header over extern errno is "just fix it".
This commit is contained in:
parent
b2870ae5c7
commit
96aa446b35
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=420701
2 changed files with 21 additions and 2 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= eif
|
||||
PORTVERSION= 1.3.4
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= games ipv6
|
||||
MASTER_SITES= http://www.stack.nl/~marcolz/empire/ \
|
||||
ftp://ftp.stack.nl/pub/users/johans/eif/
|
||||
|
@ -12,7 +12,7 @@ MAINTAINER= johans@FreeBSD.org
|
|||
COMMENT= Empire text client
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= shebangfix readline
|
||||
USES= ncurses readline shebangfix
|
||||
SHEBANG_FILES= contrib/*.pl
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
@ -21,5 +21,6 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e '/curout_isapipe/d' ${WRKSRC}/src/data.h
|
||||
@${REINPLACE_CMD} -e '/cd .(pkglibdir)/s/cd /&$$(DESTDIR)/' \
|
||||
${WRKSRC}/contrib/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's@lcurses@lncurses@g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
18
games/eif/files/patch-src_games.c
Normal file
18
games/eif/files/patch-src_games.c
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- src/games.c.orig 2003-09-25 15:54:27 UTC
|
||||
+++ src/games.c
|
||||
@@ -25,14 +25,13 @@
|
||||
#ifdef HAVE_UNISTD_H
|
||||
#include <unistd.h>
|
||||
#endif /* HAVE_UNISTD_H */
|
||||
+#include <errno.h>
|
||||
|
||||
#include "cntl.h"
|
||||
#include "data.h"
|
||||
#include "games.h"
|
||||
#include "print.h"
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
#define MAX_GAMES 50
|
||||
|
||||
typedef struct {
|
Loading…
Reference in a new issue