Adding soundtracker version 0.3.6.
Mod player/tracking tool which supports XM and MOD formats. PR: 15180 Submitted by: Kristopher Zentner <kzentner@u.washington.edu>
This commit is contained in:
parent
600ae94e73
commit
96fbb327bf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24052
11 changed files with 85 additions and 0 deletions
|
@ -66,6 +66,7 @@
|
|||
SUBDIR += shorten
|
||||
SUBDIR += sidplay
|
||||
SUBDIR += snowstar
|
||||
SUBDIR += soundtracker
|
||||
SUBDIR += sox
|
||||
SUBDIR += splay
|
||||
SUBDIR += splaytk
|
||||
|
|
29
audio/soundtracker/Makefile
Normal file
29
audio/soundtracker/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# New ports collection makefile for: soundtracker
|
||||
# Version required: 0.3.6
|
||||
# Date created: 28 November 1999
|
||||
# Whom: kzentner
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= soundtracker-0.3.6
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ftp://ftp.soundtracker.org/pub/soundtracker/v0.3/
|
||||
|
||||
MAINTAINER= kzentner@u.washington.edu
|
||||
|
||||
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
|
||||
|
||||
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
|
||||
|
||||
.if defined(USE_GNOME)
|
||||
CONFIGURE_ARGS+= --enable-gnome
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@strip ${PREFIX}/bin/soundtracker
|
||||
|
||||
.include <bsd.port.mk>
|
1
audio/soundtracker/distinfo
Normal file
1
audio/soundtracker/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (soundtracker-0.3.6.tar.gz) = 66ae56a5c6163105e72f58152a88417d
|
10
audio/soundtracker/files/patch-aa
Normal file
10
audio/soundtracker/files/patch-aa
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- app/drivers/oss-input.c.orig Sun Nov 28 20:02:10 1999
|
||||
+++ app/drivers/oss-input.c Sun Nov 28 20:03:03 1999
|
||||
@@ -33,6 +33,6 @@
|
||||
#include <sys/types.h>
|
||||
#include <unistd.h>
|
||||
-#include <sys/soundcard.h>
|
||||
+#include <machine/soundcard.h>
|
||||
#include <sys/time.h>
|
||||
|
||||
#include <glib.h>
|
10
audio/soundtracker/files/patch-ab
Normal file
10
audio/soundtracker/files/patch-ab
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- app/drivers/oss-output.c.orig Sun Nov 28 20:04:30 1999
|
||||
+++ app/drivers/oss-output.c Sun Nov 28 20:04:01 1999
|
||||
@@ -33,6 +33,6 @@
|
||||
#include <sys/types.h>
|
||||
#include <unistd.h>
|
||||
-#include <sys/soundcard.h>
|
||||
+#include <machine/soundcard.h>
|
||||
#include <sys/time.h>
|
||||
|
||||
#include <glib.h>
|
8
audio/soundtracker/files/patch-ac
Normal file
8
audio/soundtracker/files/patch-ac
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- app/sample-editor.c.orig Sun Nov 28 20:05:23 1999
|
||||
+++ app/sample-editor.c Sun Nov 28 20:04:51 1999
|
||||
@@ -28,4 +28,4 @@
|
||||
#include <fcntl.h>
|
||||
#include <stdlib.h>
|
||||
-#include <sys/soundcard.h>
|
||||
+#include <machine/soundcard.h>
|
||||
#include <sys/ioctl.h>
|
7
audio/soundtracker/files/patch-ad
Normal file
7
audio/soundtracker/files/patch-ad
Normal file
|
@ -0,0 +1,7 @@
|
|||
--- app/Makefile.in.orig Mon Nov 29 01:49:07 1999
|
||||
+++ app/Makefile.in Mon Nov 29 01:49:59 1999
|
||||
@@ -466,3 +466,3 @@
|
||||
install-exec-local:
|
||||
- chown root.root $(bindir)/soundtracker
|
||||
+ chown root.wheel $(bindir)/soundtracker
|
||||
chmod +s $(bindir)/soundtracker
|
7
audio/soundtracker/files/patch-ae
Normal file
7
audio/soundtracker/files/patch-ae
Normal file
|
@ -0,0 +1,7 @@
|
|||
--- app/Makefile.am.orig Mon Nov 29 01:49:43 1999
|
||||
+++ app/Makefile.am Mon Nov 29 01:49:53 1999
|
||||
@@ -42,3 +42,3 @@
|
||||
install-exec-local:
|
||||
- chown root.root $(bindir)/soundtracker
|
||||
+ chown root.wheel $(bindir)/soundtracker
|
||||
chmod +s $(bindir)/soundtracker
|
1
audio/soundtracker/pkg-comment
Normal file
1
audio/soundtracker/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Mod player/tracking tool which supports XM and MOD formats
|
9
audio/soundtracker/pkg-descr
Normal file
9
audio/soundtracker/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
Soundtracker is a gtk based module tracker and editor for X written by
|
||||
Michael Krause. It currently supports XM and MOD formats only and it
|
||||
allows you to save your files to XM or WAV format. Soundtracker supports XI
|
||||
instruments and WAV samples.
|
||||
|
||||
WWW: http://www.soundtracker.org
|
||||
|
||||
- Kristopher
|
||||
kzentner@u.washington.edu
|
2
audio/soundtracker/pkg-plist
Normal file
2
audio/soundtracker/pkg-plist
Normal file
|
@ -0,0 +1,2 @@
|
|||
bin/soundtracker
|
||||
share/locale/de/LC_MESSAGES/soundtracker.mo
|
Loading…
Reference in a new issue