graphics/xpaint: Update to 3.1.4
- Switch to DISTVERSION - Define LICENSE_FILE - Use autoreconf as workaround to fix build (not needed in <= 3.1.3) - Put most SED commands in patches - Comment patches about what they doing - Port uses USES=jpeg and not openjpeg* (at the moment) - Take maintainership ChangeLog: https://sourceforge.net/projects/sf-xpaint/files/sf-xpaint/
This commit is contained in:
parent
930e1fa1a0
commit
973a707c70
15 changed files with 229 additions and 199 deletions
|
@ -1,45 +1,38 @@
|
|||
PORTNAME= xpaint
|
||||
PORTVERSION= 2.9.10.3
|
||||
PORTREVISION= 3
|
||||
DISTVERSION= 3.1.4
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF/sf-${PORTNAME}/sf-${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
|
||||
MASTER_SITES= SF/sf-${PORTNAME}/sf-${PORTNAME}/${PORTNAME}-${DISTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= eduardo@FreeBSD.org
|
||||
COMMENT= Simple paint program
|
||||
WWW= http://sf-xpaint.sourceforge.net/
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libpng.so:graphics/png \
|
||||
libopenjpeg.so:graphics/openjpeg15 \
|
||||
libtiff.so:graphics/tiff \
|
||||
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libjbig.so:graphics/jbigkit \
|
||||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
libnetpbm.so:graphics/netpbm \
|
||||
libpng.so:graphics/png \
|
||||
libtiff.so:graphics/tiff \
|
||||
libXaw3dxft.so:x11-toolkits/libxaw3dxft
|
||||
RUN_DEPENDS= psselect:print/psutils \
|
||||
bash:shells/bash
|
||||
RUN_DEPENDS= bash:shells/bash \
|
||||
psselect:print/psutils
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= ghostscript:run jpeg libtool:build localbase:ldflags \
|
||||
pkgconfig shebangfix tar:bzip2 xorg
|
||||
USES= autoreconf desktop-file-utils gmake jpeg libtool:build \
|
||||
localbase:ldflags pkgconfig shebangfix tar:bzip2 xorg
|
||||
USE_XORG= ice sm x11 xext xft xmu xpm xt
|
||||
|
||||
SHEBANG_FILES= share/bin/imgmerge share/bin/xpaint_ocr
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include/openjpeg-1.5
|
||||
MAKE_ENV+= RM="${RM}"
|
||||
# util/Makefile and vxp2ps/Makefile needs it
|
||||
BINARY_ALIAS= make=${GMAKE}
|
||||
|
||||
post-patch:
|
||||
@${RM} ${WRKSRC}/XPaint.ad
|
||||
@${REINPLACE_CMD} -e 's/-ldl //' \
|
||||
${WRKSRC}/configure ${WRKSRC}/rw/configure
|
||||
@${REINPLACE_CMD} -e '/^LIBTOOL =/s|=.*|= ${LOCALBASE}/bin/libtool|' \
|
||||
-e '/^install-exec-am:/s/install-libLTLIBRARIES//' \
|
||||
${WRKSRC}/rw/Makefile.in
|
||||
@${REINPLACE_CMD} -e '/if (!image)/s/return;/return -1;/' \
|
||||
${WRKSRC}/rw/readWriteTGA.c
|
||||
|
||||
post-configure:
|
||||
${MAKE} -C ${WRKSRC} clean
|
||||
# Do not install libraries
|
||||
pre-build:
|
||||
@${REINPLACE_CMD} -e '/^install-exec-am:/s/install-libLTLIBRARIES//' \
|
||||
${WRKSRC}/xpaintrw/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (xpaint-2.9.10.3.tar.bz2) = 9de0cb99557ea8329391b5d45ad59be080972924258aeb1b3c0c748bab9586c7
|
||||
SIZE (xpaint-2.9.10.3.tar.bz2) = 1283725
|
||||
TIMESTAMP = 1689277150
|
||||
SHA256 (xpaint-3.1.4.tar.bz2) = 6edacc9b011e6ce356c3d989156fc62460e3bfd958856c8f133c5f3589d67851
|
||||
SIZE (xpaint-3.1.4.tar.bz2) = 1630009
|
||||
|
|
23
graphics/xpaint/files/patch-Makefile.am
Normal file
23
graphics/xpaint/files/patch-Makefile.am
Normal file
|
@ -0,0 +1,23 @@
|
|||
Fix app-defaults install path.
|
||||
Fix link to libxaw3dxft path.
|
||||
|
||||
--- Makefile.am.orig 2021-01-07 14:18:14 UTC
|
||||
+++ Makefile.am
|
||||
@@ -3,7 +3,7 @@ SHAREDIR = $(prefix)/share/xpaint
|
||||
## Local Configuration arguments
|
||||
BINDIR = $(prefix)/bin
|
||||
SHAREDIR = $(prefix)/share/xpaint
|
||||
-XAPPLOADDIR = /etc/X11/app-defaults
|
||||
+XAPPLOADDIR = $(prefix)/share/X11/app-defaults
|
||||
|
||||
## Enable/disable PRINTCAP (for older BSD style printing configuration)
|
||||
## PRINTCAP = -DPRINTCAP
|
||||
@@ -85,7 +85,7 @@ version.h:
|
||||
.PHONY:
|
||||
|
||||
version.h:
|
||||
- rm -f xaw_incdir ; ln -s /usr/include/X11/Xaw3dxft xaw_incdir
|
||||
+ rm -f xaw_incdir ; ln -s ${LOCALBASE}/include/X11/Xaw3dxft xaw_incdir
|
||||
echo "#define XPAINT_VERSION \"$(PACKAGE_VERSION)\"" > version.h
|
||||
|
||||
substads: substads.c
|
|
@ -1,55 +0,0 @@
|
|||
--- Makefile.in.orig 2014-04-17 16:50:14.000000000 +0200
|
||||
+++ Makefile.in 2014-04-21 15:13:31.000000000 +0200
|
||||
@@ -358,7 +358,7 @@ top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
BINDIR = $(prefix)/bin
|
||||
SHAREDIR = $(prefix)/share/xpaint
|
||||
-XAPPLOADDIR = /etc/X11/app-defaults
|
||||
+XAPPLOADDIR = /usr/local/lib/X11/app-defaults
|
||||
PRINT_COMMAND = lpr
|
||||
LPCCMD = /usr/sbin/lpc status
|
||||
#define LPCCMD
|
||||
@@ -1041,14 +1041,14 @@ docs: INSTALL README TODO ChangeLog
|
||||
.PHONY:
|
||||
|
||||
version.h:
|
||||
- rm -f xaw_incdir ; ln -s /usr/include/X11/Xaw3dxft xaw_incdir
|
||||
+ rm -f xaw_incdir ; ln -s /usr/local/include/X11/Xaw3dxft xaw_incdir
|
||||
echo "#define XPAINT_VERSION \"$(PACKAGE_VERSION)\"" > version.h
|
||||
|
||||
substads: substads.c
|
||||
- $(CC) substads.c -o $@
|
||||
+ $(CC) $(CFLAGS) substads.c -o $@
|
||||
|
||||
preproc: preproc.c version.h
|
||||
- $(CC) preproc.c -o $@
|
||||
+ $(CC) $(CFLAGS) preproc.c -o $@
|
||||
|
||||
DefaultRC.txt.h: substads DefaultRC
|
||||
./substads -ad2c DefaultRC $@
|
||||
@@ -1056,21 +1056,20 @@ DefaultRC.txt.h: substads DefaultRC
|
||||
messages.h: preproc
|
||||
./preproc > messages.h
|
||||
|
||||
-XPaint.ad: app-defaults
|
||||
- $(CC) substads.c -o substads
|
||||
- cd app-defaults ; \
|
||||
+XPaint.ad: substads app-defaults
|
||||
+ (cd app-defaults ; \
|
||||
../substads -appdefs \
|
||||
XPAINT_VERSION $(PACKAGE_VERSION) \
|
||||
XPAINT_SHAREDIR $(SHAREDIR) \
|
||||
XPAINT_PRINT_COMMAND "$(PRINT_COMMAND)" \
|
||||
XPAINT_POSTSCRIPT_VIEWER "$(POSTSCRIPT_VIEWER)" \
|
||||
- XPAINT_EXTERN_VIEWER "$(EXTERN_VIEWER)"
|
||||
+ XPAINT_EXTERN_VIEWER "$(EXTERN_VIEWER)")
|
||||
cp -p app-defaults/out/XPaint XPaint.ad
|
||||
|
||||
XPaint.ad.h: substads XPaint.ad
|
||||
./substads -ad2c XPaint.ad $@
|
||||
|
||||
-xpaint.1: xpaint.1.in version.h
|
||||
+xpaint.1: substads xpaint.1.in version.h
|
||||
./substads -single xpaint.1.in xpaint.1 XPAINT_VERSION $(PACKAGE_VERSION)
|
||||
|
||||
install-exec-hook:
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.orig 2015-12-03 20:52:59.771668000 +0100
|
||||
+++ configure 2015-12-03 20:53:09.226361000 +0100
|
||||
@@ -5611,7 +5611,7 @@
|
||||
$as_echo_n "checking location of freetype2 headers... " >&6; }
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
-#include <freetype2/config/ftheader.h>
|
||||
+#include <freetype2/freetype/config/ftheader.h>
|
||||
int
|
||||
main ()
|
||||
{
|
24
graphics/xpaint/files/patch-configure.ac
Normal file
24
graphics/xpaint/files/patch-configure.ac
Normal file
|
@ -0,0 +1,24 @@
|
|||
Do not build with -ldl.
|
||||
Fix path to freetype2.
|
||||
|
||||
|
||||
--- configure.ac.orig 2021-08-16 08:58:14 UTC
|
||||
+++ configure.ac
|
||||
@@ -36,7 +36,7 @@ if test x"$have_x11" = xyes; then
|
||||
dnl check X11
|
||||
AC_CHECK_LIB([X11], [XOpenDisplay], have_x11="yes")
|
||||
if test x"$have_x11" = xyes; then
|
||||
- AC_SUBST([X_LIBS], ["-lXmu -lXt -lSM -lICE -lXext -lX11 -lXpm -ldl -rdynamic"])
|
||||
+ AC_SUBST([X_LIBS], ["-lXmu -lXt -lSM -lICE -lXext -lX11 -lXpm -rdynamic"])
|
||||
AC_SUBST([X_CFLAGS], ["-I/usr/include/X11"])
|
||||
else
|
||||
echo "X11 libraries not installed !"
|
||||
@@ -317,7 +317,7 @@ AC_PREPROC_IFELSE(
|
||||
|
||||
AC_MSG_CHECKING([location of freetype2 headers])
|
||||
AC_PREPROC_IFELSE(
|
||||
- [AC_LANG_PROGRAM([[#include <freetype2/config/ftheader.h>]])],
|
||||
+ [AC_LANG_PROGRAM([[#include <freetype2/freetype/config/ftheader.h>]])],
|
||||
[AC_MSG_RESULT([already in path])],
|
||||
[AC_PREPROC_IFELSE(
|
||||
[AC_LANG_PROGRAM([[#include </usr/include/freetype2/freetype/config/ftheader.h>]])],
|
|
@ -1,26 +1,22 @@
|
|||
--- fileBrowser.c.orig 2014-05-08 13:50:48 UTC
|
||||
Suppport dirent(3) if defined.
|
||||
|
||||
--- fileBrowser.c.orig 2020-09-02 07:24:21 UTC
|
||||
+++ fileBrowser.c
|
||||
@@ -47,11 +47,7 @@ extern Xaw3dXftData *xaw3dxft_data;
|
||||
@@ -48,7 +48,7 @@ extern Xaw3dXftData *xaw3dxft_data;
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
-#if defined(SYSV) || defined(SVR4) || defined(__CYGWIN__) || defined(__VMS )
|
||||
+#if HAVE_DIRENT_H
|
||||
#include <dirent.h>
|
||||
-#else
|
||||
-#include <sys/dir.h>
|
||||
-#endif
|
||||
#include <pwd.h>
|
||||
|
||||
#include "rw/rwTable.h"
|
||||
@@ -562,11 +558,7 @@ static void
|
||||
#else
|
||||
#include <sys/dir.h>
|
||||
@@ -563,7 +563,7 @@ setCWD(arg_t * arg, char *dir)
|
||||
setCWD(arg_t * arg, char *dir)
|
||||
{
|
||||
DIR *dirp;
|
||||
-#if defined(SYSV) || defined(SVR4) || defined(__alpha) || defined(__CYGWIN__)
|
||||
+#if HAVE_DIRENT_H
|
||||
struct dirent *e;
|
||||
-#else
|
||||
- struct direct *e;
|
||||
-#endif
|
||||
int count = 0, i = 0;
|
||||
int dirCount = 0, fileCount = 0;
|
||||
String *list;
|
||||
#else
|
||||
struct direct *e;
|
||||
|
|
23
graphics/xpaint/files/patch-main.c
Normal file
23
graphics/xpaint/files/patch-main.c
Normal file
|
@ -0,0 +1,23 @@
|
|||
The XtGetApplicationResources() function uses the 'resources' array instead
|
||||
of the 'options' array to obtain resources.
|
||||
|
||||
--- main.c.orig 2020-09-03 07:06:19 UTC
|
||||
+++ main.c
|
||||
@@ -146,7 +146,7 @@ static XtResource resources[] =
|
||||
{"winsize", "WinSize", XtRString, sizeof(String),
|
||||
XtOffset(AppInfo *, winsize), XtRImmediate, (XtPointer) "0x0"},
|
||||
{"shareDir", "ShareDir", XtRString, sizeof(String),
|
||||
- XtOffset(AppInfo *, shareDir), XtRImmediate, (XtPointer) NULL},
|
||||
+ XtOffset(AppInfo *, shareDir), XtRImmediate, (XtPointer) SHAREDIR},
|
||||
{"rcFile", "RcFile", XtRString, sizeof(String),
|
||||
XtOffset(AppInfo *, rcFile), XtRImmediate, (XtPointer) NULL},
|
||||
{"help", "Help", XtRString, sizeof(String),
|
||||
@@ -206,7 +206,7 @@ static XrmOptionDescRec options[] =
|
||||
{"-hilitcolor", ".hilitcolor", XrmoptionSepArg, (XtPointer) NULL},
|
||||
{"-canvassize", ".canvassize", XrmoptionSepArg, (XtPointer) NULL},
|
||||
{"-winsize", ".winsize", XrmoptionSepArg, (XtPointer) "0x0"},
|
||||
- {"-sharedir", ".shareDir", XrmoptionSepArg, (XtPointer) SHAREDIR},
|
||||
+ {"-sharedir", ".shareDir", XrmoptionSepArg, (XtPointer) NULL},
|
||||
{"-rcfile", ".rcFile", XrmoptionSepArg, (XtPointer) NULL},
|
||||
{"-helpfile", ".helpFile", XrmoptionSepArg, (XtPointer) NULL},
|
||||
{"-msgfile", ".msgFile", XrmoptionSepArg, (XtPointer) NULL},
|
|
@ -1,11 +0,0 @@
|
|||
--- rw/configure.orig 2015-12-03 20:56:32.251228000 +0100
|
||||
+++ rw/configure 2015-12-03 20:56:55.905547000 +0100
|
||||
@@ -11691,7 +11691,7 @@
|
||||
$as_echo_n "checking location of freetype2 headers... " >&6; }
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
-#include <freetype2/config/ftheader.h>
|
||||
+#include <freetype2/freetype/config/ftheader.h>
|
||||
int
|
||||
main ()
|
||||
{
|
|
@ -1,11 +0,0 @@
|
|||
--- rw/readWriteJP2K.c.orig 2023-05-08 13:59:30 UTC
|
||||
+++ rw/readWriteJP2K.c
|
||||
@@ -69,7 +69,7 @@ ReadJP2K(char *file_name)
|
||||
int i, j, k, l, w, h, w0, nc, step, delta, shift, bpp;
|
||||
int *src, codec = CODEC_JP2;
|
||||
|
||||
- if ((fp = fopen(file_name, "rb")) == NULL) return (-1);
|
||||
+ if ((fp = fopen(file_name, "rb")) == NULL) return (Image *)(-1);
|
||||
|
||||
/* Read in the entire file */
|
||||
fseek(fp, 0, SEEK_END);
|
|
@ -1,57 +0,0 @@
|
|||
--- util/Makefile.orig 2012-02-05 15:14:24.000000000 +0100
|
||||
+++ util/Makefile 2013-09-16 13:27:46.000000000 +0200
|
||||
@@ -1,13 +1,11 @@
|
||||
-GCC = gcc
|
||||
-CPP = g++ -fpermissive
|
||||
|
||||
all: pdfconcat ppmtops pgf2pnm
|
||||
|
||||
pdfconcat:
|
||||
- $(GCC) -O3 -s -DNDEBUG=1 -DNO_CONFIG=1 -ansi -pedantic -Wunused -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes -Wmissing-declarations pdfconcat.c -o pdfconcat
|
||||
+ $(CC) $(CFLAGS) -s -DNDEBUG=1 -DNO_CONFIG=1 -ansi -pedantic -Wunused -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes -Wmissing-declarations pdfconcat.c -o pdfconcat
|
||||
|
||||
ppmtops:
|
||||
- $(GCC) ppmtops.c -o ppmtops
|
||||
+ $(CC) $(CFLAGS) ppmtops.c -o ppmtops
|
||||
|
||||
pgf2pnm: main.cpp pnm.cpp
|
||||
@if [ -x /usr/include/libpgf ] ; then \
|
||||
@@ -15,25 +13,25 @@ pgf2pnm: main.cpp pnm.cpp
|
||||
$(CPP) -c pnm.cpp -o pnm.o -I/usr/include/libpgf ; \
|
||||
$(CPP) -o pgf2pnm main.o pnm.o -lpgf ; \
|
||||
else \
|
||||
- @echo "libpgf not installed !!" ; \
|
||||
+ echo "libpgf not installed !!" ; \
|
||||
fi
|
||||
|
||||
install:
|
||||
@if [ -x pdfconcat ] ; then \
|
||||
- mkdir -p $(DESTDIR)/usr/bin ; \
|
||||
- install -c pdfconcat $(DESTDIR)/usr/bin ; \
|
||||
- echo "install -c pdfconcat $(DESTDIR)/usr/bin" ; \
|
||||
- mkdir -p $(DESTDIR)/usr/share/man/man1 ; \
|
||||
- install -c -m 644 pdfconcat.1 $(DESTDIR)/usr/share/man/man1 ; \
|
||||
- echo "install -c pdfconcat.1 $(DESTDIR)/usr/share/man/man1" ; fi
|
||||
+ mkdir -p $(DESTDIR)$(PREFIX)/bin ; \
|
||||
+ install -c pdfconcat $(DESTDIR)$(PREFIX)/bin ; \
|
||||
+ echo "install -c pdfconcat $(DESTDIR)$(PREFIX)/bin" ; \
|
||||
+ mkdir -p $(DESTDIR)$(PREFIX)/man/man1 ; \
|
||||
+ install -c -m 644 pdfconcat.1 $(DESTDIR)$(PREFIX)/man/man1 ; \
|
||||
+ echo "install -c pdfconcat.1 $(DESTDIR)$(PREFIX)/man/man1" ; fi
|
||||
@if [ -x ppmtops ] ; then \
|
||||
- mkdir -p $(DESTDIR)/usr/bin ; \
|
||||
- install -c ppmtops $(DESTDIR)/usr/bin ; \
|
||||
- echo "install -c ppmtops $(DESTDIR)/usr/bin" ; fi
|
||||
+ mkdir -p $(DESTDIR)$(PREFIX)/bin ; \
|
||||
+ install -c -s ppmtops $(DESTDIR)$(PREFIX)/bin ; \
|
||||
+ echo "install -c ppmtops $(DESTDIR)$(PREFIX)/bin" ; fi
|
||||
@if [ -x pgf2pnm ] ; then \
|
||||
- mkdir -p $(DESTDIR)/usr/bin ; \
|
||||
- install -c pgf2pnm $(DESTDIR)/usr/bin ; \
|
||||
- echo "install -c pgf2pnm $(DESTDIR)/usr/bin" ; fi
|
||||
+ mkdir -p $(DESTDIR)$(PREFIX)/bin ; \
|
||||
+ install -c pgf2pnm $(DESTDIR)$(PREFIX)/bin ; \
|
||||
+ echo "install -c pgf2pnm $(DESTDIR)$(PREFIX)/bin" ; fi
|
||||
|
||||
clean:
|
||||
rm -f core *~ *.o pdfconcat ppmtops pgf2pnm
|
25
graphics/xpaint/files/patch-vxp2ps_Makefile
Normal file
25
graphics/xpaint/files/patch-vxp2ps_Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
Respect compiler and fix DESTDIR path.
|
||||
|
||||
--- vxp2ps/Makefile.orig 2021-01-19 08:35:54 UTC
|
||||
+++ vxp2ps/Makefile
|
||||
@@ -3,16 +3,16 @@ vxp2ps: vxp2ps.c
|
||||
all: vxp2ps vxp2tex vxp2dkw
|
||||
|
||||
vxp2ps: vxp2ps.c
|
||||
- gcc vxp2ps.c -o vxp2ps -lm $(CFLAGSEXTRA)
|
||||
+ $(CC) $(CFLAGS) vxp2ps.c -o vxp2ps -lm $(CFLAGSEXTRA)
|
||||
|
||||
vxp2tex: vxp2tex.c
|
||||
- gcc vxp2tex.c -o vxp2tex -lm
|
||||
+ $(CC) $(CFLAGS) vxp2tex.c -o vxp2tex -lm
|
||||
|
||||
vxp2dkw: vxp2dkw.c
|
||||
- gcc vxp2dkw.c -o vxp2dkw -lm
|
||||
+ $(CC) $(CFLAGS) vxp2dkw.c -o vxp2dkw -lm
|
||||
|
||||
install: all
|
||||
- install -c -s vxp2ps vxp2tex vxp2dkw "$(DESTDIR)"/usr/bin
|
||||
+ install -c -s vxp2ps vxp2tex vxp2dkw $(DESTDIR)$(PREFIX)/bin
|
||||
|
||||
clean:
|
||||
rm -f core *~ vxp2ps vxp2tex vxp2dkw
|
13
graphics/xpaint/files/patch-xpaintrw_Makefile.am
Normal file
13
graphics/xpaint/files/patch-xpaintrw_Makefile.am
Normal file
|
@ -0,0 +1,13 @@
|
|||
Fix libtool path.
|
||||
|
||||
--- xpaintrw/Makefile.am.orig 2023-07-13 21:19:11 UTC
|
||||
+++ xpaintrw/Makefile.am
|
||||
@@ -28,7 +28,7 @@ xpaint_DEFINES = $(ARCH_DEFINES) $(EXTRA_DEFINES) $(XA
|
||||
|
||||
xpaint_DEFINES = $(ARCH_DEFINES) $(EXTRA_DEFINES) $(XAWLIB_DEFINES)
|
||||
|
||||
-LIBTOOL = /usr/bin/libtool
|
||||
+LIBTOOL = ${LOCALBASE}/bin/libtool
|
||||
AM_CFLAGS = @X_CFLAGS@ @SPECIAL_CFLAGS@ $(xpaint_DEFINES)
|
||||
AM_YFLAGS = -d
|
||||
CLEANFILES =
|
|
@ -1,6 +1,8 @@
|
|||
--- rw/rwTable.c.orig 2012-02-08 09:08:02.000000000 +0100
|
||||
+++ rw/rwTable.c 2013-09-16 13:27:46.000000000 +0200
|
||||
@@ -339,7 +339,7 @@ RWtableGetWriterList()
|
||||
Extend support to FreeBSD and OpenBSD.
|
||||
|
||||
--- xpaintrw/rwTable.c.orig 2021-01-23 08:03:16 UTC
|
||||
+++ xpaintrw/rwTable.c
|
||||
@@ -294,7 +294,7 @@ RWGetMsg()
|
||||
char *
|
||||
RWGetMsg()
|
||||
{
|
|
@ -1,13 +1,19 @@
|
|||
bin/imgmerge
|
||||
bin/pdfconcat
|
||||
bin/ppmtops
|
||||
bin/vxp2dkw
|
||||
bin/vxp2ps
|
||||
bin/vxp2tex
|
||||
bin/xpaint
|
||||
lib/X11/app-defaults/XPaint
|
||||
lib/X11/app-defaults/XPaint_es
|
||||
lib/X11/app-defaults/XPaint_fr
|
||||
bin/xpaint_generate_toolicons
|
||||
man/man1/imgmerge.1.gz
|
||||
man/man1/pdfconcat.1.gz
|
||||
man/man1/xpaint.1.gz
|
||||
share/X11/app-defaults/XPaint
|
||||
share/X11/app-defaults/XPaint.big
|
||||
share/X11/app-defaults/XPaint.medium
|
||||
share/X11/app-defaults/XPaint.small
|
||||
share/X11/app-defaults/XPaint_es
|
||||
share/X11/app-defaults/XPaint_fr
|
||||
share/applications/xpaint.desktop
|
||||
share/icons/hicolor/scalable/apps/xpaint.svg
|
||||
%%DATADIR%%/XPaintIcon.xpm
|
||||
%%DATADIR%%/bin/xpaint_ocr
|
||||
%%DATADIR%%/bitmaps/brushbox.cfg
|
||||
|
@ -57,6 +63,68 @@ man/man1/xpaint.1.gz
|
|||
%%DATADIR%%/bitmaps/elec/resV.xpm
|
||||
%%DATADIR%%/bitmaps/elec/tfxV.xpm
|
||||
%%DATADIR%%/bitmaps/elec/traV.xpm
|
||||
%%DATADIR%%/bitmaps/toolicons/arcOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/arrowOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/boxOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/brokenlineOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/brushOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/dotPenOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/dynPenOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/ellipseOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/eraseOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/fillOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/filledBoxOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/filledEllipseOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/filledFreehandOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/filledPolygonOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/filledSplineOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/fractalFillOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/freehandOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/gradientFillOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/lineOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/pencil.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/pencilOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/polygonOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/selectBoxOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/selectEllipseOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/selectFreeHandOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/selectFreehandOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/selectPolygonOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/selectSplineOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/smearOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/splineOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/sprayOp.xpm.gz
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/arc.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/arrow.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/box.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/brokenline.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/brush.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/dotPen.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/dynPen.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/ellipse.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/erase.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/fill.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/filledBox.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/filledEllipse.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/filledFreehand.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/filledPolygon.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/filledSpline.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/fractalFill.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/freehand.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/gradientFill.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/line.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/pencil.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/polygon.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/selectBox.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/selectEllipse.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/selectFreehand.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/selectPolygon.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/selectSpline.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/smear.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/spline.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/spray.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/svg/text.svg
|
||||
%%DATADIR%%/bitmaps/toolicons/textOp.xpm.gz
|
||||
%%DATADIR%%/c_scripts/3d_curves/helicoid.c
|
||||
%%DATADIR%%/c_scripts/3d_curves/lissajous.c
|
||||
%%DATADIR%%/c_scripts/3d_surfaces/ellipsoid.c
|
||||
|
@ -73,15 +141,20 @@ man/man1/xpaint.1.gz
|
|||
%%DATADIR%%/c_scripts/filters/mapping.c
|
||||
%%DATADIR%%/c_scripts/filters/merge.c
|
||||
%%DATADIR%%/c_scripts/filters/permute.c
|
||||
%%DATADIR%%/c_scripts/filters/projective.c
|
||||
%%DATADIR%%/c_scripts/filters/rotleft.c
|
||||
%%DATADIR%%/c_scripts/filters/rotright.c
|
||||
%%DATADIR%%/c_scripts/filters/similarity.c
|
||||
%%DATADIR%%/c_scripts/filters/updown.c
|
||||
%%DATADIR%%/c_scripts/images/alpha_test.c
|
||||
%%DATADIR%%/c_scripts/images/rgb_test.c
|
||||
%%DATADIR%%/c_scripts/layers/combine.c
|
||||
%%DATADIR%%/c_scripts/procedures/canvas+vxp.c
|
||||
%%DATADIR%%/c_scripts/procedures/proc_with_params.c
|
||||
%%DATADIR%%/c_scripts/procedures/setmemory.c
|
||||
%%DATADIR%%/c_scripts/templates/image.c
|
||||
%%DATADIR%%/c_scripts/templates/bird.png
|
||||
%%DATADIR%%/c_scripts/templates/cat.jpg
|
||||
%%DATADIR%%/c_scripts/templates/script.c
|
||||
%%DATADIR%%/help/Help
|
||||
%%DATADIR%%/help/Help_es
|
||||
%%DATADIR%%/help/Help_fr
|
||||
|
@ -110,9 +183,11 @@ man/man1/xpaint.1.gz
|
|||
%%DATADIR%%/include/protocol.h
|
||||
%%DATADIR%%/include/rc.h
|
||||
%%DATADIR%%/include/region.h
|
||||
%%DATADIR%%/include/rwTable.h
|
||||
%%DATADIR%%/include/text.h
|
||||
%%DATADIR%%/include/version.h
|
||||
%%DATADIR%%/include/xpaint.h
|
||||
%%DATADIR%%/include/xpaintrw.h
|
||||
%%DATADIR%%/messages/Messages
|
||||
%%DATADIR%%/messages/Messages_es
|
||||
%%DATADIR%%/messages/Messages_fr
|
||||
|
|
Loading…
Reference in a new issue