Update to 1.1.16.

This commit is contained in:
Joe Marcus Clarke 2006-05-02 22:40:27 +00:00
parent 9e4e615412
commit 9742552485
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=161219
6 changed files with 34 additions and 34 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= libxslt
PORTVERSION= 1.1.15
PORTREVISION= 1
PORTVERSION= 1.1.16
CATEGORIES?= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.1

View file

@ -1,3 +1,3 @@
MD5 (gnome2/libxslt-1.1.15.tar.bz2) = 0a48d1a723d5338b246702ab1769e7bf
SHA256 (gnome2/libxslt-1.1.15.tar.bz2) = 6322124f471d6ed4908833cddaba512b247aa169cb8d1ebd87219afe051c6e03
SIZE (gnome2/libxslt-1.1.15.tar.bz2) = 1822862
MD5 (gnome2/libxslt-1.1.16.tar.bz2) = 35e1c422b4b222c860dd56445fa51a8b
SHA256 (gnome2/libxslt-1.1.16.tar.bz2) = 9e9840b2bbe4bdc7c0afeba3ee981fdeb4964d2c4109ced127ccc9ef975a9c37
SIZE (gnome2/libxslt-1.1.16.tar.bz2) = 1861172

View file

@ -0,0 +1,29 @@
--- configure.orig Tue May 2 18:32:39 2006
+++ configure Tue May 2 18:34:50 2006
@@ -21701,7 +21701,7 @@ except: print 0"`
-d $with_python/lib/python$PYTHON_VERSION/site-packages
then
PYTHON_INCLUDES=$with_python/include/python$PYTHON_VERSION
- PYTHON_SITE_PACKAGES='$(libdir)/lib/python$(PYTHON_VERSION)/site-packages'
+ PYTHON_SITE_PACKAGES=$with_python/lib/python$PYTHON_VERSION/site-packages
else
if test -r $prefix/include/python$PYTHON_VERSION/Python.h
then
@@ -21724,7 +21724,7 @@ except: print 0"`
fi
if test "$with_python" != ""
then
- pythondir=$(PYTHON_SITE_PACKAGES)
+ pythondir='$(PYTHON_SITE_PACKAGES)'
else
pythondir='$(libdir)/python$(PYTHON_VERSION)/site-packages'
fi
@@ -22057,7 +22057,7 @@ fi
-if test "$WITH_MODULES" == "1"; then
+if test "$WITH_MODULES" = "1"; then
WITH_MODULES_TRUE=
WITH_MODULES_FALSE='#'
else

View file

@ -1,11 +0,0 @@
--- libexslt/crypto.c.orig Mon Jul 5 19:33:58 2004
+++ libexslt/crypto.c Mon Jul 5 19:35:25 2004
@@ -315,6 +315,8 @@
#define PLATFORM_MD5 GCRY_MD_MD5
#define PLATFORM_SHA1 GCRY_MD_SHA1
+#include <sys/types.h>
+#include <sys/time.h>
#include <sys/select.h> /* needed by gcrypt.h 4 Jul 04 */
#include <gcrypt.h>

View file

@ -1,18 +0,0 @@
$FreeBSD$
--- libxslt/xslt.h 2001/12/06 12:04:42 1.1
+++ libxslt/xslt.h 2001/12/06 12:07:32
@@ -11,6 +11,12 @@
#include <libxml/tree.h>
+#if defined(WIN32) && defined(_MSC_VER)
+#include <libxslt/xsltwin32config.h>
+#else
+#include <libxslt/xsltconfig.h>
+#endif
+
#ifdef __cplusplus
extern "C" {
#endif

View file

@ -19,6 +19,7 @@ PLIST= ${.CURDIR}/pkg-plist
USE_GNOME= gnomehack lthack gnometarget libxslt
USE_PYTHON= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--with-python=${LOCALBASE}