Complete new patch files for update to version 1.1.7.

This commit is contained in:
Lars Koeller 2000-12-24 12:59:19 +00:00
parent 9b36675494
commit 9775928ec9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36306
5 changed files with 218 additions and 101 deletions

View file

@ -1,60 +1,155 @@
--- XmHTML.cf.orig Sat Feb 20 13:38:17 1999
+++ XmHTML.cf Sat Feb 20 14:08:18 1999
@@ -22,10 +22,10 @@
XCOMM
XCOMM This specifies where the XmHTML library will be installed
-#define XmHTMLLibDir $(USRLIBDIR)
+#define XmHTMLLibDir /usr/X11R6/lib
XCOMM This specifies where the XmHTML header files will be installed
-#define XmHTMLIncDir $(INCROOT)/XmHTML
+#define XmHTMLIncDir /usr/X11R6/include/XmHTML
XCOMM You may need to modify the following DEFINES as follows:
XCOMM if your system doesn't provide str[n]casecmp, add -DNEED_STRCASECMP
@@ -51,6 +51,11 @@
DEFINES = -DNEED_STRCASECMP
#endif
+BUILDINCTOP= ..
+BUILDBINTOP= ..
+BUILDLIBTOP= ..
+INSTINCFLAGS = -c -m 0444
+
XCOMM Image support configuration
XCOMM XPM support.
@@ -59,8 +64,8 @@
XCOMM Uncomment and fill in the proper paths to xpm.h and libXpm
XCOMM The defaults are /usr/X11R6/include (or wherever your X includes live)
XCOMM and /usr/X11R6/lib (or wherever your X libraries live)
-XCOMM XPMINCLUDES = -I$(INCROOT)/X11
-XCOMM XPMLIBRARIES = -L$(LIBDIR) -lXpm
+XPMINCLUDES = -I$(INCROOT)/X11
+XPMLIBRARIES = -L$(LIBDIR) -lXpm
XCOMM
XCOMM JPEG Support. Enabled by default.
@@ -74,8 +79,8 @@
XCOMM Required include files: jpeglib.h, jconfig.h, jmorecfg.h
XCOMM
#if (IHaveJPEG)
-JPEGINC =
-JPEGLIB = -ljpeg
+JPEGINC = -I/usr/local/include
+JPEGLIB = -ljpeg -L/usr/local/lib
#else
XCOMM JPEG support not selected
#endif
@@ -93,8 +98,8 @@
XCOMM Required include files: png.h, pngconf.h
XCOMM
#if (IHavePNG)
-PNGINC =
-PNGLIB = -lpng
+PNGINC = -I/usr/local/include
+PNGLIB = -lpng -L/usr/local/lib
#else
XCOMM PNG support not selected
#endif
*** Makefile.orig Thu Feb 4 01:43:27 1999
--- Makefile Sat Aug 5 15:29:56 2000
***************
*** 40,46 ****
# remove the examples directory from this line.
# If you want to build the XmHTML tutorial examples, add the book directory.
! SUBDIRS= lib http examples tools
# some common definitions
#
--- 40,46 ----
# remove the examples directory from this line.
# If you want to build the XmHTML tutorial examples, add the book directory.
! SUBDIRS= lib http examples tools book contrib
# some common definitions
#
***************
*** 64,72 ****
# Compiler Settings #
# #
#####################
! CC = gcc
! CFLAGS = -g -funroll-loops -Wall -pipe -ansi
! LDFLAGS =
# The following flags are *very* usefull if you are getting unresolved
# references to functions in libraries that you *know* to exist.
--- 64,72 ----
# Compiler Settings #
# #
#####################
! CC = libtool gcc
! CFLAGS = -O2 -funroll-loops -pipe -ansi
! #LDFLAGS =
# The following flags are *very* usefull if you are getting unresolved
# references to functions in libraries that you *know* to exist.
***************
*** 115,121 ****
# HAVE_LIBZ => zlib.h
ZLIBINC =
! IMAGEINCLUDES = $(ZLIBINC)
# Image libraries
# No need to add -lXpm if you need to include it with LIBS below
--- 115,121 ----
# HAVE_LIBZ => zlib.h
ZLIBINC =
! IMAGEINCLUDES = -I${LOCALBASE}/include $(ZLIBINC)
# Image libraries
# No need to add -lXpm if you need to include it with LIBS below
***************
*** 126,132 ****
# HAVE_LIBZ => libz (and possibly libm)
ZLIBLIB = -lz -lm
! IMAGELIBS = -ljpeg -lpng $(ZLIBLIB)
# It might be troublesome to know what the correct defines are for your
# system. A possible set of defines for some OS's is given below. Pick
--- 126,132 ----
# HAVE_LIBZ => libz (and possibly libm)
ZLIBLIB = -lz -lm
! IMAGELIBS = -L${LOCALBASE}/lib -ljpeg -lpng $(ZLIBLIB)
# It might be troublesome to know what the correct defines are for your
# system. A possible set of defines for some OS's is given below. Pick
***************
*** 166,182 ****
# Add -DDEBUG to enable selective debug output (see the file DEBUGGING for more
# info).
#
! CPPFLAGS = -DDEBUG -D_GNU_SOURCE -D_BSD_SOURCE -D_POSIX_SOURCE -DHAVE_REGEX_H $(IMAGEDEFINES)
# Various include directories
LIBINC=-I. -I../include -I../include/common -I../../include -I../../include/common
# Platform specific includes
ifeq ($(PLATFORM),Motif)
! PLATFORMINC=-I../../include/XmHTML -I/usr/X11R6/include
else
ifeq ($(PLATFORM),gtk)
! PLATFORMINC=-I../../include/gtk-xmhtml -I/usr/local/include
endif
endif
--- 166,182 ----
# Add -DDEBUG to enable selective debug output (see the file DEBUGGING for more
# info).
#
! CPPFLAGS = -DHAVE_REGEX_H $(IMAGEDEFINES)
# Various include directories
LIBINC=-I. -I../include -I../include/common -I../../include -I../../include/common
# Platform specific includes
ifeq ($(PLATFORM),Motif)
! PLATFORMINC=-I../../include/XmHTML -I${X11BASE}/include
else
ifeq ($(PLATFORM),gtk)
! PLATFORMINC=-I../../include/gtk-xmhtml -I${LOCALBASE}/include
endif
endif
***************
*** 192,208 ****
# Motif version (default)
ifeq ($(PLATFORM),Motif)
! LIBDIR = -L/usr/X11R6/lib
# This is what is required under Linux (Motif 2.0.1).
# Your mileage may vary.
! LIBS = -lXm -lXpm -lXmu -lXt -lXext -lX11 -lSM -lICE
else
# gtk version (only supported port for now)
ifeq($(PLATFORM),gtk)
! LIBDIR = -L/usr/local/lib
LIBS = -lgdk -lgtk -lX11
# endif gtk
--- 192,208 ----
# Motif version (default)
ifeq ($(PLATFORM),Motif)
! LIBDIR = -L${X11BASE}/lib
# This is what is required under Linux (Motif 2.0.1).
# Your mileage may vary.
! LIBS = ${MOTIFLIB} -lXpm -lXmu -lXt -lXext -lX11 -lSM -lICE
else
# gtk version (only supported port for now)
ifeq($(PLATFORM),gtk)
! LIBDIR = -L${X11BASE}/lib
LIBS = -lgdk -lgtk -lX11
# endif gtk
***************
*** 308,311 ****
tools/scansrc.sh ./lib/common > docs/sources.desc
tools/scansrc.sh ./lib/Motif >> docs/sources.desc
tools/scansrc.sh ./lib/gtk >> docs/sources.desc
-
--- 308,310 ----

View file

@ -1,18 +1,15 @@
--- src/Imakefile.orig Sat Feb 20 14:31:44 1999
+++ src/Imakefile Sun Feb 21 12:52:40 1999
@@ -61,11 +61,15 @@
--- examples/Makefile.orig Wed Feb 3 19:43:27 1999
+++ examples/Makefile Tue Nov 2 01:39:14 1999
@@ -11,10 +11,10 @@
EXAMPLES=example_1 example_2 example_4
XCOMM I don't know whether or not X11R5/R4 image has got a Concat3.
XCOMM This works.
+.if (${PORTOBJFORMAT} == "aout")
#if (ProjectX < 6)
SOXMHTMLLIBREV = $(XmHTMLVersionNum)./**/$(XmHTMLRevision)./**/$(XmHTMLUpdateLevel)
#else
SOXMHTMLLIBREV = Concat3($(XmHTMLVersionNum).,$(XmHTMLRevision).,$(XmHTMLUpdateLevel))
#endif
+.else
+SOXMHTMLLIBREV = $(XmHTMLVersionNum)./**/$(XmHTMLUpdateLevel)
+.endif
# The XmHTML library
-XMHTMLLIB = -L../lib -lXmHTML
+XMHTMLLIB = ../lib/libXmHTML.la
HEADERS = XmHTML.h XmHTMLP.h HTML.h Parser.h ParserP.h
# Richard Offer's http client-side library
-HTTPLIB = -L../http -lhttp
+HTTPLIB = ../http/libhttp.la
# Libraries against which all examples are linked
LINKLIBS = $(XMHTMLLIB) $(LOADLIBES) $(DMALLOCLIB)

View file

@ -1,11 +1,23 @@
--- ./book/Imakefile.org Wed May 12 01:31:48 1999
+++ ./book/Imakefile Wed May 12 02:03:40 1999
@@ -36,7 +36,7 @@
DEPLIBS = $(DEPXMLIB) $(DEPXTOOLLIB) $(DEPXLIB)
--- http/Makefile.orig Wed Feb 3 19:43:27 1999
+++ http/Makefile Tue Nov 2 01:28:54 1999
@@ -2,7 +2,7 @@
# lint configuration. I use lclint.
#
XCOMM required libraries
-LOCAL_LIBRARIES = $(XMHTMLLIB) $(XMLIB) $(XTOOLLIB) $(XLIB) $(DMALLOCLIB)
+LOCAL_LIBRARIES = $(XMHTMLLIB) $(MOTIFLIB) $(XTOOLLIB) $(XLIB) $(DMALLOCLIB)
-LIBRARY=libhttp.a
+LIBRARY=libhttp.la
SRCS = simple_html.c simple_html2.c autosize_html.c forced_html.c html.c
# List of source, object and header files
SRCS=HTTP.c cookie.c
@@ -27,9 +27,8 @@
# targets to build
$(TARGET):: $(OBJS)
- $(RM) $@ \
- $(AR) $@ $(OBJS)
- $(RANLIB) $@
+ $(RM) $@
+ $(CC) -o $@ $(OBJS:.o=.lo) -rpath ${PREFIX}/lib -version-info 0:2
stamp-includes:
@if [ -d ../include ]; then set +x; \

View file

@ -1,11 +1,24 @@
--- ./examples/Imakefile.org Wed May 12 01:31:48 1999
+++ ./examples/Imakefile Wed May 12 02:04:00 1999
@@ -36,7 +36,7 @@
DEPLIBS = $(DEPXMLIB) $(DEPXTOOLLIB) $(DEPXLIB)
--- lib/Makefile.orig Wed Feb 3 19:43:26 1999
+++ lib/Makefile Tue Nov 2 01:28:54 1999
@@ -25,7 +25,7 @@
# Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. #
##############################################################################
#
-LIBRARY=libXmHTML.a
+LIBRARY=libXmHTML.la
XCOMM required libraries
-LOCAL_LIBRARIES = $(XMHTMLLIB) $(XMLIB) $(XTOOLLIB) $(XLIB) $(DMALLOCLIB)
+LOCAL_LIBRARIES = $(XMHTMLLIB) $(MOTIFLIB) $(XTOOLLIB) $(XLIB) $(DMALLOCLIB)
# Target to make
TARGET=$(LIBRARY)
@@ -44,9 +44,9 @@
@(set -x; cd common; $(MAKE) all $(pass_flags) )
XCOMM common routines for all examples
XCOMM
$(TARGET):: common $(PLATFORM)
- $(RM) $@ \
- $(AR) $@ common/*.o $(PLATFORM)/*.o
- $(RANLIB) $@
+ $(RM) $@
+ $(CC) -o $@ common/*.lo $(PLATFORM)/*.lo \
+ -rpath ${PREFIX}/lib -version-info 1:2
depend::
@( for dir in $(SUBDIRS) ; do \

View file

@ -1,11 +1,11 @@
--- ./tools/Imakefile.org Wed May 12 01:31:49 1999
+++ ./tools/Imakefile Wed May 12 02:04:11 1999
@@ -35,7 +35,7 @@
DEFAULT_LIBS =
--- tools/Makefile.orig Wed Feb 3 19:43:27 1999
+++ tools/Makefile Tue Nov 2 01:38:36 1999
@@ -88,7 +88,7 @@
XCOMM X libraries, required for reptype
-LOCAL_LIBRARIES = $(XMLIB) $(XTOOLLIB) $(XLIB) $(DMALLOCLIB) $(DEFAULT_LIBS)
+LOCAL_LIBRARIES = $(MOTIFLIB) $(XTOOLLIB) $(XLIB) $(DMALLOCLIB) $(DEFAULT_LIBS)
httpget:: httpget.o
$(RM) $@ \
- $(CC) -o $@ $(LDFLAGS) httpget.o -L../http -lhttp $(DMALLOCLIB)
+ $(CC) -o $@ $(LDFLAGS) httpget.o ../http/libhttp.la $(DMALLOCLIB)
#if (IHaveZLIB)
SRCS = GetRepTypes.c WidgetSize.c gifinfo.c ImBuffer.c parse.c gif2gzf.c \
# gif to gzf converter
gif2gzf:: gif2gzf.o LZWStream.o ImBuffer.o