Update to version 0.9.41.

PR:		11861
Submitted by:	Chris Piazza <cpiazza@home.net>
This commit is contained in:
Steve Price 1999-06-08 23:59:02 +00:00
parent 0c1b4fd6b0
commit 9789b00d07
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=19344
5 changed files with 35 additions and 49 deletions

View file

@ -1,12 +1,12 @@
# New ports collection makefile for: icewm
# Version required: 0.9.39
# Version required: 0.9.41
# Date created: 10 August 1997
# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
#
# $Id: Makefile,v 1.36 1999/05/16 23:20:18 mharo Exp $
# $Id: Makefile,v 1.37 1999/06/07 01:57:36 steve Exp $
#
DISTNAME= icewm-0.9.39
DISTNAME= icewm-0.9.41
CATEGORIES= x11-wm
MASTER_SITES= http://www.kiss.uni-lj.si/~k4fr0235/icewm/devel/ \
http://www.physik.TU-Berlin.DE/~ibex/ports/distfiles/icewm/
@ -19,39 +19,18 @@ LIB_DEPENDS= gnome.2:${PORTSDIR}/x11/gnomelibs
.endif
LIB_DEPENDS+= Xpm.4:${PORTSDIR}/graphics/xpm
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
ICEOPTION= --with-shape
.if defined(USE_I18N)
ICEOPTION+= --with-i18n
.endif
.if defined(XLOCALE)
ICEOPTION+= --with-xlocale
CONFIGURE_ARGS+= --enable-i18n
.endif
.if defined(GNOME)
ICEOPTION+= --with-imlib --with-gnome --with-sm
ICEOPTION+= --with-imlib --with-gnome
.endif
pre-patch:
.if defined(TITLE_BOTTOM)
@${PATCH} ${PATCH_ARGS} < ${FILESDIR}/patch-titlebottom
.else
@${PATCH} ${PATCH_ARGS} < ${FILESDIR}/patch-titletop
.endif
.if defined(GNOME)
@${PATCH} ${PATCH_ARGS} < ${FILESDIR}/patch-gnome
.endif
do-configure:
( cd ${WRKSRC}; env X11BASE="${X11BASE}" CXX="${CXX}" \
CXXFLAGS="${CXXFLAGS}" \
${SH} config ${ICEOPTION} )
post-install:
${INSTALL_DATA} ${FILESDIR}/bsd-daemon.xpm ${PREFIX}/share/icewm/taskbar
strip ${PREFIX}/bin/icewm
strip ${PREFIX}/bin/icewmbg
strip ${PREFIX}/bin/icewmhint
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (icewm-0.9.39.src.tar.gz) = 1a4d7bc60d6f6235d04a1c43bd739043
MD5 (icewm-0.9.41.src.tar.gz) = 05eccadc612fe3bb8d2d769c89da8771

View file

@ -1,17 +1,16 @@
--- install.inc.orig Sat Feb 20 08:33:06 1999
+++ install.inc Mon May 3 15:44:56 1999
@@ -1,10 +1,9 @@
-PREFIX = /usr/local
BINDIR = $(PREFIX)/bin
-LIBDIR = $(PREFIX)/lib/X11/icewm
-ETCDIR = /etc/X11/icewm
+LIBDIR = $(PREFIX)/share/icewm
+ETCDIR = $(LIBDIR)
--- install.in.orig Mon Jun 7 20:07:12 1999
+++ install.in Mon Jun 7 20:08:10 1999
@@ -3,11 +3,11 @@
INSTALL = install -c
-INSTALLDIR = $(INSTALL) -m 755 -d
-INSTALLBIN = $(INSTALL) -m 555
PREFIX = @prefix@
BINDIR = @bindir@
-LIBDIR = @libdir@/X11/icewm
+LIBDIR = @prefix@/share/icewm
ETCDIR = @sysconfdir@
INSTALL = @INSTALL@
-INSTALLDIR = @INSTALL@ -m 755 -d
+INSTALLDIR = mkdir -p
+INSTALLBIN = $(INSTALL) $(STRIP) -m 555
INSTALLLIB = $(INSTALL) -m 444
#INSTALLETC = $(INSTALL) -m 644
INSTALLBIN = @INSTALL_PROGRAM@
INSTALLLIB = @INSTALL_DATA@
#INSTALLETC = @INSTALL_DATA@

View file

@ -0,0 +1,14 @@
--- src/wmtaskbar.cc.orig Sun May 23 00:57:11 1999
+++ src/wmtaskbar.cc Sun May 23 00:57:25 1999
@@ -331,9 +331,9 @@
/** Use Linux 2.0 Penguin as start button */
#ifndef START_PIXMAP
-#define START_PIXMAP "linux.xpm"
+//#define START_PIXMAP "linux.xpm"
//#define START_PIXMAP "debian.xpm"
-//#define START_PIXMAP "bsd-daemon.xpm"
+#define START_PIXMAP "bsd-daemon.xpm"
//#define START_PIXMAP "start.xpm"
//#define START_PIXMAP "xfree86os2.xpm"
#endif

View file

@ -1,17 +1,11 @@
Window Manager designed for speed, usability and consistency.
When you want titlebars to be bottom ( default is top ),
% make -DTITLE_BOTTOM install
When you want gnome option,
% make -DGNOME install
When you want i18n option,
% make -DUSE_I18N install
When you want to compile with xlocale option,
% make -DXLOCALE install
'bsd-daemon.xpm' is from Steve Farrell.
WWW: http://www.kiss.uni-lj.si/~k4fr0235/icewm/