Update to 2.5.3

- Move USES upward
- Remove no-op MLINKS and create symlinks for manpages
- Sort INSTALLED_SCRIPTS
- Regenerate patch files with makepatch:

Changes:	https://www.ruby-lang.org/en/news/2018/10/18/ruby-2-5-3-released/
		https://www.ruby-lang.org/en/news/2018/10/17/ruby-2-5-2-released/
PR:		232431
Submitted by:	Yasuhiro KIMURA <yasu@utahime.org>
Security:	afc60484-0652-440e-b01a-5ef814747f06
MFH:		2018Q4
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2018-10-20 14:57:33 +00:00
parent 4adccb1351
commit 97a290bd3f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=482554
9 changed files with 36 additions and 52 deletions

View file

@ -174,8 +174,8 @@ RUBY24= "" # PLIST_SUB helpers
#
# Ruby 2.5
#
RUBY_RELVERSION= 2.5.1
RUBY_PORTREVISION= 5
RUBY_RELVERSION= 2.5.3
RUBY_PORTREVISION= 0
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 0
RUBY25= "" # PLIST_SUB helpers

View file

@ -23,6 +23,8 @@ BUILD_DEPENDS= libffi>=0:devel/libffi
LIB_DEPENDS= libyaml.so:textproc/libyaml
RUN_DEPENDS= libffi>=0:devel/libffi
USES= autoreconf cpe ssl tar:xz
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
--disable-rpath \
--enable-pthread \
@ -37,7 +39,6 @@ GNU_CONFIGURE= yes
# Keep this, else ruby will fail to load libraries dependent of libpthread.
LIBS+= -lpthread -L${LOCALBASE}/lib
USE_LDCONFIG= yes
USES= autoreconf cpe ssl tar:xz
WRKSRC= ${RUBY_WRKSRC}
RUBY_VER= 2.5
@ -110,14 +111,14 @@ MAKE_JOBS_UNSAFE= yes
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
MLINKS= ${RUBY_NAME}.1 ruby.1
PLIST_SUB+= IF_DEFAULT=""
.else
PKGNAMESUFFIX= ${RUBY_VER:C/\.//}
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
INSTALLED_SCRIPTS= irb erb rdoc ri ruby
INSTALLED_SCRIPTS= erb irb rdoc ri ruby
INSTALLED_MANUALS= erb irb ri ruby
EXTSAMPLES= bigdecimal/sample/*.rb
@ -167,13 +168,19 @@ pre-install-RDOC-on:
${MKDIR} ${STAGEDIR}${RUBY_SITERIDIR}
post-install:
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
#
# Link just installed "ruby" to "ruby25", etc.
#
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
. for FILE in ${INSTALLED_SCRIPTS}
${LN} -fs ${FILE}${RUBY_SUFFIX} ${STAGEDIR}${PREFIX}/bin/${FILE}
. endfor
#
# Link "ruby.1.gz" to "ruby25.1.gz", etc.
#
. for FILE in ${INSTALLED_MANUALS}
${LN} -fs ${FILE}${RUBY_SUFFIX}.1.gz ${STAGEDIR}${MANPREFIX}/man/man1/${FILE}.1.gz
. endfor
.endif
post-install-DEBUG-off:

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1522331706
SHA256 (ruby/ruby-2.5.1.tar.xz) = 886ac5eed41e3b5fc699be837b0087a6a5a3d10f464087560d2d21b3e71b754d
SIZE (ruby/ruby-2.5.1.tar.xz) = 11348108
TIMESTAMP = 1540022791
SHA256 (ruby/ruby-2.5.3.tar.xz) = 1cc9d0359a8ea35fc6111ec830d12e60168f3b9b305a3c2578357d360fcf306f
SIZE (ruby/ruby-2.5.3.tar.xz) = 11453336

View file

@ -1,6 +1,6 @@
--- configure.ac.orig 2018-01-04 02:12:16.000000000 +0800
+++ configure.ac 2018-07-19 14:45:11.636321000 +0800
@@ -2482,7 +2482,7 @@
--- configure.ac.orig 2018-01-03 18:12:16 UTC
+++ configure.ac
@@ -2482,7 +2482,7 @@ AS_IF([test "$ac_cv_func_qsort_r" != no]
AC_CACHE_CHECK(whether qsort_r is GNU version, rb_cv_gnu_qsort_r,
[AC_TRY_COMPILE([
@%:@include <stdlib.h>
@ -9,7 +9,7 @@
int (*compar)(const void *, const void *, void *),
void *arg);
],[ ],
@@ -2492,7 +2492,7 @@
@@ -2492,7 +2492,7 @@ void qsort_r(void *base, size_t nmemb, s
AC_CACHE_CHECK(whether qsort_r is BSD version, rb_cv_bsd_qsort_r,
[AC_TRY_COMPILE([
@%:@include <stdlib.h>
@ -18,7 +18,7 @@
void *arg, int (*compar)(void *, const void *, const void *));
],[ ],
[rb_cv_bsd_qsort_r=yes],
@@ -3245,7 +3245,7 @@
@@ -3245,7 +3245,7 @@ AS_IF([test "$with_dln_a_out" != yes], [
: ${LDSHARED='$(CC) -shared'}
AS_IF([test "$rb_cv_binary_elf" = yes], [
LDFLAGS="$LDFLAGS -rdynamic"
@ -27,7 +27,7 @@
], [
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
])
@@ -3724,6 +3723,7 @@
@@ -3724,6 +3724,7 @@ AS_CASE("$enable_shared", [yes], [
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).$(SOEXT).$(MAJOR)$(MINOR)'
LIBRUBY_SONAME='$(LIBRUBY_SO)'

View file

@ -1,28 +0,0 @@
From 75de15ddcdab6efe7faf3ca1f6b5c6e5b6ba57cc Mon Sep 17 00:00:00 2001
From: Kazuki Yamaguchi <k@rhe.jp>
Date: Sat, 24 Mar 2018 01:44:37 +0900
Subject: [PATCH] extconf.rb: fix build with LibreSSL 2.7.0
Our compat implementation of accessor functions that were introduced in
OpenSSL 1.1.0 conflicts with those from LibreSSL 2.7.0. Use the
HAVE_OPAQUE_OPENSSL code path when LibreSSL 2.7 or newer is detected.
Fix suggested by Joel Sing.
Fixes: https://github.com/ruby/openssl/issues/192
--- ext/openssl/extconf.rb.orig
+++ ext/openssl/extconf.rb
@@ -157,8 +157,11 @@ def find_openssl_library
have_func("SSL_is_server")
# added in 1.1.0
+if !have_struct_member("SSL", "ctx", "openssl/ssl.h") ||
+ try_static_assert("LIBRESSL_VERSION_NUMBER >= 0x2070000fL", "openssl/opensslv.h")
+ $defs.push("-DHAVE_OPAQUE_OPENSSL")
+end
have_func("CRYPTO_lock") || $defs.push("-DHAVE_OPENSSL_110_THREADING_API")
-have_struct_member("SSL", "ctx", "openssl/ssl.h") || $defs.push("-DHAVE_OPAQUE_OPENSSL")
have_func("BN_GENCB_new")
have_func("BN_GENCB_free")
have_func("BN_GENCB_get_arg")

View file

@ -1,6 +1,6 @@
--- lib/mkmf.rb.orig 2015-12-16 09:25:48 UTC
--- lib/mkmf.rb.orig 2018-10-09 14:09:35 UTC
+++ lib/mkmf.rb
@@ -235,7 +235,7 @@ module MakeMakefile
@@ -234,7 +234,7 @@ module MakeMakefile
end
$extmk ||= false
if not $extmk and File.exist?(($hdrdir = RbConfig::CONFIG["rubyhdrdir"]) + "/ruby/ruby.h")

View file

@ -1,6 +1,6 @@
--- ./lib/rdoc/generator/json_index.rb.orig 2017-11-12 19:37:25.144883000 -0500
+++ ./lib/rdoc/generator/json_index.rb 2017-11-12 19:37:44.551836000 -0500
@@ -175,7 +175,7 @@
--- lib/rdoc/generator/json_index.rb.orig 2017-11-27 10:45:24 UTC
+++ lib/rdoc/generator/json_index.rb
@@ -175,7 +175,7 @@ class RDoc::Generator::JsonIndex
debug_msg "Writing gzipped search index to %s" % outfile
Zlib::GzipWriter.open(outfile) do |gz|
@ -9,7 +9,7 @@
gz.orig_name = search_index_file.basename.to_s
gz.write search_index
gz.close
@@ -193,7 +193,7 @@
@@ -193,7 +193,7 @@ class RDoc::Generator::JsonIndex
debug_msg "Writing gzipped file to %s" % outfile
Zlib::GzipWriter.open(outfile) do |gz|

View file

@ -1,6 +1,6 @@
--- tool/mkconfig.rb.orig 2015-12-09 20:53:21 UTC
--- tool/mkconfig.rb.orig 2017-05-02 12:45:07 UTC
+++ tool/mkconfig.rb
@@ -168,8 +168,9 @@ def vars.expand(val, config = self)
@@ -157,8 +157,9 @@ def vars.expand(val, config = self)
val.replace(newval) unless newval == val
val
end
@ -11,4 +11,4 @@
+rubyarchdir = "/lib/ruby/#{major}.#{minor}/#{arch}"
relative_archdir = rubyarchdir.rindex(prefix, 0) ? rubyarchdir[prefix.size..-1] : rubyarchdir
puts %[\
# frozen-string-literal: false
# encoding: ascii-8bit

View file

@ -876,9 +876,13 @@ lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
%%RUBY_LIBDIR%%/yaml/dbm.rb
%%RUBY_LIBDIR%%/yaml/store.rb
libdata/pkgconfig/ruby-%%RUBY_VER%%.pc
%%IF_DEFAULT%%man/man1/erb.1.gz
man/man1/erb%%RUBY_SUFFIX%%.1.gz
%%IF_DEFAULT%%man/man1/irb.1.gz
man/man1/irb%%RUBY_SUFFIX%%.1.gz
%%IF_DEFAULT%%man/man1/ri.1.gz
man/man1/ri%%RUBY_SUFFIX%%.1.gz
%%IF_DEFAULT%%man/man1/ruby.1.gz
man/man1/%%RUBY_NAME%%.1.gz
%%DOCS%%%%RUBY_DOCDIR%%/COPYING
%%DOCS%%%%RUBY_DOCDIR%%/COPYING.ja
@ -4013,6 +4017,7 @@ man/man1/%%RUBY_NAME%%.1.gz
%%CAPIDOCS%%%%RUBY_DOCDIR%%/capi/html/de/d38/symbol_8h__dep__incl.map
%%CAPIDOCS%%%%RUBY_DOCDIR%%/capi/html/de/d38/symbol_8h__dep__incl.md5
%%CAPIDOCS%%%%RUBY_DOCDIR%%/capi/html/de/d38/symbol_8h__dep__incl.png
%%CAPIDOCS%%%%RUBY_DOCDIR%%/capi/html/de/d3c/structselect__set.html
%%CAPIDOCS%%%%RUBY_DOCDIR%%/capi/html/de/d40/structcls__struct__12byte.html
%%CAPIDOCS%%%%RUBY_DOCDIR%%/capi/html/de/d43/group__embed.html
%%CAPIDOCS%%%%RUBY_DOCDIR%%/capi/html/de/d43/group__embed.map