- Move from Tk 8.2 to Tk 8.4
PR: ports/110429 Submitted by: Martin Tournoij <carpetsmoker@xs4all.nl> Approved by: maintainer timeout (fenner; 1 year)
This commit is contained in:
parent
7cbc70d188
commit
97b94804d5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=210504
6 changed files with 36 additions and 16 deletions
|
@ -7,8 +7,8 @@
|
|||
|
||||
PORTNAME= imm
|
||||
PORTVERSION= 3.5a1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= mbone tk82
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= mbone tk84
|
||||
MASTER_SITES= ftp://ftp.hawaii.edu/paccom/imm-3.5a1/
|
||||
DISTNAME= imm.source
|
||||
EXTRACT_SUFX= .tar.Z
|
||||
|
@ -16,10 +16,8 @@ EXTRACT_SUFX= .tar.Z
|
|||
MAINTAINER= fenner@FreeBSD.org
|
||||
COMMENT= Internet Image(or other data) Multicaster (and receiver)
|
||||
|
||||
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
|
||||
|
||||
USE_TK= yes
|
||||
WRKSRC= ${WRKDIR}/mnm
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
# Some versions of make, like SGI's, use the following variable to
|
||||
# determine which shell to use for executing commands:
|
||||
SHELL = /bin/sh
|
||||
INCLUDE_DIR = -I${PREFIX}/include -I${LOCALBASE}/include/tcl8.2 -I${LOCALBASE}/include/tk8.2
|
||||
INCLUDE_DIR = -I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4 -I${X11BASE}/include
|
||||
# Libraries to use when linking:
|
||||
LIBS = -lm
|
||||
|
||||
TKLIBS= -L$(PREFIX)/lib -L${LOCALBASE}/lib -ltk82 -ltcl82 -lX11
|
||||
TKLIBS= -L${X11BASE}/lib -L$(PREFIX)/lib -L${LOCALBASE}/lib -ltk84 -ltcl84 -lX11
|
||||
|
||||
TARGET = ../freebsd
|
||||
|
||||
CFLAGS = -g -DSIG_T=void -DMULTICAST -I. -DERROR_TEST
|
||||
|
||||
CC = gcc
|
||||
CC ?= gcc
|
||||
CC_SWITCHES = ${CFLAGS}
|
||||
|
||||
ROBJS = protocol.o utils.o
|
||||
|
|
12
mbone/imm/files/patch-src-tkAppInit.c
Normal file
12
mbone/imm/files/patch-src-tkAppInit.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/tkAppInit.c.orig Thu Mar 15 10:00:05 2007
|
||||
+++ src/tkAppInit.c Thu Mar 15 10:00:12 2007
|
||||
@@ -97,9 +97,6 @@
|
||||
* Sun shared libraries to be used for Tcl.
|
||||
*/
|
||||
|
||||
-extern int matherr();
|
||||
-void GetDspStatus();
|
||||
-int *tclDummyMathPtr = (int *) matherr;
|
||||
|
||||
/***************************************************************************/
|
||||
/* fork and initiate server process */
|
|
@ -7,8 +7,8 @@
|
|||
|
||||
PORTNAME= imm
|
||||
PORTVERSION= 3.5a1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= mbone tk82
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= mbone tk84
|
||||
MASTER_SITES= ftp://ftp.hawaii.edu/paccom/imm-3.5a1/
|
||||
DISTNAME= imm.source
|
||||
EXTRACT_SUFX= .tar.Z
|
||||
|
@ -16,10 +16,8 @@ EXTRACT_SUFX= .tar.Z
|
|||
MAINTAINER= fenner@FreeBSD.org
|
||||
COMMENT= Internet Image(or other data) Multicaster (and receiver)
|
||||
|
||||
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
|
||||
|
||||
USE_TK= yes
|
||||
WRKSRC= ${WRKDIR}/mnm
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
# Some versions of make, like SGI's, use the following variable to
|
||||
# determine which shell to use for executing commands:
|
||||
SHELL = /bin/sh
|
||||
INCLUDE_DIR = -I${PREFIX}/include -I${LOCALBASE}/include/tcl8.2 -I${LOCALBASE}/include/tk8.2
|
||||
INCLUDE_DIR = -I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4 -I${X11BASE}/include
|
||||
# Libraries to use when linking:
|
||||
LIBS = -lm
|
||||
|
||||
TKLIBS= -L$(PREFIX)/lib -L${LOCALBASE}/lib -ltk82 -ltcl82 -lX11
|
||||
TKLIBS= -L${X11BASE}/lib -L$(PREFIX)/lib -L${LOCALBASE}/lib -ltk84 -ltcl84 -lX11
|
||||
|
||||
TARGET = ../freebsd
|
||||
|
||||
CFLAGS = -g -DSIG_T=void -DMULTICAST -I. -DERROR_TEST
|
||||
|
||||
CC = gcc
|
||||
CC ?= gcc
|
||||
CC_SWITCHES = ${CFLAGS}
|
||||
|
||||
ROBJS = protocol.o utils.o
|
||||
|
|
12
net/imm/files/patch-src-tkAppInit.c
Normal file
12
net/imm/files/patch-src-tkAppInit.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/tkAppInit.c.orig Thu Mar 15 10:00:05 2007
|
||||
+++ src/tkAppInit.c Thu Mar 15 10:00:12 2007
|
||||
@@ -97,9 +97,6 @@
|
||||
* Sun shared libraries to be used for Tcl.
|
||||
*/
|
||||
|
||||
-extern int matherr();
|
||||
-void GetDspStatus();
|
||||
-int *tclDummyMathPtr = (int *) matherr;
|
||||
|
||||
/***************************************************************************/
|
||||
/* fork and initiate server process */
|
Loading…
Reference in a new issue